aboutsummaryrefslogtreecommitdiff
path: root/www/hiawatha
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2016-04-24 10:22:47 +0000
committerLars Engels <lme@FreeBSD.org>2016-04-24 10:22:47 +0000
commit8923875bb74ad25213b2a09b7ebe2502688ee629 (patch)
tree9f90a1a3c699c5375a273ef96af63988806aef87 /www/hiawatha
parentaa0f1a4c36172aedd89e6b9176bce382f71c955a (diff)
downloadports-8923875bb74ad25213b2a09b7ebe2502688ee629.tar.gz
ports-8923875bb74ad25213b2a09b7ebe2502688ee629.zip
Notes
Diffstat (limited to 'www/hiawatha')
-rw-r--r--www/hiawatha/Makefile1
-rw-r--r--www/hiawatha/files/patch-src__http.c13
2 files changed, 14 insertions, 0 deletions
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index d2323520f697..6f9204a88763 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hiawatha
PORTVERSION= 10.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://www.hiawatha-webserver.org/files/
diff --git a/www/hiawatha/files/patch-src__http.c b/www/hiawatha/files/patch-src__http.c
new file mode 100644
index 000000000000..b87664ba8b74
--- /dev/null
+++ b/www/hiawatha/files/patch-src__http.c
@@ -0,0 +1,13 @@
+--- src/http.c.orig 2015-12-28 15:05:15 UTC
++++ src/http.c
+@@ -845,8 +845,8 @@ int last_forwarded_ip(t_http_header *htt
+ /* Forwarded header
+ */
+ begin = NULL;
+- while ((forwarded = strcasestr(forwarded, "for=")) == NULL) {
+- begin = forwarded;
++ while ((forwarded = strcasestr(forwarded, "for=")) != NULL) {
++ begin = forwarded + 4;
+ forwarded++;
+ }
+