aboutsummaryrefslogtreecommitdiff
path: root/www/horde-base
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-06 11:34:39 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-06 11:34:39 +0000
commitd10990107b2981488952b1ba378611b4272ca299 (patch)
treedf626357be38a033083499e7c3bb8cf75a867973 /www/horde-base
parent6f29a39440cd1d44b7ef8381bd72eea153efbb03 (diff)
downloadports-d10990107b2981488952b1ba378611b4272ca299.tar.gz
ports-d10990107b2981488952b1ba378611b4272ca299.zip
Notes
Diffstat (limited to 'www/horde-base')
-rw-r--r--www/horde-base/Makefile71
-rw-r--r--www/horde-base/files/httpd.conf.horde57
-rw-r--r--www/horde-base/files/pkg-message.in6
-rw-r--r--www/horde-base/pkg-plist2
4 files changed, 19 insertions, 117 deletions
diff --git a/www/horde-base/Makefile b/www/horde-base/Makefile
index 0d8a4c7c83c2..4536d3060587 100644
--- a/www/horde-base/Makefile
+++ b/www/horde-base/Makefile
@@ -7,6 +7,7 @@
PORTNAME= horde
DISTVERSION= 3.1.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= HORDE
PKGNAMESUFFIX= -base
@@ -80,7 +81,6 @@ RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
CONFLICTS= horde-2.*
NO_BUILD= yes
-USE_APACHE= 1.3+
USE_GETTEXT= yes # Already implied by USE_PHP =gettext, to pet portlint
USE_PHP= ctype gettext session
SUB_FILES= pkg-message pkg-deinstall pkg-install
@@ -206,16 +206,14 @@ SUB_DIRS= admin config js lib locale po scripts services templates themes util
LHORDEDIR?= www/horde
LHORDESBIN?= sbin
-PLIST_SUB= HORDEDIR=${LHORDEDIR} HORDESBIN=${LHORDESBIN} \
- HORDE_INC=${LHORDE_INC}
-SUB_LIST+= HORDEDIR=${HORDEDIR} APACHE_CONF=${APACHE_CONF} \
- HORDESBIN=${HORDESBIN} HORDEADMUSR=${HORDEADMUSR} HORDEGRP=${WWWGRP}
+PLIST_SUB= HORDEDIR=${LHORDEDIR} HORDESBIN=${LHORDESBIN}
+SUB_LIST+= HORDEDIR=${HORDEDIR} HORDESBIN=${HORDESBIN} \
+ HORDEADMUSR=${HORDEADMUSR} HORDEGRP=${WWWGRP}
HORDEDIR= ${PREFIX}/${LHORDEDIR}
HORDESBIN= ${PREFIX}/${LHORDESBIN}
CONFDIR= ${HORDEDIR}/config
-APACHE_CONF= ${APACHE_CNFDIR}/httpd.conf
PEARDIR?= ${LOCALBASE}/share/pear
LOG_FILE?= /var/log/horde.log
@@ -235,35 +233,13 @@ USE_PHP+= mcal
. endif
.endif
-.if ${APACHE_VERSION} >= 20
-APACHE_CNFDIR= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}
-HORDE_INC= ${APACHE_CNFDIR}/Includes
-LHORDE_INC= ${HORDE_INC:S|^${LOCALBASE}/||}
-PLIST_SUB+= RMDIRINC="@comment "
-.else
-APACHE_CNFDIR= ${LOCALBASE}/etc/apache
-HORDE_INC= ${PREFIX}/etc/horde
-LHORDE_INC= ${HORDE_INC:S|^${PREFIX}/||}
-PLIST_SUB+= RMDIRINC=""
-.endif
-
post-extract:
@${MV} ${WRKSRC}/README ${WRKSRC}/docs/
pre-configure:
@${RM} ${PATCHES2RM:S|^|${WRKSRC}/|:S|$|.orig|}
- @${SED} -e "s:/home/httpd/html/horde:${HORDEDIR}:" \
- -e "s:php_value auto_prepend_file:# php_value auto_prepend_file:" \
- -e "s:/home/httpd/phplib:${PEARDIR}:" \
- ${FILESDIR}/httpd.conf.horde > ${WRKDIR}/httpd-horde.conf
-.if ${PHP_VER} == 5
- @${REINPLACE_CMD} -e "s:mod_php4.c:mod_php5.c:" ${WRKDIR}/httpd-horde.conf
-.endif
-.if ${APACHE_VERSION} >= 22
- @${REINPLACE_CMD} -e "s:IfModule mod_\([^ ]*\)\.c:IfModule \1_module:" \
- ${WRKDIR}/httpd-horde.conf
-.endif
- @${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" ${WRKSRC}/config/mime_drivers.php.dist
+ @${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:"\
+ ${WRKSRC}/config/mime_drivers.php.dist
.if !defined(WITHOUT_X11)
. if !defined(WITHOUT_WV)
@${REINPLACE_CMD} -e "s://UNCOMMENTIFWV::" ${WRKSRC}/config/mime_drivers.php.dist
@@ -335,31 +311,22 @@ pre-install:
do-install:
@${MKDIR} ${HORDEDIR}
-.for REP in ${SUB_DIRS}
- @${CP} -Rp ${WRKSRC}/${REP} ${HORDEDIR}
-.endfor
+ @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${HORDEDIR}/
@${CP} -p ${WRKSRC}/*.php ${HORDEDIR}
-
@${CP} ${WRKSRC}/scripts/set_perms.sh ${HORDESBIN}/horde_set_perms.sh
@${CHMOD} u+x ${HORDESBIN}/horde_set_perms.sh
-.if ${APACHE_VERSION} >= 20
- ${INSTALL_DATA} ${WRKDIR}/httpd-horde.conf ${HORDE_INC}
-.else
- @${MKDIR} ${HORDE_INC}
- @${INSTALL_DATA} ${WRKDIR}/httpd-horde.conf ${HORDE_INC}
-. if !defined(PACKAGE_BUILDING)
- @(if [ -f ${APACHE_CONF} ] ; then \
- ${ECHO_MSG} "===> Updating ${APACHE_CONF}..." ; \
- ${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
- ${ECHO_CMD} "# Horde's include directory" >> ${APACHE_CONF} ; \
- ${ECHO_CMD} "Include ${HORDE_INC}" >> ${APACHE_CONF} ; \
- fi)
-. endif
-.endif
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${HORDEDIR}
- @${CHMOD} -R o-rwx ${CONFDIR}
- @${TOUCH} ${LOG_FILE}
- @${CHOWN} ${WWWOWN}:${WWWGRP} ${LOG_FILE}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${HORDEDIR}/
+ @${CHMOD} -R o-rwx ${HORDEDIR}/
+ ${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP}\
+ %D/${HORDEDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ ${ECHO_CMD} @exec ${CHMOD} -R o-rwx\
+ %D/${HORDEDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ ${TOUCH} ${LOG_FILE}
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${LOG_FILE}
+ ${ECHO_CMD} "@exec ${TOUCH} ${LOG_FILE};${CHOWN} ${WWWOWN}:${WWWGRP} ${LOG_FILE}"\
+ >> ${TMPPLIST}
+ ${ECHO_CMD} "@unexec if [ ! -s ${LOG_FILE} ];then ${RM} -f ${LOG_FILE};fi"\
+ >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${INSTALL} -d ${DOCSDIR}/
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
diff --git a/www/horde-base/files/httpd.conf.horde b/www/horde-base/files/httpd.conf.horde
index 0bd4b621c52b..e69de29bb2d1 100644
--- a/www/horde-base/files/httpd.conf.horde
+++ b/www/horde-base/files/httpd.conf.horde
@@ -1,57 +0,0 @@
-# This is included in Apache's httpd.conf for Horde
-
-<Directory /home/httpd/html/horde>
- Options Indexes FollowSymLinks
- AllowOverride None
- order allow,deny
- allow from all
- <IfModule mod_php4.c>
- php_value include_path '/home/httpd/phplib:.'
- php_flag register_globals On
- php_flag magic_quotes_gpc Off
- php_flag track_vars On
- php_value memory_limit 16M
- </IfModule>
-</Directory>
-
-<IfModule mod_alias.c>
- Alias /horde/ "/home/httpd/html/horde/"
-</IfModule>
-#
-# For security, don't serve pages from the Horde configuration and library
-# directories.
-#
-#<Directory "/home/httpd/html/horde/admin">
-# Order deny,allow
-# Deny from all
-#</Directory>
-<Directory "/home/httpd/html/horde/config">
- Order deny,allow
- Deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/lib">
- Order deny,allow
- Deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/locale">
- Order deny,allow
- Deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/po">
- Order deny,allow
- Deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/scripts">
- Order deny,allow
- Deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/templates">
- Order deny,allow
- Deny from all
-</Directory>
-<Directory "/home/httpd/html/horde/util">
- Order deny,allow
- Deny from all
-</Directory>
-# End of Horde configuration ================
-
diff --git a/www/horde-base/files/pkg-message.in b/www/horde-base/files/pkg-message.in
index 3226c28ff455..6620f9f27fe1 100644
--- a/www/horde-base/files/pkg-message.in
+++ b/www/horde-base/files/pkg-message.in
@@ -27,14 +27,8 @@ Select a log driver; if you keep 'file', do not forget to add a line
in /etc/newsyslog.conf.
Then select and configure a preferences driver.
-Your %%APACHE_CONF%% has been updated,
-you have to restart Apache.
-
When everything is OK, you should be able to access Horde from
<http://localhost/horde/>.
-(If <http://localhost/horde/> does not run, but
- <http://localhost/horde/index.php> is OK, then you have
- to define index.php as a DirectoryIndex in %%APACHE_CONF%%.)
There is a testing script at <http://localhost/horde/test.php>.
************************************************************************
diff --git a/www/horde-base/pkg-plist b/www/horde-base/pkg-plist
index 56e576ba48d9..29e0d333d896 100644
--- a/www/horde-base/pkg-plist
+++ b/www/horde-base/pkg-plist
@@ -1,4 +1,3 @@
-%%HORDE_INC%%/httpd-horde.conf
%%HORDESBIN%%/horde_set_perms.sh
%%HORDEDIR%%/admin/cmdshell.php
%%HORDEDIR%%/admin/datatree.php
@@ -1714,4 +1713,3 @@
@dirrm %%HORDEDIR%%/admin/locale
@dirrm %%HORDEDIR%%/admin
@dirrmtry %%HORDEDIR%%
-%%RMDIRINC%%@dirrmtry %%HORDE_INC%%