aboutsummaryrefslogtreecommitdiff
path: root/www/horde2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 23:15:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 23:15:39 +0000
commit2d704fa337f2155224beb87cb9e1b2495cfc8601 (patch)
treebcf81475862807650ad15a905af525d99bd17ceb /www/horde2
parentf621617ff6d32311ab35c0ad9cb7d4f6fc026640 (diff)
downloadports-2d704fa337f2155224beb87cb9e1b2495cfc8601.tar.gz
ports-2d704fa337f2155224beb87cb9e1b2495cfc8601.zip
Notes
Diffstat (limited to 'www/horde2')
-rw-r--r--www/horde2/Makefile10
-rw-r--r--www/horde2/distinfo2
-rw-r--r--www/horde2/files/patch-ac110
-rw-r--r--www/horde2/files/patch-lib_Horde.php22
-rw-r--r--www/horde2/pkg-plist12
5 files changed, 58 insertions, 98 deletions
diff --git a/www/horde2/Makefile b/www/horde2/Makefile
index 74dc4f459835..b07c56172b5f 100644
--- a/www/horde2/Makefile
+++ b/www/horde2/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= horde
-PORTVERSION= 2.2.3
-PORTREVISION= 3
+PORTVERSION= 2.2.4
+PORTREVISION= 0
CATEGORIES= www
MASTER_SITES= ftp://ftp.horde.org/pub/horde/ \
ftp://ftp.au.horde.org/pub/horde/ \
@@ -15,12 +15,15 @@ MASTER_SITES= ftp://ftp.horde.org/pub/horde/ \
ftp://ftp.it.horde.org/pub/mirror/horde.org/horde/ \
ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/horde/ \
ftp://ftp.pt.horde.org/pub/horde-ftp/horde/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-RC2
MAINTAINER= thierry@pompo.net
COMMENT= A common code-base used by Horde applications, written in PHP
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
#-----------------------------------------------------------------------
-# You may define these options:
+# You may define this option:
#
# - WITHOUT_SUPPORTED_DB: if you run a database not in the ports tree;
#
@@ -123,7 +126,6 @@ pre-install:
post-patch:
@${RM} ${WRKSRC}/po/translation.php.orig
- @${RM} ${WRKSRC}/lib/Horde.php.orig
@${RM} ${WRKSRC}/scripts/db/README.orig
@${RM} ${WRKSRC}/scripts/set_perms.sh.orig
@${RM} ${WRKSRC}/config/horde.php.dist.orig
diff --git a/www/horde2/distinfo b/www/horde2/distinfo
index a3f3a9d318d9..2d3a364780f4 100644
--- a/www/horde2/distinfo
+++ b/www/horde2/distinfo
@@ -1 +1 @@
-MD5 (horde-2.2.3.tar.gz) = 27e5c190a6a22a6aa2201e6b714a653d
+MD5 (horde-2.2.4-RC2.tar.gz) = 90e8eb3fac042ead2c55a6ab04d266b8
diff --git a/www/horde2/files/patch-ac b/www/horde2/files/patch-ac
index 1b5a2da2db3e..a44be2f27a84 100644
--- a/www/horde2/files/patch-ac
+++ b/www/horde2/files/patch-ac
@@ -1,5 +1,5 @@
---- config/registry.php.dist.orig Mon Dec 30 02:26:06 2002
-+++ config/registry.php.dist Thu Jan 16 23:02:48 2003
+--- config/registry.php.dist.orig Tue May 6 14:28:01 2003
++++ config/registry.php.dist Sat Aug 9 15:09:34 2003
@@ -20,8 +20,8 @@
* IMP handle the authentication for Horde. This avoids the
* "double login" while accessing IMP.
@@ -11,37 +11,24 @@
/* mail: Handler for sending mail. */
$this->registry['mail']['compose'] = 'imp';
-@@ -45,12 +45,29 @@
- $this->registry['memos']['show'] = 'mnemo';
- $this->registry['memos']['add'] = 'mnemo';
+@@ -33,11 +33,11 @@
+ $this->registry['contacts']['sources'] = 'turba';
+ $this->registry['contacts']['fields'] = 'turba';
+ /* These handlers are available with Turba 1.2 */
+-// $this->registry['contacts']['add_field'] = 'turba';
+-// $this->registry['contacts']['delete_field'] = 'turba';
+-// $this->registry['contacts']['get_field'] = 'turba';
+-// $this->registry['contacts']['list_field'] = 'turba';
+-// $this->registry['contacts']['import_vcard'] = 'turba';
++//UNCOMMENTWHENINSTTURBA $this->registry['contacts']['add_field'] = 'turba';
++//UNCOMMENTWHENINSTTURBA $this->registry['contacts']['delete_field'] = 'turba';
++//UNCOMMENTWHENINSTTURBA $this->registry['contacts']['get_field'] = 'turba';
++//UNCOMMENTWHENINSTTURBA $this->registry['contacts']['list_field'] = 'turba';
++//UNCOMMENTWHENINSTTURBA $this->registry['contacts']['import_vcard'] = 'turba';
-+//$this->registry['publickey']['add'] = 'turba';
-+//$this->registry['publickey']['delete'] = 'turba';
-+//$this->registry['publickey']['get'] = 'turba';
-+//$this->registry['publickey']['list'] = 'turba';
-+
-+/* memos: Handler for memos/notepad. */
-+$this->registry['memos']['search'] = 'mnemo';
-+$this->registry['memos']['list'] = 'mnemo';
-+$this->registry['memos']['show'] = 'mnemo';
-+$this->registry['memos']['add'] = 'mnemo';
-+
-+/* nic: network utilities */
-+$this->registry['net']['finger'] = 'nic';
-+
- /* tasks: Handler for todo lists. */
- $this->registry['tasks']['search'] = 'nag';
- $this->registry['tasks']['list'] = 'nag';
- $this->registry['tasks']['show'] = 'nag';
- $this->registry['tasks']['add'] = 'nag';
-
-+/* whups: bugs reports */
-+$this->registry['projects']['list'] = 'whups';
-+$this->registry['projects']['add'] = 'whups';
-
- /**
- * Application registry
-@@ -100,68 +117,122 @@
+ /* events: Handler for events. */
+ $this->registry['events']['show'] = 'kronolith';
+@@ -111,78 +111,95 @@
'status' => 'notoolbar'
);
@@ -54,6 +41,15 @@
- 'status' => 'inactive'
-);
-
+-$this->applications['ingo'] = array(
+- 'fileroot' => dirname(__FILE__) . '/../ingo',
+- 'webroot' => $this->applications['horde']['webroot'] . '/ingo',
+- 'icon' => $this->applications['horde']['webroot'] . '/ingo/graphics/ingo.gif',
+- 'name' => _("Filters"),
+- 'allow_guests' => false,
+- 'status' => 'inactive'
+-);
+-
-$this->applications['turba'] = array(
- 'fileroot' => dirname(__FILE__) . '/../turba',
- 'webroot' => $this->applications['horde']['webroot'] . '/turba',
@@ -107,6 +103,7 @@
- 'allow_guests' => false,
- 'status' => 'inactive'
-);
+-
+//UNCOMMENTWHENINSTIMP$this->applications['imp'] = array(
+//UNCOMMENTWHENINSTIMP 'fileroot' => dirname(__FILE__) . '/../imp',
+//UNCOMMENTWHENINSTIMP 'webroot' => $this->applications['horde']['webroot'] . '/imp',
@@ -116,6 +113,15 @@
+//UNCOMMENTWHENINSTIMP 'status' => 'active'
+//UNCOMMENTWHENINSTIMP);
+
++//UNCOMMENTWHENINSTINGO$this->applications['ingo'] = array(
++//UNCOMMENTWHENINSTINGO 'fileroot' => dirname(__FILE__) . '/../ingo',
++//UNCOMMENTWHENINSTINGO 'webroot' => $this->applications['horde']['webroot'] . '/ingo',
++//UNCOMMENTWHENINSTINGO 'icon' => $this->applications['horde']['webroot'] . '/ingo/graphics/ingo.gif',
++//UNCOMMENTWHENINSTINGO 'name' => _("Filters"),
++//UNCOMMENTWHENINSTINGO 'allow_guests' => false,
++//UNCOMMENTWHENINSTINGO 'status' => 'active'
++//UNCOMMENTWHENINSTINGO);
++
+//UNCOMMENTWHENINSTTURBA$this->applications['turba'] = array(
+//UNCOMMENTWHENINSTTURBA 'fileroot' => dirname(__FILE__) . '/../turba',
+//UNCOMMENTWHENINSTTURBA 'webroot' => $this->applications['horde']['webroot'] . '/turba',
@@ -170,15 +176,6 @@
+//UNCOMMENTWHENINSTKLUTZ 'status' => 'active'
+//UNCOMMENTWHENINSTKLUTZ);
+
-+//UNCOMMENTWHENINSTGOLLEM$this->applications['gollem'] = array(
-+//UNCOMMENTWHENINSTGOLLEM 'fileroot' => dirname(__FILE__) . '/../gollem',
-+//UNCOMMENTWHENINSTGOLLEM 'webroot' => '/horde/gollem',
-+//UNCOMMENTWHENINSTGOLLEM 'icon' => '/horde/gollem/graphics/gollem.gif',
-+//UNCOMMENTWHENINSTGOLLEM 'name' => _("FTP"),
-+//UNCOMMENTWHENINSTGOLLEM 'allow_guests' => false,
-+//UNCOMMENTWHENINSTGOLLEM 'status' => 'active'
-+//UNCOMMENTWHENINSTGOLLEM);
-+
+//UNCOMMENTWHENINSTNIC$this->applications['nic'] = array(
+//UNCOMMENTWHENINSTNIC 'fileroot' => dirname(__FILE__) . '/../nic',
+//UNCOMMENTWHENINSTNIC 'webroot' => '/horde/nic',
@@ -196,37 +193,10 @@
+//UNCOMMENTWHENINSTJONAH 'allow_guests' => true,
+//UNCOMMENTWHENINSTJONAH 'status' => 'active'
+//UNCOMMENTWHENINSTJONAH);
-+
-+//UNCOMMENTWHENINSTTROLL$this->applications['troll'] = array(
-+//UNCOMMENTWHENINSTTROLL 'fileroot' => dirname(__FILE__) . '/../troll',
-+//UNCOMMENTWHENINSTTROLL 'webroot' => '/horde/troll',
-+//UNCOMMENTWHENINSTTROLL 'icon' => '/horde/troll/graphics/troll.gif',
-+//UNCOMMENTWHENINSTTROLL 'name' => _("News"),
-+//UNCOMMENTWHENINSTTROLL 'allow_guests' => false,
-+//UNCOMMENTWHENINSTTROLL 'status' => 'active'
-+//UNCOMMENTWHENINSTTROLL);
-+
-+//UNCOMMENTWHENINSTBABEL$this->applications['babel'] = array(
-+//UNCOMMENTWHENINSTBABEL 'fileroot' => dirname(__FILE__) . '/../babel',
-+//UNCOMMENTWHENINSTBABEL 'webroot' => $this->applications['horde']['webroot'] . '/babel',
-+//UNCOMMENTWHENINSTBABEL 'icon' => $this->applications['horde']['webroot'] . '/babel/graphics/babel.gif',
-+//UNCOMMENTWHENINSTBABEL 'name' => _("i18n"),
-+//UNCOMMENTWHENINSTBABEL 'allow_guests' => false,
-+//UNCOMMENTWHENINSTBABEL 'status' => 'active'
-+//UNCOMMENTWHENINSTBABEL);
-+
-+//UNCOMMENTWHENINSTWHUPS$this->applications['whups'] = array(
-+//UNCOMMENTWHENINSTWHUPS 'fileroot' => dirname(__FILE__) . '/../whups',
-+//UNCOMMENTWHENINSTWHUPS 'webroot' => '/horde/whups',
-+//UNCOMMENTWHENINSTWHUPS 'icon' => '/horde/whups/graphics/whups.gif',
-+//UNCOMMENTWHENINSTWHUPS 'name' => _("Bugs"),
-+//UNCOMMENTWHENINSTWHUPS 'allow_guests' => false,
-+//UNCOMMENTWHENINSTWHUPS 'status' => 'active'
-+//UNCOMMENTWHENINSTWHUPS);
-
/**
-@@ -303,6 +374,29 @@
+ * Service registry
+@@ -326,6 +343,29 @@
$this->services['nag']['horde']['summary'] = array(
'file' => '%application%/lib/api.php',
'function' => 'nagSummary',
diff --git a/www/horde2/files/patch-lib_Horde.php b/www/horde2/files/patch-lib_Horde.php
deleted file mode 100644
index f19d1cad4b2a..000000000000
--- a/www/horde2/files/patch-lib_Horde.php
+++ /dev/null
@@ -1,22 +0,0 @@
---- lib/Horde.php.orig Wed Apr 23 23:43:06 2003
-+++ lib/Horde.php Sat Aug 2 21:14:12 2003
-@@ -120,7 +120,7 @@
- *
- * @author Chuck Hagenbuch <chuck@horde.org>
- * @author Jon Parise <jon@horde.org>
-- * @version $Revision: 1.118.2.42 $
-+ * @version $Revision: 1.118.2.43 $
- * @since Horde 1.3
- * @package horde
- */
-@@ -184,8 +184,8 @@
- }
-
- include_once 'Log.php';
-- $logger = Log::singleton($conf['log']['type'], $conf['log']['name'],
-- $conf['log']['ident'], $conf['log']['params']);
-+ $logger = &Log::singleton($conf['log']['type'], $conf['log']['name'],
-+ $conf['log']['ident'], $conf['log']['params']);
-
- if (!$logger) {
- Horde::fatal(new PEAR_Error('An error has occurred. Furthermore, Horde encountered an error attempting to log this error. Please check your Horde logging configuration in horde/config/horde.php.'), __FILE__, __LINE__, false);
diff --git a/www/horde2/pkg-plist b/www/horde2/pkg-plist
index 466b45710fec..58d80bf9067c 100644
--- a/www/horde2/pkg-plist
+++ b/www/horde2/pkg-plist
@@ -167,6 +167,7 @@
%%HORDEDIR%%/lib/base.php
%%HORDEDIR%%/lib/version.php
%%HORDEDIR%%/locale/.htaccess
+%%HORDEDIR%%/locale/ar_SY/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/bg_BG/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/ca_ES/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/cs_CZ/LC_MESSAGES/horde.mo
@@ -185,6 +186,7 @@
%%HORDEDIR%%/locale/ko_KR/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/lt_LT/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/lv_LV/LC_MESSAGES/horde.mo
+%%HORDEDIR%%/locale/mk_MK/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/nl_NL/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/nb_NO/LC_MESSAGES/horde.mo
%%HORDEDIR%%/locale/nn_NO/LC_MESSAGES/horde.mo
@@ -209,6 +211,7 @@
%%HORDEDIR%%/po/Makefile
%%HORDEDIR%%/po/README
%%HORDEDIR%%/po/wintokoi.pl
+%%HORDEDIR%%/po/ar_SY.po
%%HORDEDIR%%/po/bg_BG.po
%%HORDEDIR%%/po/ca_ES.po
%%HORDEDIR%%/po/cs_CZ.po
@@ -227,6 +230,7 @@
%%HORDEDIR%%/po/ko_KR.po
%%HORDEDIR%%/po/lt_LT.po
%%HORDEDIR%%/po/lv_LV.po
+%%HORDEDIR%%/po/mk_MK.po
%%HORDEDIR%%/po/nl_NL.po
%%HORDEDIR%%/po/nb_NO.po
%%HORDEDIR%%/po/nn_NO.po
@@ -266,6 +270,7 @@
%%HORDEDIR%%/scripts/mime_mapping/Makefile
%%HORDEDIR%%/scripts/mime_mapping/convert.pl
%%HORDEDIR%%/scripts/mime_mapping/mime.types
+%%HORDEDIR%%/scripts/mime_mapping/mime.types.horde
%%HORDEDIR%%/scripts/set_perms.sh
%%HORDEDIR%%/status.php
%%HORDEDIR%%/templates/.htaccess
@@ -314,6 +319,7 @@
%%HORDEDIR%%/templates/wml/login/user.inc
%%HORDEDIR%%/test.php
%%HORDEDIR%%/util/css2horde.php
+%%HORDEDIR%%/util/go.php
%%HORDEDIR%%/util/special_characters.php
%%HORDESBIN%%/horde_set_perms.sh
etc/horde/httpd.conf.horde
@@ -344,6 +350,8 @@ etc/horde/httpd.conf.horde
@dirrm %%HORDEDIR%%/lib/Token
@dirrm %%HORDEDIR%%/lib/VFS
@dirrm %%HORDEDIR%%/lib
+@dirrm %%HORDEDIR%%/locale/ar_SY/LC_MESSAGES
+@dirrm %%HORDEDIR%%/locale/ar_SY
@dirrm %%HORDEDIR%%/locale/bg_BG/LC_MESSAGES
@dirrm %%HORDEDIR%%/locale/bg_BG
@dirrm %%HORDEDIR%%/locale/ca_ES/LC_MESSAGES
@@ -377,6 +385,8 @@ etc/horde/httpd.conf.horde
@dirrm %%HORDEDIR%%/locale/lt_LT
@dirrm %%HORDEDIR%%/locale/lv_LV/LC_MESSAGES
@dirrm %%HORDEDIR%%/locale/lv_LV
+@dirrm %%HORDEDIR%%/locale/mk_MK/LC_MESSAGES
+@dirrm %%HORDEDIR%%/locale/mk_MK
@dirrm %%HORDEDIR%%/locale/nl_NL/LC_MESSAGES
@dirrm %%HORDEDIR%%/locale/nl_NL
@dirrm %%HORDEDIR%%/locale/nb_NO/LC_MESSAGES
@@ -430,4 +440,4 @@ etc/horde/httpd.conf.horde
@dirrm %%HORDEDIR%%/po
@unexec rmdir %D/%%HORDEDIR%%/config 2>/dev/null || true
@unexec rmdir %D/%%HORDEDIR%% 2>/dev/null || true
-@dirrm etc/horde
+@unexec rmdir %D/etc/horde 2>/dev/null || true