aboutsummaryrefslogtreecommitdiff
path: root/www/horde3-meta
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-12-12 12:24:01 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-12-12 12:24:01 +0000
commit1e429944f998b352d7f3efd46ff0c1a0a2f44f03 (patch)
tree368eaa45923e728a9578f2f58fe2e52c54200f10 /www/horde3-meta
parente252b7167c93062ce5b1ca4853ea7e4d1b684b3d (diff)
Notes
Diffstat (limited to 'www/horde3-meta')
-rw-r--r--www/horde3-meta/Makefile127
-rw-r--r--www/horde3-meta/files/post-configure-message6
-rw-r--r--www/horde3-meta/pkg-descr12
3 files changed, 145 insertions, 0 deletions
diff --git a/www/horde3-meta/Makefile b/www/horde3-meta/Makefile
new file mode 100644
index 000000000000..38f94ebec126
--- /dev/null
+++ b/www/horde3-meta/Makefile
@@ -0,0 +1,127 @@
+# New ports collection makefile for: horde
+# Date created: 24 February 2007
+# Whom: Beech Rintoul <beech@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= meta
+PORTVERSION= 1.0
+PORTREVISION= 11
+CATEGORIES= www
+MASTER_SITES= # Empty
+DISTFILES= # None
+
+MAINTAINER= horde@FreeBSD.org
+COMMENT= Meta port for the horde framework
+
+NO_BUILD= yes
+LHORDEDIR?= www/horde
+
+OPTIONS= ANSEL "Photo Gallery" off \
+ CHORA "CVS Web Viewer" off \
+ DIMP "Dynamic Imp" off \
+ GOLLEM "Web-Based File Manager" off \
+ HERMES "Time Tracking Application" off \
+ HPASSWD "Password Changing Module" off \
+ IMP "IMAP Webmail System" on \
+ INGO "Email-Filter Management" on \
+ JETA "Java SSH Applets" off \
+ KRONOLITH "Calendar Application" off \
+ MIMP "Mobile Webmail System" off \
+ MNEMO "Notes and Memo Application" off \
+ NAG "Task List Manager" on \
+ NIC "Network Monitor" off \
+ TREAN "Bookmark Manager" off \
+ TURBA "Contact Management" on \
+ VACATION "Vacation & Auto Respond" off \
+ WHUPS "Bug Tracking/Ticket System" off \
+ KLUTZ "Comic Strip Viewer" off
+
+.include <bsd.port.pre.mk>
+
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde3-base
+
+.if !defined(WITHOUT_IMP)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/imp/index.php:${PORTSDIR}/mail/horde3-imp
+.endif
+
+.if defined(WITH_MIMP)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mimp/index.php:${PORTSDIR}/mail/horde3-mimp
+.endif
+
+.if defined(WITH_DIMP)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/dimp/compose.php:${PORTSDIR}/mail/horde3-dimp
+.endif
+
+.if !defined(WITHOUT_INGO)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/ingo/filters.php:${PORTSDIR}/mail/horde3-ingo
+.endif
+
+.if !defined(WITHOUT_TURBA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/turba/minisearch.php:${PORTSDIR}/mail/horde3-turba
+.endif
+
+.if defined(WITH_KRONOLITH)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/kronolith/index.php:${PORTSDIR}/deskutils/horde3-kronolith
+.endif
+
+.if defined(WITH_MNEMO)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mnemo/index.php:${PORTSDIR}/deskutils/horde3-mnemo
+.endif
+
+.if !defined(WITHOUT_NAG)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/nag/data.php:${PORTSDIR}/deskutils/horde3-nag
+.endif
+
+.if defined(WITH_CHORA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/chora/index.php:${PORTSDIR}/devel/horde3-chora
+.endif
+
+.if defined(WITH_GOLLEM)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/gollem/index.php:${PORTSDIR}/ftp/horde3-gollem
+.endif
+
+.if defined(WITH_JETA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/jeta/index.php:${PORTSDIR}/security/horde3-jeta
+.endif
+
+.if defined(WITH_HPASSWD)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/passwd/index.php:${PORTSDIR}/www/horde3-passwd
+.endif
+
+.if defined(WITH_VACATION)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/vacation/main.php:${PORTSDIR}/mail/horde3-vacation
+.endif
+
+.if defined(WITH_TREAN)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/trean/data.php:${PORTSDIR}/www/horde3-trean
+.endif
+
+.if defined(WITH_NIC)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/nic/status.php:${PORTSDIR}/net-mgmt/horde3-nic
+.endif
+
+.if defined(WITH_ANSEL)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/ansel/gallery.php:${PORTSDIR}/www/horde3-ansel
+.endif
+
+.if defined(WITH_WHUPS)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/whups/index.php:${PORTSDIR}/devel/horde3-whups
+.endif
+
+.if defined(WITH_HERMES)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/hermes/index.php:${PORTSDIR}/deskutils/horde3-hermes
+.endif
+
+.if defined(WITH_KLUTZ)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/klutz/index.php:${PORTSDIR}/deskutils/horde3-klutz
+.endif
+
+post-configure:
+ @${CAT} ${FILESDIR}/post-configure-message
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.post.mk>
diff --git a/www/horde3-meta/files/post-configure-message b/www/horde3-meta/files/post-configure-message
new file mode 100644
index 000000000000..ae87a0751fe8
--- /dev/null
+++ b/www/horde3-meta/files/post-configure-message
@@ -0,0 +1,6 @@
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
+Configuration step finished. Run 'make install' to install the rest of the
+modules you selected. Run 'make clean && make config' to re-enter the
+configuration. Please note that you CANNOT REMOVE modules through this menu
+system, use pkg_delete instead.
+* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
diff --git a/www/horde3-meta/pkg-descr b/www/horde3-meta/pkg-descr
new file mode 100644
index 000000000000..1790f5bc67cb
--- /dev/null
+++ b/www/horde3-meta/pkg-descr
@@ -0,0 +1,12 @@
+Horde is a framework used by several applications written in PHP.
+
+Horde is used by these ports: mail/imp, mail/mimp, mail/turba,
+devel/chora, deskutils/kronolith, deskutils/nag, mail/ingo, ftp/gollem
+security/jeta, www/horde-passwd and deskutils/mnemo, .
+
+This package does not contain anything by itself -- it is a
+"meta-port" that depends on other Horde packages. Its sole purpose is
+to require dependencies so users can install this package only and
+have all the Horde stuff pulled in by the port/package dependency mechanism.
+
+WWW: http://www.horde.org/