aboutsummaryrefslogtreecommitdiff
path: root/www/horde4-meta/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-26 15:48:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-26 15:48:31 +0000
commit479313d22b0953f7f4270ed0b8bb0974907375f3 (patch)
treebb25acfadb667363ecd9f75dcb5cd6246d6f8567 /www/horde4-meta/Makefile
parent016689207d8eca587fa1d46602b6f37c9aadc80a (diff)
Notes
Diffstat (limited to 'www/horde4-meta/Makefile')
-rw-r--r--www/horde4-meta/Makefile91
1 files changed, 91 insertions, 0 deletions
diff --git a/www/horde4-meta/Makefile b/www/horde4-meta/Makefile
new file mode 100644
index 000000000000..da9d082ec04e
--- /dev/null
+++ b/www/horde4-meta/Makefile
@@ -0,0 +1,91 @@
+# New ports collection makefile for: horde
+# Date created: 24 February 2007
+# Whom: beech@alaskaparadise.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= meta
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= # Empty
+PKGNAMEPREFIX= horde-
+DISTFILES= # None
+
+MAINTAINER= beech@alaskaparadise.com
+COMMENT= Meta port for the horde framework
+
+NO_BUILD= yes
+LHORDEDIR?= www/horde
+
+OPTIONS= IMP "IMAP Webmail System" on \
+ MIMP "Mobile Webmail System" off \
+ INGO "Email-Filter Management" on \
+ TURBA "Contact Management" on \
+ KRONOLITH "Calendar Application" off \
+ MNEMO "Notes and Memo Application" off \
+ NAG "Task List Manager" on \
+ CHORA "CVS Web Viewer" off \
+ GOLLEM "Web-Based File Manager" off \
+ JETA "Java SSH Applets" off \
+ HPASSWD "Password Changing Module" off
+
+.include <bsd.port.pre.mk>
+
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
+
+.if !defined(WITHOUT_IMP)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/imp/index.php:${PORTSDIR}/mail/imp
+.endif
+
+.if defined(WITH_MIMP)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mimp/index.php:${PORTSDIR}/mail/mimp
+.endif
+
+.if !defined(WITHOUT_INGO)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/ingo/filters.php:${PORTSDIR}/mail/ingo
+.endif
+
+.if !defined(WITHOUT_TURBA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/turba/minisearch.php:${PORTSDIR}/mail/turba
+.endif
+
+.if defined(WITH_KRONOLITH)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/kronolith/index.php:${PORTSDIR}/deskutils/kronolith
+.endif
+
+.if defined(WITH_MNEMO)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/mnemo/index.php:${PORTSDIR}/deskutils/mnemo
+.endif
+
+.if !defined(WITHOUT_NAG)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/nag/data.php:${PORTSDIR}/deskutils/nag
+.endif
+
+.if defined(WITH_CHORA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/chora/index.php:${PORTSDIR}/devel/chora
+.endif
+
+.if defined(WITH_GOLLEM)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/gollem/index.php:${PORTSDIR}/ftp/gollem
+.endif
+
+.if defined(WITH_JETA)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/jeta/index.php:${PORTSDIR}/security/jeta
+.endif
+
+.if defined(WITH_HPASSWD)
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/passwd/index.php:${PORTSDIR}/www/horde-passwd
+.endif
+
+post-configure:
+ @${CAT} ${FILESDIR}/post-configure-message
+
+postinstall:
+
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+do-install:
+
+.include <bsd.port.post.mk>