aboutsummaryrefslogtreecommitdiff
path: root/www/hs-activehs
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-03-29 22:43:58 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-03-29 22:43:58 +0000
commitbd8d410bbe561cb06cef8e6439398148ea172996 (patch)
treebb6acd9e4d75e5dd918d3f6f723ca485c7f0dd6f /www/hs-activehs
parent18f2b16087e8ecd6790e8d551f1083d977da1d77 (diff)
Notes
Diffstat (limited to 'www/hs-activehs')
-rw-r--r--www/hs-activehs/Makefile11
-rw-r--r--www/hs-activehs/distinfo4
-rw-r--r--www/hs-activehs/files/patch-Main.hs10
-rw-r--r--www/hs-activehs/files/patch-Simple.hs19
-rw-r--r--www/hs-activehs/files/patch-Smart.hs10
-rw-r--r--www/hs-activehs/files/patch-Special.hs20
-rw-r--r--www/hs-activehs/files/patch-activehs.cabal15
7 files changed, 77 insertions, 12 deletions
diff --git a/www/hs-activehs/Makefile b/www/hs-activehs/Makefile
index 3f05460c179f..669699ee8b4d 100644
--- a/www/hs-activehs/Makefile
+++ b/www/hs-activehs/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= activehs
-PORTVERSION= 0.3.0.1
-PORTREVISION= 1
+PORTVERSION= 0.3.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -12,11 +11,11 @@ LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= activehs-base>=0.2 Agda>=2.3.0.1 blaze-html>=0.5 \
- blaze-markup>=0.5.1.0 cmdargs>=0.7 data-pprint>=0.2 \
- dia-base>=0.1 dia-functions>=0.2.1.1 haskell-src-exts>=1.12 \
+USE_CABAL= activehs-base>=0.2 blaze-html>=0.5 blaze-markup>=0.5.1.0 \
+ cmdargs>=0.7 data-pprint>=0.2 dia-base>=0.1 \
+ dia-functions>=0.2.1.1 haskell-src-exts>=1.12 \
highlighting-kate>=0.5 hint>=0.3.3.2 hoogle>=4.2.11 mtl>=2.0 \
- pandoc>=1.8 pureMD5>=2.1 QuickCheck>=2.4 simple-reflect>=0.2 \
+ pandoc>=1.10 pureMD5>=2.1 QuickCheck>=2.4 simple-reflect>=0.2 \
snap-core>=0.6 snap-server>=0.6 split>=0.1 syb>=0.2 \
text>=0.11 utf8-string>=0.3 xhtml>=3000.2
diff --git a/www/hs-activehs/distinfo b/www/hs-activehs/distinfo
index bb773e290fc4..6846af2f7017 100644
--- a/www/hs-activehs/distinfo
+++ b/www/hs-activehs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/activehs-0.3.0.1.tar.gz) = 860556c074cde2dad353cf4ca68a47271947e574c4680c237e79fe8bbb8c5627
-SIZE (cabal/activehs-0.3.0.1.tar.gz) = 35745
+SHA256 (cabal/activehs-0.3.1.tar.gz) = 0c0ab3ef3338d713d0bde0ce288199ce28c6401e27545691f04e08450403ea0f
+SIZE (cabal/activehs-0.3.1.tar.gz) = 33193
diff --git a/www/hs-activehs/files/patch-Main.hs b/www/hs-activehs/files/patch-Main.hs
new file mode 100644
index 000000000000..0920ef39498b
--- /dev/null
+++ b/www/hs-activehs/files/patch-Main.hs
@@ -0,0 +1,10 @@
+--- ./Main.hs.orig 2013-02-12 20:23:46.000000000 +0100
++++ ./Main.hs 2013-02-18 19:59:53.000000000 +0100
+@@ -31,7 +31,6 @@
+ import System.Locale (defaultTimeLocale)
+ import Data.Time (getCurrentTime, formatTime, diffUTCTime)
+ import Data.Maybe (listToMaybe)
+---import Prelude hiding (catch)
+
+ ---------------------------------------------------------------
+
diff --git a/www/hs-activehs/files/patch-Simple.hs b/www/hs-activehs/files/patch-Simple.hs
new file mode 100644
index 000000000000..bc6f6eeca660
--- /dev/null
+++ b/www/hs-activehs/files/patch-Simple.hs
@@ -0,0 +1,19 @@
+--- ./Simple.hs.orig 2013-02-12 20:23:45.000000000 +0100
++++ ./Simple.hs 2013-02-18 19:59:53.000000000 +0100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ExistentialQuantification, ScopedTypeVariables, PatternGuards, FlexibleContexts #-}
++{-# LANGUAGE ExistentialQuantification, ScopedTypeVariables, PatternGuards, FlexibleContexts, CPP #-}
+
+ module Simple
+ ( Task (..), TaskChan
+@@ -23,7 +23,9 @@
+ import Control.Monad (when, forever)
+ import Control.Monad.Error (MonadError, catchError)
+ import Data.List (isPrefixOf)
+---import Prelude hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
+
+ -------------------------
+
diff --git a/www/hs-activehs/files/patch-Smart.hs b/www/hs-activehs/files/patch-Smart.hs
new file mode 100644
index 000000000000..ad3d8eb0ba59
--- /dev/null
+++ b/www/hs-activehs/files/patch-Smart.hs
@@ -0,0 +1,10 @@
+--- ./Smart.hs.orig 2013-02-12 20:23:45.000000000 +0100
++++ ./Smart.hs 2013-02-18 19:59:53.000000000 +0100
+@@ -37,7 +37,6 @@
+ import qualified Data.Data as D
+ import Data.List (nub)
+ import Data.Char (isAlpha)
+---import Prelude hiding (catch)
+
+
+ ----------------------------------------------------------------------
diff --git a/www/hs-activehs/files/patch-Special.hs b/www/hs-activehs/files/patch-Special.hs
new file mode 100644
index 000000000000..af4c8ebd5c92
--- /dev/null
+++ b/www/hs-activehs/files/patch-Special.hs
@@ -0,0 +1,20 @@
+--- ./Special.hs.orig 2013-02-12 20:23:46.000000000 +0100
++++ ./Special.hs 2013-02-18 19:59:53.000000000 +0100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE ScopedTypeVariables, OverloadedStrings, ViewPatterns, PatternGuards, NamedFieldPuns #-}
++{-# LANGUAGE ScopedTypeVariables, OverloadedStrings, ViewPatterns, PatternGuards, NamedFieldPuns, CPP #-}
+
+ module Special
+ ( SpecialTask (..), exerciseServer'
+@@ -25,8 +25,9 @@
+ import System.Directory (getTemporaryDirectory)
+
+ import Control.Concurrent (threadDelay, forkIO, killThread)
+---import Prelude hiding (catch)
+-
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
+
+ ---------------------------------------------------------------
+
diff --git a/www/hs-activehs/files/patch-activehs.cabal b/www/hs-activehs/files/patch-activehs.cabal
index 5bbbc9570646..0528ec55bb35 100644
--- a/www/hs-activehs/files/patch-activehs.cabal
+++ b/www/hs-activehs/files/patch-activehs.cabal
@@ -1,10 +1,17 @@
---- ./activehs.cabal.orig 2012-10-10 11:22:11.000000000 +0200
-+++ ./activehs.cabal 2012-11-03 20:34:38.000000000 +0100
-@@ -77,6 +77,7 @@
+--- ./activehs.cabal.orig 2013-02-12 20:23:46.000000000 +0100
++++ ./activehs.cabal 2013-03-10 13:53:48.000000000 +0100
+@@ -76,11 +76,12 @@
+ bytestring >= 0.9 && < 0.11,
utf8-string >= 0.3 && < 0.4,
xhtml >= 3000.2 && < 3000.3,
- blaze-html >= 0.4 && < 0.6,
+- blaze-html >= 0.4 && < 0.6,
++ blaze-html >= 0.4 && < 0.7,
+ blaze-markup == 0.5.1.*,
pureMD5 >= 2.1 && < 2.2,
deepseq >= 1.1 && < 1.4,
split >= 0.1 && < 0.3,
+- pandoc >= 1.10 && < 1.11,
++ pandoc >= 1.10 && < 1.12,
+ time >= 1.2 && < 1.5,
+ old-time >= 1.0 && < 1.2,
+ process >= 1.0 && < 1.2,