aboutsummaryrefslogtreecommitdiff
path: root/www/hs-activehs
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
commit109269205e521bb1d2d87678a391e5adefff88d6 (patch)
tree93f1f9278a9a48902904b7ff4a5ce711c10efe08 /www/hs-activehs
parentad7295cafd0e46ece6fcbf594ef39a767c296d0e (diff)
downloadports-109269205e521bb1d2d87678a391e5adefff88d6.tar.gz
ports-109269205e521bb1d2d87678a391e5adefff88d6.zip
Notes
Diffstat (limited to 'www/hs-activehs')
-rw-r--r--www/hs-activehs/Makefile3
-rw-r--r--www/hs-activehs/files/patch-Converter.hs13
-rw-r--r--www/hs-activehs/files/patch-Main.hs10
-rw-r--r--www/hs-activehs/files/patch-Simple.hs19
-rw-r--r--www/hs-activehs/files/patch-Smart.hs10
-rw-r--r--www/hs-activehs/files/patch-Special.hs20
-rw-r--r--www/hs-activehs/files/patch-activehs.cabal19
7 files changed, 31 insertions, 63 deletions
diff --git a/www/hs-activehs/Makefile b/www/hs-activehs/Makefile
index 669699ee8b4d..f14114b0f4a7 100644
--- a/www/hs-activehs/Makefile
+++ b/www/hs-activehs/Makefile
@@ -2,6 +2,7 @@
PORTNAME= activehs
PORTVERSION= 0.3.1
+PORTREVISION= 1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,8 +10,6 @@ COMMENT= Haskell code presentation tool
LICENSE= BSD
-CABAL_SETUP= Setup.hs
-
USE_CABAL= activehs-base>=0.2 blaze-html>=0.5 blaze-markup>=0.5.1.0 \
cmdargs>=0.7 data-pprint>=0.2 dia-base>=0.1 \
dia-functions>=0.2.1.1 haskell-src-exts>=1.12 \
diff --git a/www/hs-activehs/files/patch-Converter.hs b/www/hs-activehs/files/patch-Converter.hs
new file mode 100644
index 000000000000..e4e7da82e900
--- /dev/null
+++ b/www/hs-activehs/files/patch-Converter.hs
@@ -0,0 +1,13 @@
+--- ./Converter.hs.orig 2013-02-12 20:23:45.000000000 +0100
++++ ./Converter.hs 2013-05-28 16:20:35.000000000 +0200
+@@ -249,8 +249,8 @@
+
+ mkName :: String -> HSyn.Name
+ mkName n@(c:_)
+- | isSymbol c = HSyn.Symbol n
+-mkName n = HSyn.Ident n
++ | isLetter c = HSyn.Ident n
++mkName n = HSyn.Symbol n
+
+ mkImport_ :: String -> String -> HSyn.ImportDecl
+ mkImport_ magic m
diff --git a/www/hs-activehs/files/patch-Main.hs b/www/hs-activehs/files/patch-Main.hs
deleted file mode 100644
index 0920ef39498b..000000000000
--- a/www/hs-activehs/files/patch-Main.hs
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./Main.hs.orig 2013-02-12 20:23:46.000000000 +0100
-+++ ./Main.hs 2013-02-18 19:59:53.000000000 +0100
-@@ -31,7 +31,6 @@
- import System.Locale (defaultTimeLocale)
- import Data.Time (getCurrentTime, formatTime, diffUTCTime)
- import Data.Maybe (listToMaybe)
----import Prelude hiding (catch)
-
- ---------------------------------------------------------------
-
diff --git a/www/hs-activehs/files/patch-Simple.hs b/www/hs-activehs/files/patch-Simple.hs
deleted file mode 100644
index bc6f6eeca660..000000000000
--- a/www/hs-activehs/files/patch-Simple.hs
+++ /dev/null
@@ -1,19 +0,0 @@
---- ./Simple.hs.orig 2013-02-12 20:23:45.000000000 +0100
-+++ ./Simple.hs 2013-02-18 19:59:53.000000000 +0100
-@@ -1,4 +1,4 @@
--{-# LANGUAGE ExistentialQuantification, ScopedTypeVariables, PatternGuards, FlexibleContexts #-}
-+{-# LANGUAGE ExistentialQuantification, ScopedTypeVariables, PatternGuards, FlexibleContexts, CPP #-}
-
- module Simple
- ( Task (..), TaskChan
-@@ -23,7 +23,9 @@
- import Control.Monad (when, forever)
- import Control.Monad.Error (MonadError, catchError)
- import Data.List (isPrefixOf)
----import Prelude hiding (catch)
-+#if !MIN_VERSION_base(4,6,0)
-+import Prelude hiding (catch)
-+#endif
-
- -------------------------
-
diff --git a/www/hs-activehs/files/patch-Smart.hs b/www/hs-activehs/files/patch-Smart.hs
deleted file mode 100644
index ad3d8eb0ba59..000000000000
--- a/www/hs-activehs/files/patch-Smart.hs
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./Smart.hs.orig 2013-02-12 20:23:45.000000000 +0100
-+++ ./Smart.hs 2013-02-18 19:59:53.000000000 +0100
-@@ -37,7 +37,6 @@
- import qualified Data.Data as D
- import Data.List (nub)
- import Data.Char (isAlpha)
----import Prelude hiding (catch)
-
-
- ----------------------------------------------------------------------
diff --git a/www/hs-activehs/files/patch-Special.hs b/www/hs-activehs/files/patch-Special.hs
deleted file mode 100644
index af4c8ebd5c92..000000000000
--- a/www/hs-activehs/files/patch-Special.hs
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./Special.hs.orig 2013-02-12 20:23:46.000000000 +0100
-+++ ./Special.hs 2013-02-18 19:59:53.000000000 +0100
-@@ -1,4 +1,4 @@
--{-# LANGUAGE ScopedTypeVariables, OverloadedStrings, ViewPatterns, PatternGuards, NamedFieldPuns #-}
-+{-# LANGUAGE ScopedTypeVariables, OverloadedStrings, ViewPatterns, PatternGuards, NamedFieldPuns, CPP #-}
-
- module Special
- ( SpecialTask (..), exerciseServer'
-@@ -25,8 +25,9 @@
- import System.Directory (getTemporaryDirectory)
-
- import Control.Concurrent (threadDelay, forkIO, killThread)
----import Prelude hiding (catch)
--
-+#if !MIN_VERSION_base(4,6,0)
-+import Prelude hiding (catch)
-+#endif
-
- ---------------------------------------------------------------
-
diff --git a/www/hs-activehs/files/patch-activehs.cabal b/www/hs-activehs/files/patch-activehs.cabal
index 0528ec55bb35..68ed888b6f5d 100644
--- a/www/hs-activehs/files/patch-activehs.cabal
+++ b/www/hs-activehs/files/patch-activehs.cabal
@@ -1,6 +1,21 @@
--- ./activehs.cabal.orig 2013-02-12 20:23:46.000000000 +0100
-+++ ./activehs.cabal 2013-03-10 13:53:48.000000000 +0100
-@@ -76,11 +76,12 @@
++++ ./activehs.cabal 2013-05-28 16:18:31.000000000 +0200
+@@ -63,7 +63,7 @@
+ activehs-base >= 0.2 && < 0.4,
+ data-pprint >= 0.2 && < 0.3,
+ base >= 4.0 && < 4.7,
+- QuickCheck >= 2.4 && < 2.6,
++ QuickCheck >= 2.4 && < 2.7,
+ array >= 0.3 && < 0.5,
+ directory >= 1.1 && < 1.3,
+ containers >= 0.4 && < 0.6,
+@@ -71,16 +71,17 @@
+ text >= 0.11 && < 0.12,
+ snap-core >= 0.6 && < 0.10,
+ snap-server >= 0.6 && < 0.10,
+- syb >= 0.2 && < 0.4,
++ syb >= 0.2 && < 0.5,
+ haskell-src-exts >= 1.12 && < 1.14,
bytestring >= 0.9 && < 0.11,
utf8-string >= 0.3 && < 0.4,
xhtml >= 3000.2 && < 3000.3,