aboutsummaryrefslogtreecommitdiff
path: root/www/hs-activehs
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-12-20 02:23:04 +0000
commitf6f83c9efc2c46d2970746758e2c682bb8a518ec (patch)
tree290f2ea61305744bf0f477895c56b92acaeb361f /www/hs-activehs
parentaf071cfdc1f8578bd1523b823e683074a3139a34 (diff)
downloadports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.tar.gz
ports-f6f83c9efc2c46d2970746758e2c682bb8a518ec.zip
Notes
Diffstat (limited to 'www/hs-activehs')
-rw-r--r--www/hs-activehs/Makefile26
-rw-r--r--www/hs-activehs/distinfo2
-rw-r--r--www/hs-activehs/files/patch-activehs.cabal10
-rw-r--r--www/hs-activehs/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/www/hs-activehs/Makefile b/www/hs-activehs/Makefile
new file mode 100644
index 000000000000..2319979f8ee1
--- /dev/null
+++ b/www/hs-activehs/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= activehs
+PORTVERSION= 0.3.0.1
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell code presentation tool
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= activehs-base>=0.2 Agda>=2.3.0.1 blaze-html>=0.5 \
+ blaze-markup>=0.5.1.0 cmdargs>=0.7 data-pprint>=0.2 \
+ dia-base>=0.1 dia-functions>=0.2.1.1 haskell-src-exts>=1.12 \
+ highlighting-kate>=0.5 hint>=0.3.3.2 hoogle>=4.2.11 mtl>=2.0 \
+ pandoc>=1.8 pureMD5>=2.1 QuickCheck>=2.4 simple-reflect>=0.2 \
+ snap-core>=0.6 snap-server>=0.6 split>=0.1 syb>=0.2 \
+ text>=0.11 utf8-string>=0.3 xhtml>=3000.2
+
+STANDALONE= yes
+EXECUTABLE= activehs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-activehs/distinfo b/www/hs-activehs/distinfo
new file mode 100644
index 000000000000..bb773e290fc4
--- /dev/null
+++ b/www/hs-activehs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/activehs-0.3.0.1.tar.gz) = 860556c074cde2dad353cf4ca68a47271947e574c4680c237e79fe8bbb8c5627
+SIZE (cabal/activehs-0.3.0.1.tar.gz) = 35745
diff --git a/www/hs-activehs/files/patch-activehs.cabal b/www/hs-activehs/files/patch-activehs.cabal
new file mode 100644
index 000000000000..5bbbc9570646
--- /dev/null
+++ b/www/hs-activehs/files/patch-activehs.cabal
@@ -0,0 +1,10 @@
+--- ./activehs.cabal.orig 2012-10-10 11:22:11.000000000 +0200
++++ ./activehs.cabal 2012-11-03 20:34:38.000000000 +0100
+@@ -77,6 +77,7 @@
+ utf8-string >= 0.3 && < 0.4,
+ xhtml >= 3000.2 && < 3000.3,
+ blaze-html >= 0.4 && < 0.6,
++ blaze-markup == 0.5.1.*,
+ pureMD5 >= 2.1 && < 2.2,
+ deepseq >= 1.1 && < 1.4,
+ split >= 0.1 && < 0.3,
diff --git a/www/hs-activehs/pkg-descr b/www/hs-activehs/pkg-descr
new file mode 100644
index 000000000000..24d9095c701c
--- /dev/null
+++ b/www/hs-activehs/pkg-descr
@@ -0,0 +1,4 @@
+ActiveHs is a Haskell source code presentation tool, developed for education
+purposes.
+
+WWW: http://hackage.haskell.org/package/activehs