aboutsummaryrefslogtreecommitdiff
path: root/www/hs-authenticate
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-18 16:40:40 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-18 16:40:40 +0000
commit2f0595223df1a70810554f7b2efc8f5b98dc4d0c (patch)
tree3d105feb3f5b1c7f921f0e78a1261b4c096b1ec1 /www/hs-authenticate
parent7ebd2904f2b07f6cd12debff0aae1de1a4bc76fb (diff)
Notes
Diffstat (limited to 'www/hs-authenticate')
-rw-r--r--www/hs-authenticate/Makefile24
-rw-r--r--www/hs-authenticate/distinfo2
-rw-r--r--www/hs-authenticate/pkg-descr4
3 files changed, 30 insertions, 0 deletions
diff --git a/www/hs-authenticate/Makefile b/www/hs-authenticate/Makefile
new file mode 100644
index 000000000000..5331b25bb7d2
--- /dev/null
+++ b/www/hs-authenticate/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-authenticate
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= authenticate
+PORTVERSION= 0.10.4
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Authentication methods for Haskell web applications
+
+LICENSE= BSD
+
+USE_CABAL= aeson>=0.3.2.11 attoparsec>=0.9 base64-bytestring>=0.1 \
+ blaze-builder>=0.2 case-insensitive>=0.2 enumerator>=0.4.7 \
+ failure>=0.0.0 http-enumerator>=0.6.5.4 http-types>=0.6 \
+ network>=2.2.1 RSA>=1.0 SHA>=1.4 tagsoup>=0.12 text>=0.5 tls>=0.7 \
+ transformers>=0.1 unordered-containers xml-enumerator>=0.4
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-authenticate/distinfo b/www/hs-authenticate/distinfo
new file mode 100644
index 000000000000..ff5e62895519
--- /dev/null
+++ b/www/hs-authenticate/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/authenticate-0.10.4.tar.gz) = fd34f931eec506bf64e62d7c5b7edb40998f8d58cab204190029382c98a55d2e
+SIZE (cabal/authenticate-0.10.4.tar.gz) = 13691
diff --git a/www/hs-authenticate/pkg-descr b/www/hs-authenticate/pkg-descr
new file mode 100644
index 000000000000..5c5aee257036
--- /dev/null
+++ b/www/hs-authenticate/pkg-descr
@@ -0,0 +1,4 @@
+Focus is on third-party authentication methods, such as OpenID, rpxnow
+and Facebook.
+
+WWW: http://github.com/yesodweb/authenticate