aboutsummaryrefslogtreecommitdiff
path: root/www/hs-snap-core
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-13 05:50:36 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-13 05:50:36 +0000
commit59fa7e27544c610aa2b9f518680de2889bd0ba5c (patch)
tree84892dd359c62e9a0905ccd77fbc0ffd2f189f65 /www/hs-snap-core
parent75be60638b28611f2a9500a0faa85a3cab4fc1e8 (diff)
downloadports-59fa7e27544c610aa2b9f518680de2889bd0ba5c.tar.gz
ports-59fa7e27544c610aa2b9f518680de2889bd0ba5c.zip
Notes
Diffstat (limited to 'www/hs-snap-core')
-rw-r--r--www/hs-snap-core/Makefile16
-rw-r--r--www/hs-snap-core/distinfo4
-rw-r--r--www/hs-snap-core/files/patch-snap-core.cabal11
-rw-r--r--www/hs-snap-core/pkg-descr23
4 files changed, 32 insertions, 22 deletions
diff --git a/www/hs-snap-core/Makefile b/www/hs-snap-core/Makefile
index 3331b13d1f38..7e4ba3ea6349 100644
--- a/www/hs-snap-core/Makefile
+++ b/www/hs-snap-core/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= snap-core
-PORTVERSION= 0.5.2
+PORTVERSION= 0.7.0.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -15,11 +15,15 @@ COMMENT= Snap: A Haskell Web Framework (Core)
LICENSE= BSD
CABAL_SETUP= Setup.hs
-USE_CABAL= attoparsec>=0.8.0.2 attoparsec-enumerator>=0.2.0.3 \
- blaze-builder>=0.2.1.4 bytestring-nums case-insensitive \
- deepseq>=1.1 dlist>=0.5 enumerator>=0.4.13.1 \
- MonadCatchIO-transformers>=0.2.1 mtl>=2 text>=0.11 \
- transformers>=0.2 unix-compat>=0.2 vector>=0.6 zlib
+USE_CABAL= attoparsec>=0.10 attoparsec-enumerator>=0.3 \
+ base16-bytestring blaze-builder>=0.2.1.4 \
+ blaze-builder-enumerator>=0.2 bytestring-nums \
+ case-insensitive>=0.3 deepseq>=1.1 dlist>=0.5 \
+ enumerator>=0.4.13.1 HUnit>=1.2 \
+ MonadCatchIO-transformers>=0.2.1 mtl>=2.0 \
+ mwc-random>=0.10 regex-posix text>=0.11 transformers>=0.2 \
+ unix-compat>=0.2 unordered-containers>=0.1.4.3 vector>=0.6 \
+ zlib-enum>=0.2.1
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-snap-core/distinfo b/www/hs-snap-core/distinfo
index 62a6ef3f3e0d..7dafe63b0ca4 100644
--- a/www/hs-snap-core/distinfo
+++ b/www/hs-snap-core/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/snap-core-0.5.2.tar.gz) = 14d234b4706e5e993e1e5c4178ede3e8ccafa070daf96eb826bc0681e17b52f2
-SIZE (cabal/snap-core-0.5.2.tar.gz) = 74409
+SHA256 (cabal/snap-core-0.7.0.1.tar.gz) = e9b2a4924ed80031d1e0b9a5d7e3a1b5dd831eaf5990819040e453c5991f1c04
+SIZE (cabal/snap-core-0.7.0.1.tar.gz) = 84601
diff --git a/www/hs-snap-core/files/patch-snap-core.cabal b/www/hs-snap-core/files/patch-snap-core.cabal
deleted file mode 100644
index 13f6f5ad7b5d..000000000000
--- a/www/hs-snap-core/files/patch-snap-core.cabal
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./snap-core.cabal.orig 2011-06-23 17:08:48.000000000 +0200
-+++ ./snap-core.cabal 2011-07-18 15:34:06.000000000 +0200
-@@ -133,7 +133,7 @@
- blaze-builder >= 0.2.1.4 && <0.4,
- bytestring,
- bytestring-nums,
-- case-insensitive >= 0.2 && < 0.3,
-+ case-insensitive >= 0.2,
- containers,
- deepseq >= 1.1 && <1.2,
- directory,
diff --git a/www/hs-snap-core/pkg-descr b/www/hs-snap-core/pkg-descr
index 3b7337b19caf..ba96f088ad09 100644
--- a/www/hs-snap-core/pkg-descr
+++ b/www/hs-snap-core/pkg-descr
@@ -1,4 +1,21 @@
-Snap is a simple and fast web development framework and server written in
-Haskell.
+Snap is a simple and fast web development framework and server written
+in Haskell. This library contains the core definitions and types for
+the Snap framework, including:
-WWW: http://snapframework.com/
+ 1. Primitive types and functions for HTTP (requests, responses, cookies,
+ post/query parameters, etc).
+
+ 2. Type aliases and helper functions for Iteratee I/O.
+
+ 3. A monad for programming web handlers called "Snap", inspired by happstack's,
+ which allows:
+
+ - Stateful access to the HTTP request and response objects.
+
+ - Monadic failure (i.e. MonadPlus/Alternative instances) for declining to
+ handle requests and chaining handlers together.
+
+ - Early termination of the computation if you know early what you want to
+ return and want to prevent further monadic processing.
+
+WWW: http://snapframework.com/