aboutsummaryrefslogtreecommitdiff
path: root/www/hs-snap-core
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-08-13 21:50:10 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-08-13 21:50:10 +0000
commit00d415717d0f3169db78d4665769a7da50b15537 (patch)
tree2cecfe8a31e970683b7eae3c25931395a144e69a /www/hs-snap-core
parentedc96cba7c59d9535053250fafa37a5791bd34c5 (diff)
downloadports-00d415717d0f3169db78d4665769a7da50b15537.tar.gz
ports-00d415717d0f3169db78d4665769a7da50b15537.zip
Notes
Diffstat (limited to 'www/hs-snap-core')
-rw-r--r--www/hs-snap-core/Makefile25
-rw-r--r--www/hs-snap-core/distinfo2
-rw-r--r--www/hs-snap-core/files/patch-snap-core.cabal11
-rw-r--r--www/hs-snap-core/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/www/hs-snap-core/Makefile b/www/hs-snap-core/Makefile
new file mode 100644
index 000000000000..3331b13d1f38
--- /dev/null
+++ b/www/hs-snap-core/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: hs-snap-core
+# Date created: September 19, 2010
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= snap-core
+PORTVERSION= 0.5.2
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Snap: A Haskell Web Framework (Core)
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= attoparsec>=0.8.0.2 attoparsec-enumerator>=0.2.0.3 \
+ blaze-builder>=0.2.1.4 bytestring-nums case-insensitive \
+ deepseq>=1.1 dlist>=0.5 enumerator>=0.4.13.1 \
+ MonadCatchIO-transformers>=0.2.1 mtl>=2 text>=0.11 \
+ transformers>=0.2 unix-compat>=0.2 vector>=0.6 zlib
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-snap-core/distinfo b/www/hs-snap-core/distinfo
new file mode 100644
index 000000000000..62a6ef3f3e0d
--- /dev/null
+++ b/www/hs-snap-core/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/snap-core-0.5.2.tar.gz) = 14d234b4706e5e993e1e5c4178ede3e8ccafa070daf96eb826bc0681e17b52f2
+SIZE (cabal/snap-core-0.5.2.tar.gz) = 74409
diff --git a/www/hs-snap-core/files/patch-snap-core.cabal b/www/hs-snap-core/files/patch-snap-core.cabal
new file mode 100644
index 000000000000..13f6f5ad7b5d
--- /dev/null
+++ b/www/hs-snap-core/files/patch-snap-core.cabal
@@ -0,0 +1,11 @@
+--- ./snap-core.cabal.orig 2011-06-23 17:08:48.000000000 +0200
++++ ./snap-core.cabal 2011-07-18 15:34:06.000000000 +0200
+@@ -133,7 +133,7 @@
+ blaze-builder >= 0.2.1.4 && <0.4,
+ bytestring,
+ bytestring-nums,
+- case-insensitive >= 0.2 && < 0.3,
++ case-insensitive >= 0.2,
+ containers,
+ deepseq >= 1.1 && <1.2,
+ directory,
diff --git a/www/hs-snap-core/pkg-descr b/www/hs-snap-core/pkg-descr
new file mode 100644
index 000000000000..3b7337b19caf
--- /dev/null
+++ b/www/hs-snap-core/pkg-descr
@@ -0,0 +1,4 @@
+Snap is a simple and fast web development framework and server written in
+Haskell.
+
+WWW: http://snapframework.com/