aboutsummaryrefslogtreecommitdiff
path: root/www/hs-snap/Makefile
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-08-13 23:28:56 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-08-13 23:28:56 +0000
commit5262591e116a9e794e6694c8f64baea1179b1876 (patch)
tree08fb8e42217c729c456171db634b4cbdeed446ef /www/hs-snap/Makefile
parentbba2b6ca97532e19b875e556d3c96ee39f0ef659 (diff)
downloadports-5262591e116a9e794e6694c8f64baea1179b1876.tar.gz
ports-5262591e116a9e794e6694c8f64baea1179b1876.zip
Notes
Diffstat (limited to 'www/hs-snap/Makefile')
-rw-r--r--www/hs-snap/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/hs-snap/Makefile b/www/hs-snap/Makefile
new file mode 100644
index 000000000000..b30fa8291fa1
--- /dev/null
+++ b/www/hs-snap/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: hs-snap
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= snap
+PORTVERSION= 0.5.2
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Snap: project starter executable and glue code library
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= attoparsec>=0.8.0.2 blaze-builder>=0.2.1.4 bytestring-nums \
+ cereal>=0.3 directory-tree>=0.10 dlist>=0.5 enumerator>=0.4.13.1 \
+ heist>=0.5 hint>=0.3.3.1 MonadCatchIO-transformers>=0.2.1 \
+ mtl>=2 snap-core>=0.5.2 snap-server>=0.5.2 text>=0.11 \
+ unix-compat zlib
+
+EXECUTABLE= snap
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>