aboutsummaryrefslogtreecommitdiff
path: root/www/hs-snap
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /www/hs-snap
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
Notes
Diffstat (limited to 'www/hs-snap')
-rw-r--r--www/hs-snap/Makefile23
-rw-r--r--www/hs-snap/distinfo4
-rw-r--r--www/hs-snap/files/patch-snap.cabal19
3 files changed, 31 insertions, 15 deletions
diff --git a/www/hs-snap/Makefile b/www/hs-snap/Makefile
index 9feb788f049c..3c28b02b3a22 100644
--- a/www/hs-snap/Makefile
+++ b/www/hs-snap/Makefile
@@ -1,27 +1,24 @@
# $FreeBSD$
PORTNAME= snap
-PORTVERSION= 0.12.0
-PORTREVISION= 4
+PORTVERSION= 0.13.2.8
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Top-level package for the Snap Web Framework
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-USE_CABAL= aeson>=0.6 attoparsec>=0.10 cereal>=0.3 clientsession>=0.8 \
- comonad>=1.1 configurator>=0.1 directory-tree>=0.10 \
- dlist>=0.5 errors>=1.4 hashable heist>=0.12 lens>=3.7.6 \
- logict>=0.4.2 MonadCatchIO-transformers>=0.2 mtl>2.0 \
- mwc-random>=0.8 pwstore-fast>=2.2 regex-posix>=0.95 \
- snap-core>=0.9 snap-server>=0.9 stm>=2.2 syb>=0.1 tagged \
- text>=0.11 transformers>=0.2 unordered-containers>=0.1.4 \
- vector>=0.7.1 vector-algorithms>=0.4 xmlhtml>=0.1
+USE_CABAL= aeson attoparsec>=0.10 cereal>=0.3 clientsession>=0.8 \
+ comonad>=1.1 configurator>=0.1 directory-tree>=0.11 \
+ directory-tree>=0.10 dlist>=0.5 errors>=1.4 hashable \
+ heist>=0.13 lens>=3.7.6 logict>=0.4.2 MonadCatchIO-transformers>=0.2 \
+ mtl>2.0 mwc-random>=0.8 pwstore-fast>=2.2 regex-posix>=0.95 \
+ snap-core>=0.9 snap-server>=0.9 stm>=2.2 syb>=0.1 \
+ text>=0.11 unordered-containers>=0.1.4 vector>=0.7.1 \
+ vector-algorithms>=0.4 xmlhtml>=0.1
EXECUTABLE= snap
-IGNORE_DYNAMIC= yes
-
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-snap/distinfo b/www/hs-snap/distinfo
index 541a2af02690..c03d580a7ea6 100644
--- a/www/hs-snap/distinfo
+++ b/www/hs-snap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/snap-0.12.0.tar.gz) = cec5990f0063be66453941cf91226051c00a8260708573c89f8e650ef7aa8c59
-SIZE (cabal/snap-0.12.0.tar.gz) = 82197
+SHA256 (cabal/snap-0.13.2.8.tar.gz) = ef2fa6b87e2f4eac56d8c95320575adea7eb7ae1c5914209a0590aae728036cb
+SIZE (cabal/snap-0.13.2.8.tar.gz) = 83938
diff --git a/www/hs-snap/files/patch-snap.cabal b/www/hs-snap/files/patch-snap.cabal
new file mode 100644
index 000000000000..3cdfd461bfdb
--- /dev/null
+++ b/www/hs-snap/files/patch-snap.cabal
@@ -0,0 +1,19 @@
+--- ./snap.cabal.orig 2014-07-03 21:45:03.000000000 +0200
++++ ./snap.cabal 2014-07-29 12:40:27.405965571 +0200
+@@ -186,7 +186,7 @@
+ else
+ build-depends:
+ base >= 4.4 && < 5,
+- lens >= 3.7.6 && < 4.2
++ lens >= 3.7.6 && < 4.4
+
+ extensions:
+ BangPatterns,
+@@ -236,6 +236,7 @@
+ text >= 0.11 && < 1.2
+
+ extensions:
++ TemplateHaskell
+ OverloadedStrings
+
+ ghc-prof-options: -prof -auto-all