aboutsummaryrefslogtreecommitdiff
path: root/www/hs-yesod-auth
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /www/hs-yesod-auth
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
downloadports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.tar.gz
ports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.zip
Notes
Diffstat (limited to 'www/hs-yesod-auth')
-rw-r--r--www/hs-yesod-auth/Makefile17
-rw-r--r--www/hs-yesod-auth/distinfo4
-rw-r--r--www/hs-yesod-auth/files/patch-yesod-auth.cabal21
3 files changed, 31 insertions, 11 deletions
diff --git a/www/hs-yesod-auth/Makefile b/www/hs-yesod-auth/Makefile
index 28581ed1990c..c23133822c4f 100644
--- a/www/hs-yesod-auth/Makefile
+++ b/www/hs-yesod-auth/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= yesod-auth
-PORTVERSION= 1.2.0
-PORTREVISION= 4
+PORTVERSION= 1.3.4
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,13 +9,13 @@ COMMENT= Authentication for Yesod
LICENSE= MIT
-USE_CABAL= aeson>=0.5 authenticate>=1.3 blaze-html>=0.5 \
- blaze-markup>=0.5.1 data-default email-validate>=1.0 \
- file-embed hamlet>=1.1 http-conduit>=1.5 http-types \
- lifted-base>=0.1 mime-mail>=0.3 network persistent>=1.2 \
- persistent-template>=1.2 pureMD5>=2.0 pwstore-fast>=2.2 \
- random>=1.0.0.2 SHA>=1.4.1.3 shakespeare-css>=1.0 \
- shakespeare-js>=1.0.2 text>=0.7 transformers>=0.2.2 \
+USE_CABAL= aeson>=0.5 authenticate>=1.3 base16-bytestring \
+ base64-bytestring blaze-builder blaze-html>=0.5 \
+ blaze-markup>=0.5.1 byteable conduit conduit-extra cryptohash \
+ data-default email-validate>=1.0 file-embed http-client \
+ http-conduit>=1.5 http-types lifted-base>=0.1 mime-mail>=0.3 \
+ network persistent>=1.2 persistent-template>=1.2 \
+ random>=1.0.0.2 resourcet safe shakespeare text>=0.7 \
unordered-containers wai>=1.4 yesod-core>=1.2 yesod-form>=1.3 \
yesod-persistent>=1.2
diff --git a/www/hs-yesod-auth/distinfo b/www/hs-yesod-auth/distinfo
index c07f593a5174..1418abc5cc97 100644
--- a/www/hs-yesod-auth/distinfo
+++ b/www/hs-yesod-auth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/yesod-auth-1.2.0.tar.gz) = 0740b3fc8825ca9d97ae3589cb86ff9d81e87c1703f8d2341fd45b9ed728b7aa
-SIZE (cabal/yesod-auth-1.2.0.tar.gz) = 26852
+SHA256 (cabal/yesod-auth-1.3.4.tar.gz) = 1ee00d9afefb3fd225e5163f689561ebf8d9a1862eb04a72a2dcb89574b61c8d
+SIZE (cabal/yesod-auth-1.3.4.tar.gz) = 36720
diff --git a/www/hs-yesod-auth/files/patch-yesod-auth.cabal b/www/hs-yesod-auth/files/patch-yesod-auth.cabal
new file mode 100644
index 000000000000..4a117f77df80
--- /dev/null
+++ b/www/hs-yesod-auth/files/patch-yesod-auth.cabal
@@ -0,0 +1,21 @@
+--- ./yesod-auth.cabal.orig 2014-06-05 07:12:31.000000000 +0200
++++ ./yesod-auth.cabal 2014-07-13 02:34:37.000000000 +0200
+@@ -33,10 +33,7 @@
+ , text >= 0.7
+ , mime-mail >= 0.3
+ , yesod-persistent >= 1.2
+- , hamlet >= 1.1
+ , shakespeare
+- , shakespeare-css >= 1.0
+- , shakespeare-js >= 1.0.2
+ , containers
+ , unordered-containers
+ , yesod-form >= 1.3 && < 1.4
+@@ -63,7 +60,6 @@
+ , blaze-builder
+ , conduit
+ , conduit-extra
+- , attoparsec-conduit
+
+ exposed-modules: Yesod.Auth
+ Yesod.Auth.BrowserId