aboutsummaryrefslogtreecommitdiff
path: root/www/hs-yesod-auth
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
committerGabor Pali <pgj@FreeBSD.org>2015-08-20 23:02:14 +0000
commit39b8e49140afdb1d1d001c477befb4b05efa7fc3 (patch)
tree607a5ca77efd301a2b4dc49b05d108829fcffa77 /www/hs-yesod-auth
parent75b64b1cb42c127b71646f039269eb7bd560d8ef (diff)
downloadports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.tar.gz
ports-39b8e49140afdb1d1d001c477befb4b05efa7fc3.zip
Notes
Diffstat (limited to 'www/hs-yesod-auth')
-rw-r--r--www/hs-yesod-auth/Makefile15
-rw-r--r--www/hs-yesod-auth/distinfo4
-rw-r--r--www/hs-yesod-auth/files/patch-yesod-auth.cabal21
3 files changed, 10 insertions, 30 deletions
diff --git a/www/hs-yesod-auth/Makefile b/www/hs-yesod-auth/Makefile
index 5b1f9365d88f..08d92b2b8128 100644
--- a/www/hs-yesod-auth/Makefile
+++ b/www/hs-yesod-auth/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= yesod-auth
-PORTVERSION= 1.3.4
-PORTREVISION= 1
+PORTVERSION= 1.4.6
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,15 +9,17 @@ COMMENT= Authentication for Yesod
LICENSE= MIT
-USE_CABAL= aeson>=0.5 authenticate>=1.3 base16-bytestring \
+USE_CABAL= aeson>=0.7 authenticate>=1.3 base16-bytestring \
base64-bytestring blaze-builder blaze-html>=0.5 \
blaze-markup>=0.5.1 byteable conduit conduit-extra cryptohash \
data-default email-validate>=1.0 file-embed http-client \
http-conduit>=1.5 http-types lifted-base>=0.1 mime-mail>=0.3 \
- network persistent>=1.2 persistent-template>=1.2 \
- random>=1.0.0.2 resourcet safe shakespeare text>=0.7 \
- unordered-containers wai>=1.4 yesod-core>=1.2 yesod-form>=1.3 \
- yesod-persistent>=1.2
+ network>=2.6 network-uri>=2.6 nonce>=1.0.2 persistent>=2.1 \
+ persistent-template>=2.1 random>=1.0.0.2 resourcet safe \
+ shakespeare text>=0.7 unordered-containers wai>=1.4 \
+ yesod-core>=1.4 yesod-form>=1.4 yesod-persistent>=1.4
+
+FLAGS_ENABLE= network-uri
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod-auth/distinfo b/www/hs-yesod-auth/distinfo
index 1418abc5cc97..ef7e0a9b6c2c 100644
--- a/www/hs-yesod-auth/distinfo
+++ b/www/hs-yesod-auth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/yesod-auth-1.3.4.tar.gz) = 1ee00d9afefb3fd225e5163f689561ebf8d9a1862eb04a72a2dcb89574b61c8d
-SIZE (cabal/yesod-auth-1.3.4.tar.gz) = 36720
+SHA256 (cabal/yesod-auth-1.4.6.tar.gz) = 5d6c74908daabe5e6d5bdff919d3e8e2bccdf5e599da430135474cbce30d1030
+SIZE (cabal/yesod-auth-1.4.6.tar.gz) = 42895
diff --git a/www/hs-yesod-auth/files/patch-yesod-auth.cabal b/www/hs-yesod-auth/files/patch-yesod-auth.cabal
deleted file mode 100644
index 4a117f77df80..000000000000
--- a/www/hs-yesod-auth/files/patch-yesod-auth.cabal
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./yesod-auth.cabal.orig 2014-06-05 07:12:31.000000000 +0200
-+++ ./yesod-auth.cabal 2014-07-13 02:34:37.000000000 +0200
-@@ -33,10 +33,7 @@
- , text >= 0.7
- , mime-mail >= 0.3
- , yesod-persistent >= 1.2
-- , hamlet >= 1.1
- , shakespeare
-- , shakespeare-css >= 1.0
-- , shakespeare-js >= 1.0.2
- , containers
- , unordered-containers
- , yesod-form >= 1.3 && < 1.4
-@@ -63,7 +60,6 @@
- , blaze-builder
- , conduit
- , conduit-extra
-- , attoparsec-conduit
-
- exposed-modules: Yesod.Auth
- Yesod.Auth.BrowserId