aboutsummaryrefslogtreecommitdiff
path: root/www/hs-yesod
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-02-18 17:53:13 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-02-18 17:53:13 +0000
commit02e663d404dab2d7e03c52ba8aa40a5c0efd8bb7 (patch)
tree980e4478a666cf94e810793450fd351b422dffd0 /www/hs-yesod
parent8527e49545eb2da6017e8fdc4bc01d125c3163fe (diff)
downloadports-02e663d404dab2d7e03c52ba8aa40a5c0efd8bb7.tar.gz
ports-02e663d404dab2d7e03c52ba8aa40a5c0efd8bb7.zip
Notes
Diffstat (limited to 'www/hs-yesod')
-rw-r--r--www/hs-yesod/Makefile39
-rw-r--r--www/hs-yesod/distinfo2
-rw-r--r--www/hs-yesod/pkg-descr8
3 files changed, 49 insertions, 0 deletions
diff --git a/www/hs-yesod/Makefile b/www/hs-yesod/Makefile
new file mode 100644
index 000000000000..985a3eb7e39a
--- /dev/null
+++ b/www/hs-yesod/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: hs-yesod
+# Date created: December 26, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= yesod
+PORTVERSION= 0.9.4.1
+CATEGORIES= www haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Creation of type-safe, RESTful web applications
+
+LICENSE= BSD
+
+USE_CABAL= attoparsec>=0.10 blaze-builder>=0.2.1.4 blaze-html>=0.4.1.3 \
+ hamlet>=0.10 http-types>=0.6.1 monad-control>=0.2 \
+ parsec>=2.1 shakespeare-css>=0.10 shakespeare-js>=0.10 \
+ shakespeare-text>=0.10 text>=0.11 transformers>=0.2.2 \
+ unix-compat>=0.2 wai>=0.4 wai-extra>=0.4.6 warp>=0.4 \
+ yesod-auth>=0.7 yesod-core>=0.9.3.4 yesod-form>=0.3 \
+ yesod-json>=0.2.2 yesod-persistent>=0.2
+
+EXECUTABLE= yesod
+
+OPTIONS= THREADED "Multi-threaded execution" on
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+.include <bsd.port.options.mk>
+
+.if defined(WITH_THREADED)
+CONFIGURE_ARGS+= --flags="threaded"
+.else
+CONFIGURE_ARGS+= --flags="-threaded"
+.endif
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/www/hs-yesod/distinfo b/www/hs-yesod/distinfo
new file mode 100644
index 000000000000..099257ba50cd
--- /dev/null
+++ b/www/hs-yesod/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/yesod-0.9.4.1.tar.gz) = d80c32a373f40014eb79fa95621da1fa10a243c10a836808805a451a52258d35
+SIZE (cabal/yesod-0.9.4.1.tar.gz) = 32368
diff --git a/www/hs-yesod/pkg-descr b/www/hs-yesod/pkg-descr
new file mode 100644
index 000000000000..d7f676dfee21
--- /dev/null
+++ b/www/hs-yesod/pkg-descr
@@ -0,0 +1,8 @@
+A RESTful web framework with strong compile-time guarantees of correctness.
+It also affords space efficient code, highly concurrent loads, and
+portability to many deployment backends (via the wai package), from CGI
+to stand-alone serving. Yesod also focuses on developer productivity.
+Yesod integrates well with tools for all your basic web development (wai,
+persistent, and shakespeare/hamlet).
+
+WWW: http://www.yesodweb.com/