aboutsummaryrefslogtreecommitdiff
path: root/www/hs-yesod
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /www/hs-yesod
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
downloadports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.tar.gz
ports-cc555442337c7591ab5c3fd19ad8e3e185a256b0.zip
Notes
Diffstat (limited to 'www/hs-yesod')
-rw-r--r--www/hs-yesod/Makefile14
-rw-r--r--www/hs-yesod/distinfo4
-rw-r--r--www/hs-yesod/files/patch-yesod.cabal19
3 files changed, 27 insertions, 10 deletions
diff --git a/www/hs-yesod/Makefile b/www/hs-yesod/Makefile
index b9a9a7b08e01..de8876a177fa 100644
--- a/www/hs-yesod/Makefile
+++ b/www/hs-yesod/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= yesod
-PORTVERSION= 1.2.0.1
-PORTREVISION= 4
+PORTVERSION= 1.2.6.1
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,12 +9,11 @@ COMMENT= Creation of type-safe, RESTful web applications
LICENSE= MIT
-USE_CABAL= aeson blaze-html>=0.5 blaze-markup>=0.5.1 data-default \
- hamlet>=1.1 monad-control>=0.3 network-conduit safe \
- shakespeare-css>=1.0 shakespeare-js>=1.0.2 text \
- transformers>=0.2.2 unordered-containers wai>=1.3 \
- wai-extra>=1.3 warp>=1.3 yaml yesod-auth>=1.2 yesod-core>=1.2 \
- yesod-form>=1.3 yesod-persistent>=1.2
+USE_CABAL= aeson blaze-html>=0.5 blaze-markup>=0.5.1 conduit-extra \
+ data-default fast-logger monad-control>=0.3 monad-logger \
+ safe shakespeare>=2.0 text unordered-containers wai>=1.3 \
+ wai-extra>=1.3 warp>=1.3 yaml yesod-auth>=1.2 \
+ yesod-core>=1.2.2 yesod-form>=1.3 yesod-persistent>=1.2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/www/hs-yesod/distinfo b/www/hs-yesod/distinfo
index e02b4ba9d926..03a4bb5008e3 100644
--- a/www/hs-yesod/distinfo
+++ b/www/hs-yesod/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/yesod-1.2.0.1.tar.gz) = a32a88bd9cd2fcda76965c66457241acc25a652e8eb9b58d144afa5929e013f2
-SIZE (cabal/yesod-1.2.0.1.tar.gz) = 7652
+SHA256 (cabal/yesod-1.2.6.1.tar.gz) = a2c624171e86f4c56f55634d02e72ea911147e1e40d3c322254cc72ed9ba38f6
+SIZE (cabal/yesod-1.2.6.1.tar.gz) = 7846
diff --git a/www/hs-yesod/files/patch-yesod.cabal b/www/hs-yesod/files/patch-yesod.cabal
new file mode 100644
index 000000000000..bbd9afdfa00a
--- /dev/null
+++ b/www/hs-yesod/files/patch-yesod.cabal
@@ -0,0 +1,19 @@
+--- ./yesod.cabal.orig 2014-06-09 09:48:13.000000000 +0200
++++ ./yesod.cabal 2014-07-13 03:05:49.000000000 +0200
+@@ -30,16 +30,12 @@
+ , transformers >= 0.2.2
+ , wai >= 1.3
+ , wai-extra >= 1.3
+- , hamlet >= 1.1
+- , shakespeare-js >= 1.0.2
+- , shakespeare-css >= 1.0
+ , warp >= 1.3
+ , blaze-html >= 0.5
+ , blaze-markup >= 0.5.1
+ , aeson
+ , safe
+ , data-default
+- , network-conduit
+ , unordered-containers
+ , yaml
+ , text