aboutsummaryrefslogtreecommitdiff
path: root/www/httest/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-16 20:34:40 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-16 20:34:40 +0000
commit08145b44dbcd42f5e8ec4a2770b008268a413333 (patch)
tree6e606e2e2824259a167697647fdb690f7ae60110 /www/httest/Makefile
parent6d226e5bb02e420d249e3b47fc1b1b5d6d0b5fd5 (diff)
downloadports-08145b44dbcd42f5e8ec4a2770b008268a413333.tar.gz
ports-08145b44dbcd42f5e8ec4a2770b008268a413333.zip
Notes
Diffstat (limited to 'www/httest/Makefile')
-rw-r--r--www/httest/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/www/httest/Makefile b/www/httest/Makefile
index d339c95a832c..d139ce618cbe 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -18,6 +18,8 @@ LICENSE= AL2
LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1 \
pcre:${PORTSDIR}/devel/pcre
+OPTIONS_DEFINE= EXAMPLES
+
CONFIGURE_ARGS= --enable-lua-module \
--with-apr="${LOCALBASE}/bin" \
--with-apr-util="${LOCALBASE}/bin" \
@@ -39,10 +41,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|`$$APR_CONFIG --cflags`||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/generate_modules_c.sh
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${EXAMPLESDIR}
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${EXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${EXAMPLESDIR}/
.endif
.include <bsd.port.mk>