aboutsummaryrefslogtreecommitdiff
path: root/www/httpcore
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2008-09-03 08:06:18 +0000
committerAlex Dupre <ale@FreeBSD.org>2008-09-03 08:06:18 +0000
commit2f946552f574933971ca6baae30da68a86675d99 (patch)
treeacc020cf8f8a0444045cca4acee1c1dc1e0c0639 /www/httpcore
parent1098ca0851a89f4dda31ca4be5f5910d679c5339 (diff)
downloadports-2f946552f574933971ca6baae30da68a86675d99.tar.gz
ports-2f946552f574933971ca6baae30da68a86675d99.zip
Notes
Diffstat (limited to 'www/httpcore')
-rw-r--r--www/httpcore/Makefile45
-rw-r--r--www/httpcore/distinfo3
-rw-r--r--www/httpcore/pkg-descr20
3 files changed, 68 insertions, 0 deletions
diff --git a/www/httpcore/Makefile b/www/httpcore/Makefile
new file mode 100644
index 000000000000..539fd0f12372
--- /dev/null
+++ b/www/httpcore/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: HttpCore
+# Date created: 11 Jul 2008
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= httpcore
+DISTVERSION= 4.0-beta2
+CATEGORIES= www java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= httpcomponents/${PORTNAME}/binary
+DISTNAME= httpcomponents-core-${DISTVERSION}-bin
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Java components implementing the base HTTP protocol
+
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/httpcomponents-core-${DISTVERSION}
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar %%JAVAJARDIR%%/${PORTNAME}-nio.jar
+
+PORTDOCS= *
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-${DISTVERSION}.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [DONE]"
+ @${ECHO_MSG} -n ">> Installing JAR file as ${JAVAJARDIR}/${PORTNAME}-nio.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}-nio-${DISTVERSION}.jar \
+ ${JAVAJARDIR}/${PORTNAME}-nio.jar
+ @${ECHO_MSG} " [DONE]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/javadoc && ${FIND} ${PORTNAME} ${PORTNAME}-nio \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${INSTALL_DATA} ${WRKSRC}/RELEASE_NOTES.txt ${DOCSDIR}/
+ @${ECHO_MSG} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/httpcore/distinfo b/www/httpcore/distinfo
new file mode 100644
index 000000000000..e89b166beece
--- /dev/null
+++ b/www/httpcore/distinfo
@@ -0,0 +1,3 @@
+MD5 (httpcomponents-core-4.0-beta2-bin.tar.gz) = e33280fe917bc1f2f934bc24fcc8b673
+SHA256 (httpcomponents-core-4.0-beta2-bin.tar.gz) = 01969c8c0cffb36873f6ffa29f48beb66ece7b927a2c86b65f6ae365d39a88ce
+SIZE (httpcomponents-core-4.0-beta2-bin.tar.gz) = 921495
diff --git a/www/httpcore/pkg-descr b/www/httpcore/pkg-descr
new file mode 100644
index 000000000000..b719c7e95ad9
--- /dev/null
+++ b/www/httpcore/pkg-descr
@@ -0,0 +1,20 @@
+The HttpCore components implement the most fundamental aspects of the HTTP
+protocol. They are nonetheless sufficient to develop basic client-side and
+server-side HTTP services with a minimal footprint and no external
+dependencies.
+
+The HttpCore base module contains the public API and the default
+implementation based on the Java classic (blocking) I/O model. It requires
+a Java 1.3 compatible runtime and has no dependency on any external libraries.
+
+HttpCore NIO extensions contain optional components that leverage the event
+driven, non-blocking I/O (NIO) model. HttpCore NIO extensions require a
+Java 5.0 compatible runtime and the HttpCore base module. HttpCore NIO
+extensions are intended for those usage scenarios where raw throughput is
+less important than the ability to handle thousands of simultaneous HTTP
+connections in a resource efficient manner.
+
+WWW: http://hc.apache.org/httpcomponents-core/
+
+- Alex Dupre
+ale@FreeBSD.org