aboutsummaryrefslogtreecommitdiff
path: root/www/httpie/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-06-03 10:56:56 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-06-03 10:56:56 +0000
commit48f7c3e659647111624559efb3fface43e268567 (patch)
tree399202e1d94dbb7a59f7dbb198579a8822c4943d /www/httpie/Makefile
parent7ead5949fa07749ccb0b7c3fc39cec716df1c213 (diff)
Notes
Diffstat (limited to 'www/httpie/Makefile')
-rw-r--r--www/httpie/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/httpie/Makefile b/www/httpie/Makefile
new file mode 100644
index 000000000000..2b030304e872
--- /dev/null
+++ b/www/httpie/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= httpie
+PORTVERSION= 0.8.0
+CATEGORIES= www
+MASTER_SITES= GH
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= Command line HTTP client
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}pygments>0:${PORTSDIR}/textproc/py-pygments
+
+USE_GITHUB= yes
+GH_ACCOUNT= jakubroztocil
+GH_COMMIT= 43cc3e7
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>