aboutsummaryrefslogtreecommitdiff
path: root/www/hudson
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-07-04 20:48:23 +0000
committerRene Ladan <rene@FreeBSD.org>2016-07-04 20:48:23 +0000
commit19f31a471be151c3b37c2a53435168e9ee3e74cf (patch)
tree239999706f3f6d8d0babe480ab358d7675c96f78 /www/hudson
parent8c8c4d9eb88ee2827497807f6f0030ce52dae781 (diff)
downloadports-19f31a471be151c3b37c2a53435168e9ee3e74cf.tar.gz
ports-19f31a471be151c3b37c2a53435168e9ee3e74cf.zip
Notes
Diffstat (limited to 'www/hudson')
-rw-r--r--www/hudson/Makefile37
-rw-r--r--www/hudson/distinfo2
-rw-r--r--www/hudson/files/hudson.in75
-rw-r--r--www/hudson/pkg-descr17
4 files changed, 0 insertions, 131 deletions
diff --git a/www/hudson/Makefile b/www/hudson/Makefile
deleted file mode 100644
index 1481920bf66e..000000000000
--- a/www/hudson/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# Created by: Herve Quiroz <hq@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= hudson
-PORTVERSION= 1.395
-CATEGORIES= www java devel
-MASTER_SITES= http://download.hudson-labs.org/war/${PORTVERSION}/
-DISTNAME= hudson
-EXTRACT_SUFX= .war
-DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
-EXTRACT_ONLY=
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Extensible continuous integration engine
-
-BROKEN= unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2016-07-04
-
-USE_JAVA= yes
-JAVA_VERSION= 1.6+
-NO_BUILD= yes
-
-USE_RC_SUBR= hudson
-
-HUDSON_HOME?= /var/lib/hudson
-HUDSON_USER?= www
-HUDSON_GROUP?= www
-
-PLIST_FILES= %%DATADIR%%/${DISTNAME}${EXTRACT_SUFX}
-SUB_LIST+= HUDSON_HOME=${HUDSON_HOME} HUDSON_USER=${HUDSON_USER} HUDSON_GROUP=${HUDSON_GROUP} JAVA_HOME=${JAVA_HOME}
-
-do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX} ${STAGEDIR}${DATADIR}/
-
-.include <bsd.port.mk>
diff --git a/www/hudson/distinfo b/www/hudson/distinfo
deleted file mode 100644
index cfc962b7c1dd..000000000000
--- a/www/hudson/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (hudson-1.395/hudson.war) = 20b7099d04a97462f45aefbf533f6c03f238c553ab82cec5aeda38c2825a8af0
-SIZE (hudson-1.395/hudson.war) = 36655613
diff --git a/www/hudson/files/hudson.in b/www/hudson/files/hudson.in
deleted file mode 100644
index c67bd3704c35..000000000000
--- a/www/hudson/files/hudson.in
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: hudson
-# REQUIRE: NETWORKING SERVERS
-# BEFORE: DAEMON
-# KEYWORD: shutdown
-
-#
-# Configuration settings for hudson in /etc/rc.conf:
-#
-# hudson_enable (bool):
-# Set to "NO" by default.
-# Set it to "YES" to enable hudson
-#
-# hudson_args (str):
-# Extra arguments passed to start command
-#
-# hudson_home (str)
-# Set to "%%HUDSON_HOME%%" by default.
-# Set the HUDSON_HOME variable for hudson process
-#
-# hudson_java_home (str):
-# Set to "%%JAVA_HOME%%" by default.
-# Set the Java virtual machine to run hudson
-#
-# hudson_java_opts (str):
-# Set to "" by default.
-# Java VM args to use.
-#
-# hudson_user (str):
-# Set to "%%HUDSON_USER%%" by default.
-# User to run hudson as.
-#
-# hudson_group (str):
-# Set to "%%HUDSON_GROUP%%" by default.
-# Group for data file ownership.
-#
-
-hudson_log_file=/var/log/hudson.log
-
-. /etc/rc.subr
-
-name="hudson"
-rcvar=hudson_enable
-
-load_rc_config "${name}"
-
-: ${hudson_enable="NO"}
-: ${hudson_home="%%HUDSON_HOME%%"}
-: ${hudson_args="--webroot=${hudson_home}/war --httpListenAddress=127.0.0.1 --httpPort=8180 --ajp13ListenAddress=127.0.0.1 --ajp13Port=8009 --prefix=/hudson"}
-: ${hudson_java_home="%%JAVA_HOME%%"}
-: ${hudson_user="%%HUDSON_USER%%"}
-: ${hudson_group="%%HUDSON_GROUP%%"}
-
-pidfile="/var/run/hudson.pid"
-command="/usr/sbin/daemon"
-java_cmd="${hudson_java_home}/bin/java"
-procname="${java_cmd}"
-command_args="-p ${pidfile} ${java_cmd} -DHUDSON_HOME=${hudson_home} ${hudson_java_opts} -jar %%DATADIR%%/hudson.war --logfile=${hudson_log_file} ${hudson_args}"
-required_dirs="${hudson_home}"
-required_files="${hudson_log_file} ${java_cmd}"
-
-start_precmd="setup_files"
-
-setup_files() {
- touch "${hudson_log_file}" "${pidfile}"
- chown "${hudson_user}:${hudson_group}" "${hudson_log_file}" "${pidfile}"
- chmod 640 "${hudson_log_file}"
- install -d -o "${hudson_user}" -g "${hudson_group}" -m 750 "${hudson_home}"
-}
-
-run_rc_command "$1"
diff --git a/www/hudson/pkg-descr b/www/hudson/pkg-descr
deleted file mode 100644
index 1d638238f2bf..000000000000
--- a/www/hudson/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-Hudson monitors executions of repeated jobs, such as building a software
-project or jobs run by cron. Among those things, current Hudson focuses on the
-following two jobs:
-
- 1. Building/testing software projects continuously, just like CruiseControl
- or DamageControl. In a nutshell, Hudson provides an easy-to-use so-called
- continuous integration system, making it easier for developers to integrate
- changes to the project, and making it easier for users to obtain a fresh
- build. The automated, continuous build increases the productivity.
-
- 2. Monitoring executions of externally-run jobs, such as cron jobs and
- procmail jobs, even those that are run on a remote machine. For example, with
- cron, all you receive is regular e-mails that capture the output, and it is
- up to you to look at them diligently and notice when it broke. Hudson keeps
- those outputs and makes it easy for you to notice when something is wrong.
-
-WWW: https://hudson.dev.java.net/