aboutsummaryrefslogtreecommitdiff
path: root/www/hydra/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-20 22:27:12 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-20 22:27:12 +0000
commitc7ce6ff43e4c762904be72db1cf35e261a923bb4 (patch)
treec5a18bb693b7c49ee11565de48a26cc8e331b0e1 /www/hydra/Makefile
parent073868564484435f1f44f2f03a9ca8840a231403 (diff)
downloadports-c7ce6ff43e4c762904be72db1cf35e261a923bb4.tar.gz
ports-c7ce6ff43e4c762904be72db1cf35e261a923bb4.zip
Notes
Diffstat (limited to 'www/hydra/Makefile')
-rw-r--r--www/hydra/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/hydra/Makefile b/www/hydra/Makefile
index 55a9a439d9d7..d678dea4bc21 100644
--- a/www/hydra/Makefile
+++ b/www/hydra/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= hydra
-PORTVERSION= 0.1.3
+PORTVERSION= 0.1.4
CATEGORIES= www
MASTER_SITES= ftp://ftp.hellug.gr/pub/software/hydra/ \
http://hydra.hellug.gr/download/ \
@@ -21,6 +21,8 @@ LIB_DEPENDS= gnutls.7:${PORTSDIR}/security/gnutls
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+
post-patch:
@${REINPLACE_CMD} -e "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
.for file in src/defines.h examples/hydra.conf
@@ -30,7 +32,9 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/etc/hydra
.for file in hydra.conf mime.types
- ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${PREFIX}/etc/hydra
+ ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${PREFIX}/etc/hydra/${file}-dist
+ [ -f ${PREFIX}/etc/hydra/${file} ] || \
+ ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${PREFIX}/etc/hydra/
.endfor
.include <bsd.port.mk>