aboutsummaryrefslogtreecommitdiff
path: root/www/hypermail
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-02-14 12:44:23 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-02-14 12:44:23 +0000
commit205f1ac23dd674163b211b136715384d89c1bf4d (patch)
tree9c81baefcee3d377ac0c3395066592b349bb4959 /www/hypermail
parent3a5a5a3b60daa9f939e7761f8990e8956b5db1b3 (diff)
downloadports-205f1ac23dd674163b211b136715384d89c1bf4d.tar.gz
ports-205f1ac23dd674163b211b136715384d89c1bf4d.zip
Notes
Diffstat (limited to 'www/hypermail')
-rw-r--r--www/hypermail/Makefile4
-rw-r--r--www/hypermail/files/patch-src-pcre-pcreposix.c12
-rw-r--r--www/hypermail/files/patch-src-pcre-pcretest.c27
3 files changed, 41 insertions, 2 deletions
diff --git a/www/hypermail/Makefile b/www/hypermail/Makefile
index 86c6c97dead0..9edebffc203e 100644
--- a/www/hypermail/Makefile
+++ b/www/hypermail/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hypermail
PORTVERSION= 2.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www mail
MASTER_SITES= SF
@@ -15,7 +15,7 @@ MAINTAINER= dan@langille.org
COMMENT= A program to generate a cross-referenced HTML mail archive
LIB_DEPENDS+= gdbm.4:${PORTSDIR}/databases/gdbm \
- pcre.0:${PORTSDIR}/devel/pcre
+ pcre.1:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-htmldir=${PREFIX}/share/doc/hypermail \
diff --git a/www/hypermail/files/patch-src-pcre-pcreposix.c b/www/hypermail/files/patch-src-pcre-pcreposix.c
new file mode 100644
index 000000000000..415d4f4746fa
--- /dev/null
+++ b/www/hypermail/files/patch-src-pcre-pcreposix.c
@@ -0,0 +1,12 @@
+--- src/pcre/pcreposix.c.orig 2003-07-03 20:04:06.000000000 +0200
++++ src/pcre/pcreposix.c 2012-02-14 12:49:55.077985140 +0100
+@@ -217,7 +217,8 @@
+
+ if (preg->re_pcre == NULL) return pcre_posix_error_code(errorptr);
+
+-preg->re_nsub = pcre_info(preg->re_pcre, NULL, NULL);
++pcre_fullinfo((const pcre *)preg->re_pcre, NULL,
++ PCRE_INFO_CAPTURECOUNT, &(preg->re_nsub));
+ return 0;
+ }
+
diff --git a/www/hypermail/files/patch-src-pcre-pcretest.c b/www/hypermail/files/patch-src-pcre-pcretest.c
new file mode 100644
index 000000000000..389e9cb8e1b5
--- /dev/null
+++ b/www/hypermail/files/patch-src-pcre-pcretest.c
@@ -0,0 +1,27 @@
+--- src/pcre/pcretest.c.orig 2012-02-14 12:36:59.560983755 +0100
++++ src/pcre/pcretest.c 2012-02-14 12:45:15.056415687 +0100
+@@ -748,24 +748,6 @@
+ new_info(re, NULL, PCRE_INFO_NAMECOUNT, &namecount);
+ new_info(re, NULL, PCRE_INFO_NAMETABLE, (void *)&nametable);
+
+- old_count = pcre_info(re, &old_options, &old_first_char);
+- if (count < 0) fprintf(outfile,
+- "Error %d from pcre_info()\n", count);
+- else
+- {
+- if (old_count != count) fprintf(outfile,
+- "Count disagreement: pcre_fullinfo=%d pcre_info=%d\n", count,
+- old_count);
+-
+- if (old_first_char != first_char) fprintf(outfile,
+- "First char disagreement: pcre_fullinfo=%d pcre_info=%d\n",
+- first_char, old_first_char);
+-
+- if (old_options != (int)get_options) fprintf(outfile,
+- "Options disagreement: pcre_fullinfo=%ld pcre_info=%d\n",
+- get_options, old_options);
+- }
+-
+ if (size != gotten_store) fprintf(outfile,
+ "Size disagreement: pcre_fullinfo=%d call to malloc for %d\n",
+ size, gotten_store);