aboutsummaryrefslogtreecommitdiff
path: root/www/hypermail
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2014-09-03 13:33:03 +0000
committerErwin Lansing <erwin@FreeBSD.org>2014-09-03 13:33:03 +0000
commitd0988e8f17086efa953462f2246f800454e29521 (patch)
treea080a6e11e340561f6504b0178923e466eed771d /www/hypermail
parent99d3b3ea99e9dc6cdf826372024972049dcc7bc2 (diff)
downloadports-d0988e8f17086efa953462f2246f800454e29521.tar.gz
ports-d0988e8f17086efa953462f2246f800454e29521.zip
Notes
Diffstat (limited to 'www/hypermail')
-rw-r--r--www/hypermail/Makefile31
-rw-r--r--www/hypermail/distinfo2
-rw-r--r--www/hypermail/files/patch-docs__Makefile.in20
-rw-r--r--www/hypermail/files/patch-src-pcre-pcreposix.c12
-rw-r--r--www/hypermail/files/patch-src-pcre-pcretest.c27
-rw-r--r--www/hypermail/files/patch-src__proto.h11
-rw-r--r--www/hypermail/pkg-descr9
-rw-r--r--www/hypermail/pkg-plist14
8 files changed, 126 insertions, 0 deletions
diff --git a/www/hypermail/Makefile b/www/hypermail/Makefile
new file mode 100644
index 000000000000..d2b5d31e1196
--- /dev/null
+++ b/www/hypermail/Makefile
@@ -0,0 +1,31 @@
+# Created by: mjhsieh
+# $FreeBSD$
+
+PORTNAME= hypermail
+PORTVERSION= 2.2.0
+PORTREVISION= 3
+CATEGORIES= www mail
+MASTER_SITES= SF
+
+MAINTAINER= erwin@FreeBSD.org
+COMMENT= Program to generate a cross-referenced HTML mail archive
+
+LICENSE= GPLv2
+
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm \
+ libpcre.so:${PORTSDIR}/devel/pcre
+
+USES= desthack
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-htmldir=${STAGEDIR}${PREFIX}/share/doc/hypermail \
+ --with-gdbm=${LOCALBASE}
+
+CFLAGS+= -L${LOCALBASE}/lib
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/hypermail \
+ ${STAGEDIR}/${PREFIX}/bin/msg2archive \
+ ${STAGEDIR}/${PREFIX}/bin/rdmsg
+
+.include <bsd.port.mk>
diff --git a/www/hypermail/distinfo b/www/hypermail/distinfo
new file mode 100644
index 000000000000..c2edbb785650
--- /dev/null
+++ b/www/hypermail/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hypermail-2.2.0.tar.gz) = 6e1fe59b603b6d8faee583dbae52155282084474d2de4ff6e348bd7e86ea8dff
+SIZE (hypermail-2.2.0.tar.gz) = 1256316
diff --git a/www/hypermail/files/patch-docs__Makefile.in b/www/hypermail/files/patch-docs__Makefile.in
new file mode 100644
index 000000000000..23af9a78274a
--- /dev/null
+++ b/www/hypermail/files/patch-docs__Makefile.in
@@ -0,0 +1,20 @@
+--- docs/Makefile.in.orig Thu Apr 10 15:31:21 2003
++++ docs/Makefile.in Thu Jan 8 00:25:29 2004
+@@ -41,7 +41,9 @@
+ $(INSTALL_PROG) -c -m 0644 hmrc.4 $(mandir)/man4
+
+ install.html:
++.if !defined(NOPORTDOCS)
+ @(if [ ! -d $(htmldir) ]; then mkdir -p $(htmldir); fi)
++ @(if [ ! -d $(imagedir) ]; then mkdir -p $(imagedir); fi)
+ $(INSTALL_PROG) -c -m 0644 hr.yellow.png $(htmldir)
+ $(INSTALL_PROG) -c -m 0644 hypermail.png $(htmldir)
+ $(INSTALL_PROG) -c -m 0644 stars.png $(htmldir)
+@@ -50,6 +52,7 @@
+ $(INSTALL_PROG) -c -m 0644 hypermail-faq.html $(htmldir)
+ $(INSTALL_PROG) -c -m 0644 customizing.html $(htmldir)
+ $(INSTALL_PROG) -c -m 0644 hmrc.html $(htmldir)
++.endif
+
+ clean:
+ clobber:
diff --git a/www/hypermail/files/patch-src-pcre-pcreposix.c b/www/hypermail/files/patch-src-pcre-pcreposix.c
new file mode 100644
index 000000000000..415d4f4746fa
--- /dev/null
+++ b/www/hypermail/files/patch-src-pcre-pcreposix.c
@@ -0,0 +1,12 @@
+--- src/pcre/pcreposix.c.orig 2003-07-03 20:04:06.000000000 +0200
++++ src/pcre/pcreposix.c 2012-02-14 12:49:55.077985140 +0100
+@@ -217,7 +217,8 @@
+
+ if (preg->re_pcre == NULL) return pcre_posix_error_code(errorptr);
+
+-preg->re_nsub = pcre_info(preg->re_pcre, NULL, NULL);
++pcre_fullinfo((const pcre *)preg->re_pcre, NULL,
++ PCRE_INFO_CAPTURECOUNT, &(preg->re_nsub));
+ return 0;
+ }
+
diff --git a/www/hypermail/files/patch-src-pcre-pcretest.c b/www/hypermail/files/patch-src-pcre-pcretest.c
new file mode 100644
index 000000000000..389e9cb8e1b5
--- /dev/null
+++ b/www/hypermail/files/patch-src-pcre-pcretest.c
@@ -0,0 +1,27 @@
+--- src/pcre/pcretest.c.orig 2012-02-14 12:36:59.560983755 +0100
++++ src/pcre/pcretest.c 2012-02-14 12:45:15.056415687 +0100
+@@ -748,24 +748,6 @@
+ new_info(re, NULL, PCRE_INFO_NAMECOUNT, &namecount);
+ new_info(re, NULL, PCRE_INFO_NAMETABLE, (void *)&nametable);
+
+- old_count = pcre_info(re, &old_options, &old_first_char);
+- if (count < 0) fprintf(outfile,
+- "Error %d from pcre_info()\n", count);
+- else
+- {
+- if (old_count != count) fprintf(outfile,
+- "Count disagreement: pcre_fullinfo=%d pcre_info=%d\n", count,
+- old_count);
+-
+- if (old_first_char != first_char) fprintf(outfile,
+- "First char disagreement: pcre_fullinfo=%d pcre_info=%d\n",
+- first_char, old_first_char);
+-
+- if (old_options != (int)get_options) fprintf(outfile,
+- "Options disagreement: pcre_fullinfo=%ld pcre_info=%d\n",
+- get_options, old_options);
+- }
+-
+ if (size != gotten_store) fprintf(outfile,
+ "Size disagreement: pcre_fullinfo=%d call to malloc for %d\n",
+ size, gotten_store);
diff --git a/www/hypermail/files/patch-src__proto.h b/www/hypermail/files/patch-src__proto.h
new file mode 100644
index 000000000000..c66a4702a15c
--- /dev/null
+++ b/www/hypermail/files/patch-src__proto.h
@@ -0,0 +1,11 @@
+--- src/proto.h.orig Thu Jul 3 18:00:18 2003
++++ src/proto.h Thu Jan 8 00:27:25 2004
+@@ -94,7 +94,7 @@
+ char *PushString(struct Push *, const char *);
+ char *PushNString(struct Push *, const char *, int);
+
+-char *strcasestr (char *, const char *);
++// char *strcasestr (char *, const char *);
+ char *strsav(const char *);
+ char *strreplace(char *, char *);
+ void strcpymax(char *, const char *, int);
diff --git a/www/hypermail/pkg-descr b/www/hypermail/pkg-descr
new file mode 100644
index 000000000000..0cdf020926d0
--- /dev/null
+++ b/www/hypermail/pkg-descr
@@ -0,0 +1,9 @@
+Hypermail is a program that takes a file of mail messages in UNIX mailbox
+format and generates a set of cross-referenced HTML documents. Each file that
+is created represents a separate message in the mail archive and contains
+links to other articles, so that the entire archive can be browsed in a
+number of ways by following links. Archives generated by Hypermail can be
+incrementally updated, and Hypermail is set by default to only update
+archives when changes are detected.
+
+WWW: http://www.landfield.com/hypermail/
diff --git a/www/hypermail/pkg-plist b/www/hypermail/pkg-plist
new file mode 100644
index 000000000000..870ede0dbc27
--- /dev/null
+++ b/www/hypermail/pkg-plist
@@ -0,0 +1,14 @@
+bin/hypermail
+bin/msg2archive
+bin/rdmsg
+man/man1/hypermail.1.gz
+man/man4/hmrc.4.gz
+%%PORTDOCS%%%%DOCSDIR%%/archive_search.html
+%%PORTDOCS%%%%DOCSDIR%%/customizing.html
+%%PORTDOCS%%%%DOCSDIR%%/hmrc.html
+%%PORTDOCS%%%%DOCSDIR%%/hr.yellow.png
+%%PORTDOCS%%%%DOCSDIR%%/hypermail-faq.html
+%%PORTDOCS%%%%DOCSDIR%%/hypermail.html
+%%PORTDOCS%%%%DOCSDIR%%/hypermail.png
+%%PORTDOCS%%%%DOCSDIR%%/stars.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%