aboutsummaryrefslogtreecommitdiff
path: root/www/igal/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-11 16:40:38 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-11 16:40:38 +0000
commit325927942ca4b18815ffd71286bd808c97528973 (patch)
treeb2b50e97bd04d994ee54140db0014cd8837cefc5 /www/igal/Makefile
parente678c82be987300c5078670b9a0c271278a041b3 (diff)
downloadports-325927942ca4b18815ffd71286bd808c97528973.tar.gz
ports-325927942ca4b18815ffd71286bd808c97528973.zip
Notes
Diffstat (limited to 'www/igal/Makefile')
-rw-r--r--www/igal/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/igal/Makefile b/www/igal/Makefile
new file mode 100644
index 000000000000..64870b7d99dd
--- /dev/null
+++ b/www/igal/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: igal
+# Date created: 14 Aug 2002
+# Whom: Dylan Carlson <absinthe@pobox.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= igal
+PORTVERSION= 1.3
+CATEGORIES= www graphics
+MASTER_SITES= http://www.stanford.edu/~epop/igal/ \
+ http://planetmirror.com/pub/igal/
+
+MAINTAINER= absinthe@pobox.com
+COMMENT= A static html image gallery generator for *nix
+
+USE_REINPLACE= yes
+
+RUN_DEPENDS= ${LOCALBASE}/bin/cjpeg:${PORTSDIR}/graphics/jpeg \
+ ${LOCALBASE}/include/Magick++.h:${PORTSDIR}/graphics/ImageMagick
+
+MAN1= igal.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile \
+ ${WRKSRC}/igal
+
+.include <bsd.port.mk>