aboutsummaryrefslogtreecommitdiff
path: root/www/ilias
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /www/ilias
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'www/ilias')
-rw-r--r--www/ilias/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/ilias/Makefile b/www/ilias/Makefile
index 66473b56dae2..63ce571bb88e 100644
--- a/www/ilias/Makefile
+++ b/www/ilias/Makefile
@@ -14,10 +14,10 @@ LICENSE= GPLv2
RUN_DEPENDS= convert:graphics/ImageMagick \
zip:archivers/zip \
${UNZIP_CMD}:archivers/unzip \
- ${LOCALBASE}/share/pear/PEAR.php:devel/pear \
- ${LOCALBASE}/share/pear/Auth/Auth.php:security/pear-Auth \
- ${LOCALBASE}/share/pear/MDB2.php:databases/pear-MDB2 \
- ${LOCALBASE}/share/pear/HTML/Template/IT.php:devel/pear-HTML_Template_IT
+ ${LOCALBASE}/share/pear/PEAR.php:devel/pear@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/Auth/Auth.php:security/pear-Auth@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR} \
+ ${LOCALBASE}/share/pear/HTML/Template/IT.php:devel/pear-HTML_Template_IT@${PHP_FLAVOR}
LIB_DEPENDS= libpng.so:graphics/png
USE_GITHUB= yes
@@ -37,8 +37,8 @@ SUB_LIST= ILIASDATADIR=${ILIASDATADIR}
OPTIONS_DEFINE= SCORM2004 Checker Mail
SCORM2004_USE= php=json
-Checker_RUN_DEPENDS= ${LOCALBASE}/share/pear/HTTP/Request.php:www/pear-HTTP_Request
-Mail_RUN_DEPENDS= ${LOCALBASE}/share/pear/Mail.php:mail/pear-Mail
+Checker_RUN_DEPENDS= ${LOCALBASE}/share/pear/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
+Mail_RUN_DEPENDS= ${LOCALBASE}/share/pear/Mail.php:mail/pear-Mail@${PHP_FLAVOR}
EXTRA_FILES= %%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/_mocha \
%%WWWDIR%%/Modules/Chatroom/chat/node_modules/.bin/express \