aboutsummaryrefslogtreecommitdiff
path: root/www/interchange/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-21 12:19:06 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-21 12:19:06 +0000
commit9311a87bb9018d471177b1be93425e943a8e9397 (patch)
treef228130e1c52729306ee431f3c27a2de099c3b66 /www/interchange/Makefile
parente1799dbe430809026017ec5be3153b67824edec9 (diff)
downloadports-9311a87bb9018d471177b1be93425e943a8e9397.tar.gz
ports-9311a87bb9018d471177b1be93425e943a8e9397.zip
Notes
Diffstat (limited to 'www/interchange/Makefile')
-rw-r--r--www/interchange/Makefile106
1 files changed, 70 insertions, 36 deletions
diff --git a/www/interchange/Makefile b/www/interchange/Makefile
index a07052d8977f..316f9241c126 100644
--- a/www/interchange/Makefile
+++ b/www/interchange/Makefile
@@ -6,71 +6,105 @@
#
PORTNAME= interchange
-PORTVERSION= 4.8.7
+PORTVERSION= 5.2.0
CATEGORIES= www
-MASTER_SITES= http://ftp.icdevgroup.org/interchange/4.8/tar/
+MASTER_SITES= http://ftp.icdevgroup.org/interchange/5.2/tar/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= loader@freebsdmall.com
COMMENT= RedHat's database-enabled e-commerce server
-BUILD_DEPENDS= ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement
-
-RUN_DEPENDS= ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
- ${ARCH_PERL}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${ARCH_PERL}/Safe/Hole.pm:${PORTSDIR}/security/p5-Safe-Hole \
- ${ARCH_PERL}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${ARCH_PERL}/MIME/Base64.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/URI/URL.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl \
- ${ARCH_PERL}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+BUILD_DEPENDS= ${ARCH_PERL}/Safe/Hole.pm:${PORTSDIR}/security/p5-Safe-Hole \
+ ${SITE_PERL}/URI/URL.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Business/UPS.pm:${PORTSDIR}/misc/p5-Business-UPS \
+ ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
USE_PERL5= yes
PERL_CONFIGURE= yes
+
+OPTIONS= MYSQL "Add MySQL support" off \
+ PGSQL "Add PostgreSQL support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MYSQL)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+USE_SQLDB= yes
+.endif
+
+.if defined(WITH_PGSQL)
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+USE_SQLDB= yes
+.endif
+
ARCH_PERL= ${SITE_PERL}/${PERL_ARCH}
MAN1= configdump.1 config_prog.1 expire.1 localize.1 \
makecat.1 dump.1 compile_link.1 offline.1 update.1 \
- restart.1 expireall.1 interchange.1
-MAN7= iccattut.7 icdatabase.7 icadvanced.7 icconfig.7 \
- icfoundation.7 icfaq.7 ic_howto_cvs.7 icupgrade.7 \
- ic_ecommerce.7 ictags.7 ictemplates.7
+ restart.1 expireall.1 interchange.1 findtags.1 \
+ ic_mod_perl.1
+
+MAN3= Vend::UserDB.3 \
+ Vend::SQL_Parser.3 \
+ Tie::ShadowHash.3 \
+ Vend::Ship::Postal.3 \
+ Vend::Parser.3 \
+ Vend::Payment::CyberCash.3 \
+ Vend::CounterFile.3 \
+ Vend::Table::Editor.3 \
+ Vend::Payment::TCLink.3 \
+ Vend::Payment::TestPayment.3 \
+ Vend::UserControl.3 \
+ Vend::SOAP::Transport.3 \
+ Vend::Payment::Signio.3 \
+ Vend::Payment::iTransact.3 \
+ Vend::Payment::WellsFargo.3 \
+ Vend::Options::Matrix.3 \
+ Vend::Payment::ECHO.3 \
+ Vend::Payment::Linkpoint.3 \
+ Vend::Ship.3 \
+ Vend::Accounting::SQL_Ledger.3 \
+ Vend::Payment::MCVE.3 \
+ Vend::Interpolate.3 \
+ Vend::Payment::PSiGate.3 \
+ IniConf.3 \
+ Business::Fedex.3 \
+ Vend::Payment::AuthorizeNet.3 \
+ Vend::Payment::EFSNet.3 \
+ Vend::Payment::BoA.3 \
+ Vend::Form.3 \
+ Vend::Payment::Skipjack.3 \
+ Vend::Options::Simple.3 \
+ Vend::Options::Old48.3 \
+ Vend::Ship::QueryUPS.3
USE_REINPLACE= yes
MAKE_ARGS+= NOCPANINSTALL=1 \
- INSTALLARCHLIB=${PREFIX}/interchange \
+ INSTALLARCHLIB=${PREFIX}/interchange/ \
INSTALLPRIVLIB=${PREFIX}/interchange/lib/ \
- INSTALLMAN1DIR=${PREFIX}/man/man1 \
- INSTALLMAN3DIR=${PREFIX}/man/man7
+ INSTALLMAN1DIR=${PREFIX}/man/man1
CONFIGURE_ARGS+= force=1
-.if defined(PACKAGE_BUILDING)
-IGNORE="needs a tty at the configure stage"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s:You are now ready to cd to \$$realdir:You are now ready to cd to ${PREFIX}:g" ${WRKSRC}/Makefile.PL
pre-configure:
-.if !defined(USE_THIS_PERL)
- @[ ! "${PERL_VER}" \< "5.6.1" ] || ( ${ECHO_CMD} -e "You use perl ${PERL_VER}, interchange should be used with 5.6.1 or better,\njust install the newer perl from ports and run 'use.perl port', this will\nmake the new perl the default perl. If you already have some perl modules\ninstalled for your old perl, you have to reinstall them for the new perl.\n\nIf you absolutely want to try to run interchange with perl ${PERL_VER},\nyou have to add '-DUSE_THIS_PERL' as an option for 'make'.\n" ; exit 1 )
-.endif
-.if !defined(CHECK_FOR_IC_USER)
- @${ECHO_CMD} -e "This port needs a specific user account ('interch') at configure time.\n\nIf it is ok for you to add a new user at configure time of this port\nadd '-DCHECK_FOR_IC_USER' as an option for 'make'.\n"
- @exit 1
-.endif
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} PRE-INSTALL
+pre-install:
+ @${MKDIR} ${PREFIX}/interchange
+
post-install:
@${INSTALL_SCRIPT} ${FILESDIR}/interchange.sh \
${PREFIX}/etc/rc.d/interchange.sh.sample
- @${REINPLACE_CMD} -i "" -e 's:%%PREFIX%%:${PREFIX}:' \
- ${PREFIX}/etc/rc.d/interchange.sh.sample
.for i in compile_link config_prog configdump dump expire expireall interchange localize makecat offline restart update
@${REINPLACE_CMD} -i "" -e "s:${PREFIX}:${PREFIX}/interchange:g; s:${PREFIX}/interchange/bin: ${PREFIX}/bin:g" ${PREFIX}/bin/${i}
.endfor
- @${CHOWN} -R interch:interch ${PREFIX}/interchange/src
+ @${CHOWN} -R interch:interch ${PREFIX}/interchange
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Needs perl 5.6.1 or higher, install lang/perl5.8 and try again
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>