aboutsummaryrefslogtreecommitdiff
path: root/www/interchange
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-07 00:30:41 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-07 00:30:41 +0000
commit396b9657ea07e84f1486bf1111614e69c626f83d (patch)
tree2b71b81c150261e05a180c50325368165ff1f7d1 /www/interchange
parentdcf8c976c2f35b0aa9589173ba858a1f9309a86c (diff)
downloadports-396b9657ea07e84f1486bf1111614e69c626f83d.tar.gz
ports-396b9657ea07e84f1486bf1111614e69c626f83d.zip
Notes
Diffstat (limited to 'www/interchange')
-rw-r--r--www/interchange/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/interchange/Makefile b/www/interchange/Makefile
index a07052d8977f..52c1693f8544 100644
--- a/www/interchange/Makefile
+++ b/www/interchange/Makefile
@@ -27,6 +27,7 @@ RUN_DEPENDS= ${SITE_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statemen
USE_PERL5= yes
PERL_CONFIGURE= yes
+PERL_VERSION= 5.8.2
ARCH_PERL= ${SITE_PERL}/${PERL_ARCH}
MAN1= configdump.1 config_prog.1 expire.1 localize.1 \
@@ -42,10 +43,13 @@ MAKE_ARGS+= NOCPANINSTALL=1 \
INSTALLARCHLIB=${PREFIX}/interchange \
INSTALLPRIVLIB=${PREFIX}/interchange/lib/ \
INSTALLMAN1DIR=${PREFIX}/man/man1 \
- INSTALLMAN3DIR=${PREFIX}/man/man7
+ INSTALLMAN3DIR=${PREFIX}/man/man7 \
+ -DCHECK_FOR_IC_USER
CONFIGURE_ARGS+= force=1
+BROKEN= "Does not install (refuses to accept the new userid it asks you to create)"
+
.if defined(PACKAGE_BUILDING)
IGNORE="needs a tty at the configure stage"
.endif
@@ -55,7 +59,7 @@ post-patch:
pre-configure:
.if !defined(USE_THIS_PERL)
- @[ ! "${PERL_VER}" \< "5.6.1" ] || ( ${ECHO_CMD} -e "You use perl ${PERL_VER}, interchange should be used with 5.6.1 or better,\njust install the newer perl from ports and run 'use.perl port', this will\nmake the new perl the default perl. If you already have some perl modules\ninstalled for your old perl, you have to reinstall them for the new perl.\n\nIf you absolutely want to try to run interchange with perl ${PERL_VER},\nyou have to add '-DUSE_THIS_PERL' as an option for 'make'.\n" ; exit 1 )
+ @[ ! "${PERL_VER}" \< "5.8" ] || ( ${ECHO_CMD} -e "You use perl ${PERL_VER}, interchange should be used with 5.8 or better,\njust install the newer perl from ports and run 'use.perl port', this will\nmake the new perl the default perl. If you already have some perl modules\ninstalled for your old perl, you have to reinstall them for the new perl.\n\nIf you absolutely want to try to run interchange with perl ${PERL_VER},\nyou have to add '-DUSE_THIS_PERL' as an option for 'make'.\n" ; exit 1 )
.endif
.if !defined(CHECK_FOR_IC_USER)
@${ECHO_CMD} -e "This port needs a specific user account ('interch') at configure time.\n\nIf it is ok for you to add a new user at configure time of this port\nadd '-DCHECK_FOR_IC_USER' as an option for 'make'.\n"