aboutsummaryrefslogtreecommitdiff
path: root/www/ismail/files
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-21 23:34:57 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-21 23:34:57 +0000
commit0918a4e2942c8b7b9079ba9097032c89e0a76a4e (patch)
tree36d819654de085fb15cf59a0602856b423972715 /www/ismail/files
parent27d4d9a537bfedd4c45ccfe411842cfbdc9ea742 (diff)
Notes
Diffstat (limited to 'www/ismail/files')
-rw-r--r--www/ismail/files/install.sh17
1 files changed, 17 insertions, 0 deletions
diff --git a/www/ismail/files/install.sh b/www/ismail/files/install.sh
new file mode 100644
index 000000000000..ee5c2f6422d8
--- /dev/null
+++ b/www/ismail/files/install.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# install.sh v0.1
+#
+# Install script which reads files from the plist and copies them to the appropriate
+# location and makes directories for them if necessary
+
+%%MKDIR%% %%INSTALLDIR%%
+
+# Install the required files
+for file in `cat pkg-plist | grep -v @ | grep ISMAILDIR | sed 's,%%[A-Z]*%%,,g'`; do
+ dir=`echo "${file}" | sed 's,/[^/]*$,/,g'`
+ if [ -d %%WRKSRC%%/ISMail/${dir} ]; then
+ %%MKDIR%% %%INSTALLDIR%%/${dir}
+ fi
+ %%INSTALL_DATA%% %%WRKSRC%%/ISMail/${file} %%INSTALLDIR%%/${file}
+done