aboutsummaryrefslogtreecommitdiff
path: root/www/jakarta-tomcat5
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-09-08 09:31:07 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-09-08 09:31:07 +0000
commit898335a4e5856ca51d99414766fea6fc70611b1f (patch)
tree44751b05f3f3345c2bf871011503f463cff3660e /www/jakarta-tomcat5
parentac9edfd67969ce040c55ee2bf49944febd284c56 (diff)
downloadports-898335a4e5856ca51d99414766fea6fc70611b1f.tar.gz
ports-898335a4e5856ca51d99414766fea6fc70611b1f.zip
Notes
Diffstat (limited to 'www/jakarta-tomcat5')
-rw-r--r--www/jakarta-tomcat5/Makefile2
-rw-r--r--www/jakarta-tomcat5/files/tomcat50.sh.in4
2 files changed, 3 insertions, 3 deletions
diff --git a/www/jakarta-tomcat5/Makefile b/www/jakarta-tomcat5/Makefile
index 6eaf43020278..383d9e3b6f5b 100644
--- a/www/jakarta-tomcat5/Makefile
+++ b/www/jakarta-tomcat5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jakarta-tomcat
PORTVERSION= 5.0.30
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= tomcat-5/v${PORTVERSION}/bin
diff --git a/www/jakarta-tomcat5/files/tomcat50.sh.in b/www/jakarta-tomcat5/files/tomcat50.sh.in
index 2823c81ca7d1..bc87ede6d9d4 100644
--- a/www/jakarta-tomcat5/files/tomcat50.sh.in
+++ b/www/jakarta-tomcat5/files/tomcat50.sh.in
@@ -109,7 +109,7 @@ log_args=">> ${tomcat%%TOMCAT_VERSION%%_stdout_log} \
if [ -f $pidfile ]; then
read rc_pid junk < $pidfile
if [ ! -z "$rc_pid" ]; then
- procname=`ps -o comm= $rc_pid`
+ procname=`ps -o ucomm= $rc_pid`
fi
fi
@@ -128,7 +128,7 @@ pid_touch ()
}
tomcat%%TOMCAT_VERSION%%_stop() {
- rc_pid=$(check_pidfile $pidfile $procname)
+ rc_pid=$(check_pidfile $pidfile *$procname*)
if [ -z "$rc_pid" ]; then
[ -n "$rc_fast" ] && return 0