aboutsummaryrefslogtreecommitdiff
path: root/www/jmeter
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-07-19 11:04:13 +0000
commitf899c758a653ca8ff2f8a63aafcb2519a0b524ed (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /www/jmeter
parent74d26774f830684ae21247061aa4bd7dabbe6527 (diff)
downloadports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.tar.gz
ports-f899c758a653ca8ff2f8a63aafcb2519a0b524ed.zip
Notes
Diffstat (limited to 'www/jmeter')
-rw-r--r--www/jmeter/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/www/jmeter/Makefile b/www/jmeter/Makefile
index 45554cf1dfb7..6349f88f3703 100644
--- a/www/jmeter/Makefile
+++ b/www/jmeter/Makefile
@@ -66,6 +66,9 @@ do-configure:
.endfor
${PRINTF} '\n' >> ${WRKSRC}/bin/system.properties
+# For some reason, it is not enough for these three to simply be listed in
+# jmeter.properties file. JMeter refuses to start, unless they are found in lib/
+BOOTSTRAP_JARS= avalon-framework xstream commons-io
do-install:
cd ${WRKSRC} \
&& ${FIND} ${DATAFILES} -type d -exec ${MKDIR} ${STAGEDIR}/${DATADIR}/{} \;
@@ -77,10 +80,6 @@ do-install:
&& ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
${INSTALL_SCRIPT} ${WRKDIR}/jmeter.sh ${STAGEDIR}${PREFIX}/bin/jmeter
-# For some reason, it is not enough for these three to simply be listed in
-# jmeter.properties file. JMeter refuses to start, unless they are found in lib/
-BOOTSTRAP_JARS= avalon-framework xstream commons-io
-post-install:
@${LN} -s ${BOOTSTRAP_JARS:C|.*|${JAVAJARDIR}/&.jar|} ${STAGEDIR}${DATADIR}/lib/
.include <bsd.port.post.mk>