aboutsummaryrefslogtreecommitdiff
path: root/www/junkbuster
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-04-30 20:36:05 +0000
committerSteve Price <steve@FreeBSD.org>2000-04-30 20:36:05 +0000
commit14fd2072a9eaa196b1d61ba5f9199f55e93aaea2 (patch)
tree6ffb1d07143f5e3c4c32453a4fed53dd4ed2980b /www/junkbuster
parent48463defd72713d2e1f2613983de0d47fe8fc2e7 (diff)
downloadports-14fd2072a9eaa196b1d61ba5f9199f55e93aaea2.tar.gz
ports-14fd2072a9eaa196b1d61ba5f9199f55e93aaea2.zip
Notes
Diffstat (limited to 'www/junkbuster')
-rw-r--r--www/junkbuster/files/patch-aa19
-rw-r--r--www/junkbuster/files/patch-ab12
-rw-r--r--www/junkbuster/files/patch-ac12
-rw-r--r--www/junkbuster/files/patch-ad12
-rw-r--r--www/junkbuster/files/patch-ae12
-rw-r--r--www/junkbuster/files/patch-af12
-rw-r--r--www/junkbuster/files/patch-ag13
-rw-r--r--www/junkbuster/files/patch-ah38
-rw-r--r--www/junkbuster/files/patch-ai10
-rw-r--r--www/junkbuster/files/patch-aj12
-rw-r--r--www/junkbuster/files/patch-ak27
-rw-r--r--www/junkbuster/files/patch-al12
-rw-r--r--www/junkbuster/files/patch-am12
13 files changed, 198 insertions, 5 deletions
diff --git a/www/junkbuster/files/patch-aa b/www/junkbuster/files/patch-aa
index 0f8a25ca2d41..08cddfae34e0 100644
--- a/www/junkbuster/files/patch-aa
+++ b/www/junkbuster/files/patch-aa
@@ -1,6 +1,7 @@
---- Makefile.orig Fri Feb 5 22:52:56 1999
-+++ Makefile Fri Feb 5 22:53:25 1999
-@@ -8,7 +8,7 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/Makefile ./Makefile
+--- /usr/ports/www/ijb/work/ijb20/Makefile Mon Feb 28 02:35:10 2000
++++ ./Makefile Mon Feb 28 02:37:39 2000
+@@ -8,10 +8,11 @@
PROG = junkbuster
O = o
RM = rm -f
@@ -9,7 +10,11 @@
# use this for Solaris 2.x
#LDFLAGS = -lnsl -lsocket
-@@ -47,7 +47,7 @@
++LDFLAGS += -lgnuregex
+
+ # use these for SunOS 4.x
+ #LDFLAGS = -nsl
+@@ -47,10 +48,10 @@
#MORE_CFLAGS = -relax_pointers
#LDFLAGS = -map junkbuster.xMAP
@@ -17,4 +22,8 @@
+CFLAGS += $(DEFAULT_CFLAGS) $(MORE_CFLAGS)
OBJS = jcc.$(O) parsers.$(O) filters.$(O) loaders.$(O) bind.$(O) conn.$(O) \
- encode.$(O) ssplit.$(O) socks4.$(O) acl.$(O) gnu_regex.$(O) win32.$(O)
+- encode.$(O) ssplit.$(O) socks4.$(O) acl.$(O) gnu_regex.$(O) win32.$(O)
++ encode.$(O) ssplit.$(O) socks4.$(O) acl.$(O) win32.$(O)
+
+ $(PROG): $(OBJS)
+ $(CC) $(CFLAGS) -o $(PROG) $(OBJS) $(LDFLAGS)
diff --git a/www/junkbuster/files/patch-ab b/www/junkbuster/files/patch-ab
new file mode 100644
index 000000000000..253d19947bf2
--- /dev/null
+++ b/www/junkbuster/files/patch-ab
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/acl.c ./acl.c
+--- /usr/ports/www/ijb/work/ijb20/acl.c Mon Feb 28 02:35:10 2000
++++ ./acl.c Mon Feb 28 02:31:06 2000
+@@ -18,7 +18,7 @@
+ #endif
+
+ #ifdef REGEX
+-#include "gnu_regex.h"
++#include "gnuregex.h"
+ #endif
+
+ #include "jcc.h"
diff --git a/www/junkbuster/files/patch-ac b/www/junkbuster/files/patch-ac
new file mode 100644
index 000000000000..bddb2f0cf3a8
--- /dev/null
+++ b/www/junkbuster/files/patch-ac
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/conn.c ./conn.c
+--- /usr/ports/www/ijb/work/ijb20/conn.c Mon Feb 28 02:35:10 2000
++++ ./conn.c Mon Feb 28 02:31:06 2000
+@@ -34,7 +34,7 @@
+ #endif
+
+ #ifdef REGEX
+-#include "gnu_regex.h"
++#include "gnuregex.h"
+ #endif
+
+ #include "jcc.h"
diff --git a/www/junkbuster/files/patch-ad b/www/junkbuster/files/patch-ad
new file mode 100644
index 000000000000..3e0c539ca92a
--- /dev/null
+++ b/www/junkbuster/files/patch-ad
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/encode.c ./encode.c
+--- /usr/ports/www/ijb/work/ijb20/encode.c Mon Feb 28 02:35:10 2000
++++ ./encode.c Mon Feb 28 02:31:06 2000
+@@ -9,7 +9,7 @@
+ #include <ctype.h>
+
+ #ifdef REGEX
+-#include "gnu_regex.h"
++#include "gnuregex.h"
+ #endif
+
+ #include "jcc.h"
diff --git a/www/junkbuster/files/patch-ae b/www/junkbuster/files/patch-ae
new file mode 100644
index 000000000000..c28b0ecf893d
--- /dev/null
+++ b/www/junkbuster/files/patch-ae
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/filters.c ./filters.c
+--- /usr/ports/www/ijb/work/ijb20/filters.c Mon Feb 28 02:35:10 2000
++++ ./filters.c Mon Feb 28 02:31:06 2000
+@@ -15,7 +15,7 @@
+ #endif
+
+ #ifdef REGEX
+-#include <gnu_regex.h>
++#include <gnuregex.h>
+ #endif
+
+ #include "jcc.h"
diff --git a/www/junkbuster/files/patch-af b/www/junkbuster/files/patch-af
new file mode 100644
index 000000000000..b89073b2eb26
--- /dev/null
+++ b/www/junkbuster/files/patch-af
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/gnu_regex.c ./gnu_regex.c
+--- /usr/ports/www/ijb/work/ijb20/gnu_regex.c Mon Feb 28 02:35:10 2000
++++ ./gnu_regex.c Mon Feb 28 02:31:06 2000
+@@ -131,7 +131,7 @@
+ #endif /* not emacs */
+
+ /* Get the interface, including the syntax bits. */
+-#include "gnu_regex.h"
++#include "gnuregex.h"
+
+ /* isalpha etc. are used for the character classes. */
+ #include <ctype.h>
diff --git a/www/junkbuster/files/patch-ag b/www/junkbuster/files/patch-ag
new file mode 100644
index 000000000000..7850ba53c513
--- /dev/null
+++ b/www/junkbuster/files/patch-ag
@@ -0,0 +1,13 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/jcc.c ./jcc.c
+--- /usr/ports/www/ijb/work/ijb20/jcc.c Mon Feb 28 02:35:10 2000
++++ ./jcc.c Mon Feb 28 02:31:06 2000
+@@ -39,7 +39,7 @@
+ #endif
+
+ #ifdef REGEX
+-#include <gnu_regex.h>
++#include <gnuregex.h>
+ #endif
+
+ #include "jcc.h"
+Binary files /usr/ports/www/ijb/work/ijb20/junkbuster and ./junkbuster differ
diff --git a/www/junkbuster/files/patch-ah b/www/junkbuster/files/patch-ah
new file mode 100644
index 000000000000..5b5d0fa34446
--- /dev/null
+++ b/www/junkbuster/files/patch-ah
@@ -0,0 +1,38 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/loaders.c ./loaders.c
+--- /usr/ports/www/ijb/work/ijb20/loaders.c Mon Feb 28 02:35:10 2000
++++ ./loaders.c Mon Feb 28 02:34:29 2000
+@@ -8,7 +8,7 @@
+ #include <stdlib.h>
+ #include <sys/types.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <errno.h>
+ #include <sys/stat.h>
+ #include <ctype.h>
+@@ -18,7 +18,7 @@
+ #endif
+
+ #ifdef REGEX
+-#include <gnu_regex.h>
++#include <gnuregex.h>
+ #endif
+
+ #include "jcc.h"
+@@ -1160,7 +1160,7 @@
+
+ extern char *acl_rcs, *bind_rcs, *conn_rcs, *encode_rcs,
+ *jcc_rcs, *loaders_rcs, *parsers_rcs, *filters_rcs,
+- *socks4_rcs, *ssplit_rcs, *gnu_regex_rcs, *win32_rcs;
++ *socks4_rcs, *ssplit_rcs, *win32_rcs;
+
+ b = strsav(b, "<h2>Source versions:</h2>\n");
+ b = strsav(b, "<pre>");
+@@ -1174,7 +1174,6 @@
+ sprintf(buf, "%s\n", socks4_rcs ); b = strsav(b, buf);
+ sprintf(buf, "%s\n", ssplit_rcs ); b = strsav(b, buf);
+ sprintf(buf, "%s\n", acl_rcs ); b = strsav(b, buf);
+- sprintf(buf, "%s\n", gnu_regex_rcs ); b = strsav(b, buf);
+ sprintf(buf, "%s\n", win32_rcs ); b = strsav(b, buf);
+ b = strsav(b, "</pre>");
+
diff --git a/www/junkbuster/files/patch-ai b/www/junkbuster/files/patch-ai
new file mode 100644
index 000000000000..d9cb3058158e
--- /dev/null
+++ b/www/junkbuster/files/patch-ai
@@ -0,0 +1,10 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/loaders.h ./loaders.h
+--- /usr/ports/www/ijb/work/ijb20/loaders.h Wed Dec 31 21:00:00 1969
++++ ./loaders.h Mon Feb 28 02:22:47 2000
+@@ -0,0 +1,6 @@
++#ifndef __LOADERS_H_INCLUDE__
++#define __LOADERS_H_INCLUDE__
++
++void * zalloc(int);
++
++#endif /* __LOADERS_H_INCLUDE__ */
diff --git a/www/junkbuster/files/patch-aj b/www/junkbuster/files/patch-aj
new file mode 100644
index 000000000000..bfdbf829703c
--- /dev/null
+++ b/www/junkbuster/files/patch-aj
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/parsers.c ./parsers.c
+--- /usr/ports/www/ijb/work/ijb20/parsers.c Mon Feb 28 02:35:10 2000
++++ ./parsers.c Mon Feb 28 02:31:06 2000
+@@ -15,7 +15,7 @@
+ #endif
+
+ #ifdef REGEX
+-#include <gnu_regex.h>
++#include <gnuregex.h>
+ #endif
+
+ #include "jcc.h"
diff --git a/www/junkbuster/files/patch-ak b/www/junkbuster/files/patch-ak
new file mode 100644
index 000000000000..7eadcb830d2b
--- /dev/null
+++ b/www/junkbuster/files/patch-ak
@@ -0,0 +1,27 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/socks4.c ./socks4.c
+--- /usr/ports/www/ijb/work/ijb20/socks4.c Mon Feb 28 02:35:10 2000
++++ ./socks4.c Mon Feb 28 02:31:06 2000
+@@ -19,11 +19,13 @@
+ #endif
+
+ #ifdef REGEX
+-#include <gnu_regex.h>
++#include <gnuregex.h>
+ #endif
+
+ #include "jcc.h"
+
++#define DEFAULT_FALLBACK_HTTP_PORT 80
++
+ #define SOCKS_REQUEST_GRANTED 90
+ #define SOCKS_REQUEST_REJECT 91
+ #define SOCKS_REQUEST_IDENT_FAILED 92
+@@ -56,7 +58,7 @@
+ unsigned char sbuf[BUFSIZ];
+ struct socks_op *c = (struct socks_op *)cbuf;
+ struct socks_reply *s = (struct socks_reply *)sbuf;
+- int web_server_addr;
++ int web_server_addr = DEFAULT_FALLBACK_HTTP_PORT;
+ int n, csiz, sfd, target_port;
+ int err = 0;
+ char *errstr, *target_host;
diff --git a/www/junkbuster/files/patch-al b/www/junkbuster/files/patch-al
new file mode 100644
index 000000000000..6b78b5f1a731
--- /dev/null
+++ b/www/junkbuster/files/patch-al
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/ssplit.c ./ssplit.c
+--- /usr/ports/www/ijb/work/ijb20/ssplit.c Mon Feb 28 02:35:10 2000
++++ ./ssplit.c Mon Feb 28 02:31:06 2000
+@@ -18,6 +18,8 @@
+ * l = flag indicating whether to ignore leading field separators
+ */
+
++#include "loaders.h"
++#include <stdlib.h>
+ #include <string.h>
+
+ int ssplit(char *s, char *c, char *v[], int n, int m, int l)
diff --git a/www/junkbuster/files/patch-am b/www/junkbuster/files/patch-am
new file mode 100644
index 000000000000..7ff4eb1b9e6a
--- /dev/null
+++ b/www/junkbuster/files/patch-am
@@ -0,0 +1,12 @@
+diff -ruN /usr/ports/www/ijb/work/ijb20/win32.c ./win32.c
+--- /usr/ports/www/ijb/work/ijb20/win32.c Mon Feb 28 02:35:10 2000
++++ ./win32.c Mon Feb 28 02:31:06 2000
+@@ -7,7 +7,7 @@
+
+ #include <stdio.h>
+ #ifdef REGEX
+-#include "gnu_regex.h"
++#include "gnuregex.h"
+ #endif
+ #include "jcc.h"
+ #include <windows.h>