aboutsummaryrefslogtreecommitdiff
path: root/www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-07-26 21:49:58 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-07-26 21:49:58 +0000
commit30c1a0a7927d6992cbf7baf9e8e1f637b2e4f6d4 (patch)
tree89c0045d73cc71a8a86842d8aa10f24e71cb5f26 /www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
parentd7df099ed9e71aeb1cf30ae4e058f52c668df365 (diff)
- update firefox/thunderbird ESR versions to 10.0.6
- update firefox 14.0.1 - update thunderbird to 14.0 - update seamonkey to 2.11 - switch to new options framework - add experimental rendering via cairo-qt (QT4 option) - add audio backend options (ALSA and PulseAudio) - rename SMB option to GNOMEVFS2 - turn on LOGGING by default (like upstream linux builds) - improve about:memory output - unbreak PGO - use system libs [1] - switch to libevent2 [2] - fix conflict with devel/libunwind and base gcc [3] - unbreak clang/libc++ build [4] - unbreak build with base gcc on >= 9.x [5] - use common IPC code with other BSDs[6] - and *miscellaneous improvements* PR: ports/146231 [1], ports/161421 [2] ports/150631, ports/168369, ports/168637, ports/168793, ports/168978 [3] ports/163454, ports/164905, ports/169231 [4] ports/169389, ports/169479 [5] Obtained from: pkgsrc via bugzilla #753046 [6] In collaboration with: Jan Beich (who did the major part of this work and deserves a special thank you!)
Notes
Notes: svn path=/head/; revision=301582
Diffstat (limited to 'www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in')
-rw-r--r--www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in75
1 files changed, 22 insertions, 53 deletions
diff --git a/www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in b/www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
index 0364449f8249..59d7a054f879 100644
--- a/www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
+++ b/www/kompozer/files/patch-xpcom-reflect-xptcall-src-md-unix-Makefile.in
@@ -1,15 +1,14 @@
--- xpcom/reflect/xptcall/src/md/unix/Makefile.in.orig 2009-05-02 18:43:37.000000000 +0200
+++ xpcom/reflect/xptcall/src/md/unix/Makefile.in 2009-09-28 22:05:47.000000000 +0200
-@@ -66,6 +66,9 @@
- ifeq (86,$(findstring 86,$(OS_TEST)))
- CPPSRCS := xptcinvoke_unixish_x86.cpp xptcstubs_unixish_x86.cpp
- endif
-+ifeq (amd64,$(OS_TEST))
-+CPPSRCS := xptcinvoke_x86_64_linux.cpp xptcstubs_x86_64_linux.cpp
-+endif
- endif
+@@ -77,7 +77,7 @@ endif
+ # New code for Linux, et. al., with gcc
+ # Migrate other platforms here after testing
#
- # OpenBSD/amd64
+-ifneq (,$(filter Linux,$(OS_ARCH)))
++ifneq (,$(filter Linux FreeBSD,$(OS_ARCH)))
+ # Linux/x86-64
+ ifeq (x86_64,$(OS_TEST))
+ CPPSRCS := xptcinvoke_x86_64_linux.cpp xptcstubs_x86_64_linux.cpp
@@ -88,7 +91,7 @@
endif
endif
@@ -19,51 +18,21 @@
ifneq (,$(findstring ia64,$(OS_TEST)))
CPPSRCS := xptcinvoke_ipf64.cpp xptcstubs_ipf64.cpp
ASFILES := xptcstubs_asm_ipf64.s xptcinvoke_asm_ipf64.s
-@@ -151,9 +154,15 @@
- CPPSRCS := xptcinvoke_openbsd_alpha.cpp xptcstubs_openbsd_alpha.cpp
- endif
- #
-+# FreeBSD/Alpha
-+#
-+ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDalpha)
-+CPPSRCS := xptcinvoke_freebsd_alpha.cpp xptcstubs_freebsd_alpha.cpp
-+endif
-+#
- # Linux/Alpha
+@@ -295,7 +295,7 @@ endif
#
--ifneq (,$(filter Linuxalpha FreeBSDalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
-+ifneq (,$(filter Linuxalpha NetBSDalpha,$(OS_ARCH)$(OS_TEST)))
- CPPSRCS := xptcinvoke_linux_alpha.cpp xptcstubs_linux_alpha.cpp
- endif
- #
-@@ -293,6 +302,14 @@
- endif
-
- #
-+# FreeBSD/PPC
-+#
-+ifeq ($(OS_ARCH)$(OS_TEST),FreeBSDpowerpc)
-+CPPSRCS := xptcinvoke_ppc_freebsd.cpp xptcstubs_ppc_freebsd.cpp
-+ASFILES := xptcinvoke_asm_ppc_freebsd.s xptcstubs_asm_ppc_freebsd.s
-+endif
-+
-+#
# Linux/PPC
#
- ifeq ($(OS_ARCH)$(OS_TEST),Linuxppc)
-@@ -364,6 +381,15 @@
- ASFILES := xptcinvoke_asm_sparc_netbsd.s xptcstubs_asm_sparc_netbsd.s
+-ifeq ($(OS_ARCH)$(OS_TEST),Linuxppc)
++ifneq (,$(filter Linuxppc FreeBSDpowerpc,$(OS_ARCH)$(OS_TEST)))
+ CPPSRCS := xptcinvoke_ppc_linux.cpp xptcstubs_ppc_linux.cpp
+ ASFILES := xptcinvoke_asm_ppc_linux.s xptcstubs_asm_ppc_linux.s
+ AS := $(CC) -c -x assembler-with-cpp
+@@ -400,7 +400,7 @@ endif
+ #
+ # OpenBSD/SPARC64
+ #
+-ifeq ($(OS_ARCH)$(OS_TEST),OpenBSDsparc64)
++ifneq (,$(filter OpenBSDsparc64 FreeBSDsparc64,$(OS_ARCH)$(OS_TEST)))
+ CPPSRCS := xptcinvoke_sparc64_openbsd.cpp xptcstubs_sparc64_openbsd.cpp
+ ASFILES := xptcinvoke_asm_sparc64_openbsd.s xptcstubs_asm_sparcv9_solaris.s
endif
- #
-+# FreeBSD/SPARC64
-+#
-+ifeq ($(OS_ARCH),FreeBSD)
-+ifneq (,$(findstring sparc,$(OS_TEST)))
-+CPPSRCS := xptcinvoke_sparc64_freebsd.cpp xptcstubs_sparc64_freebsd.cpp
-+ASFILES := xptcinvoke_asm_sparc64_freebsd.s xptcstubs_asm_sparcv9_solaris.s
-+endif
-+endif
-+#
- # Solaris/SPARC
- #
- ifeq ($(OS_ARCH),SunOS)