aboutsummaryrefslogtreecommitdiff
path: root/www/libapreq2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-06-11 09:55:35 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-06-11 09:55:35 +0000
commite9f2fe72ad04f329e5b43dfc0a906112da2d9f29 (patch)
tree220e0964eb6ed240a7edb7f8d81d49d5e8eede29 /www/libapreq2/Makefile
parentcb0ce00146ff99ff6d77d41ad5f061c1ac093296 (diff)
downloadports-e9f2fe72ad04f329e5b43dfc0a906112da2d9f29.tar.gz
ports-e9f2fe72ad04f329e5b43dfc0a906112da2d9f29.zip
Notes
Diffstat (limited to 'www/libapreq2/Makefile')
-rw-r--r--www/libapreq2/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
new file mode 100644
index 000000000000..31452fa98918
--- /dev/null
+++ b/www/libapreq2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-libapreq2
+# Date created: June 5, 2004
+# Whom: Autrijus Tang <autrijus@autrijus.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libapreq2
+PORTVERSION= 2.02r02
+CATEGORIES= www perl5 devel
+MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
+MASTER_SITE_SUBDIR=libapreq
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/r/_/}-dev
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Generic Apache2 Request Library
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2:${PORTSDIR}/www/mod_perl2 \
+ ${SITE_PERL}/ExtUtils/XSBuilder:${PORTSDIR}/devel/p5-ExtUtils-XSBuilder \
+ ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2:${PORTSDIR}/www/mod_perl2
+
+CONFLICTS= p5-libapreq
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-perl-glue
+USE_PERL5= yes
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_02//}
+
+MAN3= Apache::Cookie.3 Apache::Request.3
+
+.include <bsd.port.mk>