aboutsummaryrefslogtreecommitdiff
path: root/www/libapreq2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-12-25 17:14:48 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-12-25 17:14:48 +0000
commit0ea01d38b7592b292351dac441484b881e863d23 (patch)
tree4161fa67781cd114ef58534c11a0839b7d4d55a6 /www/libapreq2/Makefile
parentf1df687c1c7455bfd4f5fe142319d564be0d1fff (diff)
downloadports-0ea01d38b7592b292351dac441484b881e863d23.tar.gz
ports-0ea01d38b7592b292351dac441484b881e863d23.zip
Notes
Diffstat (limited to 'www/libapreq2/Makefile')
-rw-r--r--www/libapreq2/Makefile41
1 files changed, 27 insertions, 14 deletions
diff --git a/www/libapreq2/Makefile b/www/libapreq2/Makefile
index e82c426bc28f..ba16b9974c50 100644
--- a/www/libapreq2/Makefile
+++ b/www/libapreq2/Makefile
@@ -7,39 +7,52 @@
PORTNAME= libapreq2
PORTVERSION= 2.06
-CATEGORIES= www perl5 devel
+CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR=libapreq
-PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-${PORTVERSION}-dev
MAINTAINER= ports@FreeBSD.org
COMMENT= Generic Apache2 Request Library
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2 \
- ${SITE_PERL}/ExtUtils/XSBuilder:${PORTSDIR}/devel/p5-ExtUtils-XSBuilder \
- ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
WITH_APACHE2= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-perl-glue --with-apache2-apxs=${APXS}
-USE_PERL5= yes
+CONFIGURE_ARGS+= --with-apache2-apxs=${APXS}
USE_APACHE= yes
+
+.if defined (WITH_MODPERL2)
+PKGNAMEPREFIX= p5-
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2 \
+ ${SITE_PERL}/ExtUtils/XSBuilder:${PORTSDIR}/devel/p5-ExtUtils-XSBuilder \
+ ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CONFIGURE_ARGS+= --enable-perl-glue
+USE_PERL5= yes
+PLIST_SUB+= WITH_MODPERL2=""
WRKSRC= ${WRKDIR}/${DISTNAME:C/_[0-9]+//}
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-
-MAN3= APR::Request::Apache2.3 APR::Request::CGI.3 APR::Request::Cookie.3 \
- APR::Request::Error.3 APR::Request::Param.3 APR::Request.3 \
- APR::Request::Hook.3 APR::Request::Parser.3 Apache2::Cookie.3 \
- Apache2::Upload.3 Apache2::Request.3
+MAN3= APR::Request.3 \
+ APR::Request::Apache2.3 \
+ APR::Request::CGI.3 \
+ APR::Request::Cookie.3 \
+ APR::Request::Error.3 \
+ APR::Request::Hook.3 \
+ APR::Request::Param.3 \
+ APR::Request::Parser.3 \
+ Apache2::Cookie.3 \
+ Apache2::Upload.3 \
+ Apache2::Request.3
post-configure:
cd ${CONFIGURE_WRKSRC}/glue/perl && \
${PERL5} Makefile.PL -apxs ${APXS} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+.else
+PLIST_SUB+= WITH_MODPERL2="@comment "
+.endif
.include <bsd.port.mk>