aboutsummaryrefslogtreecommitdiff
path: root/www/libapreq2/files
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2010-12-05 13:53:36 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2010-12-05 13:53:36 +0000
commite901ff87256fdd13bcf5a35a1f851d599ec81aff (patch)
treed06de7ae19e738fa3273c72f77d6a8807700dfc3 /www/libapreq2/files
parent4e2a0844027734bc4e6169a60a3c0dba9b731e09 (diff)
Notes
Diffstat (limited to 'www/libapreq2/files')
-rw-r--r--www/libapreq2/files/patch-glue-perl-Makefile.PL4
-rw-r--r--www/libapreq2/files/patch-library-Makefile.in16
-rw-r--r--www/libapreq2/files/patch-module-Makefile.in10
3 files changed, 15 insertions, 15 deletions
diff --git a/www/libapreq2/files/patch-glue-perl-Makefile.PL b/www/libapreq2/files/patch-glue-perl-Makefile.PL
index 26d6f73c2aba..4387e267b7e6 100644
--- a/www/libapreq2/files/patch-glue-perl-Makefile.PL
+++ b/www/libapreq2/files/patch-glue-perl-Makefile.PL
@@ -6,8 +6,8 @@
'TYPEMAPS' => [qw(@$mp2_typemaps $typemap)],
- 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes",
- 'LIBS' => "$apreq_libs $apr_libs",
-+ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(PREFIX)/%%APACHEINCLUDEDIR%%/modules/perl",
-+ 'LIBS' => "$apreq_libs $apr_libs -L\\\$(PREFIX)/lib",
++ 'INC' => "-I$base_dir/glue/perl/xs -I$inc_dir -I$xs_dir $apache_includes -I\\\$(LOCALBASE)/%%APACHEINCLUDEDIR%%/modules/perl",
++ 'LIBS' => "$apreq_libs $apr_libs -L\\\$(LOCALBASE)/lib",
} ;
$txt .= "'depend' => $deps,\n" if ($deps) ;
$txt .= qq{
diff --git a/www/libapreq2/files/patch-library-Makefile.in b/www/libapreq2/files/patch-library-Makefile.in
index cc5e82cfeea7..caa5d3320bed 100644
--- a/www/libapreq2/files/patch-library-Makefile.in
+++ b/www/libapreq2/files/patch-library-Makefile.in
@@ -1,11 +1,11 @@
---- ./library/Makefile.in.orig 2009-04-13 06:34:05.000000000 +0000
-+++ ./library/Makefile.in 2009-04-13 06:35:03.000000000 +0000
-@@ -144,7 +144,7 @@
- DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)/include
- CPPFLAGS = @CPPFLAGS@
+--- library/Makefile.in.orig
++++ library/Makefile.in
+@@ -133,7 +133,7 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
-LIBS = @LIBS@
+LIBS = @LIBS@ -L$(prefix)
- depcomp = $(SHELL) $(top_srcdir)/depcomp
- am__depfiles_maybe = depfiles
- @AMDEP_TRUE@DEP_FILES = ./$(DEPDIR)/cookie.Plo ./$(DEPDIR)/error.Plo \
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
diff --git a/www/libapreq2/files/patch-module-Makefile.in b/www/libapreq2/files/patch-module-Makefile.in
index 6dc704f27dab..7ba20eb0c595 100644
--- a/www/libapreq2/files/patch-module-Makefile.in
+++ b/www/libapreq2/files/patch-module-Makefile.in
@@ -1,11 +1,11 @@
---- ./module/Makefile.in.orig 2009-04-13 06:36:59.000000000 +0000
-+++ ./module/Makefile.in 2009-04-13 06:35:59.000000000 +0000
-@@ -128,7 +128,7 @@
+--- module/Makefile.in.orig
++++ module/Makefile.in
+@@ -43,7 +43,7 @@
+ mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/include/apreq_config.h
CONFIG_CLEAN_FILES =
- noinst_PROGRAMS = test_cgi$(EXEEXT)
-PROGRAMS = $(noinst_PROGRAMS)
+PROGRAMS =
-
test_cgi_SOURCES = test_cgi.c
test_cgi_OBJECTS = test_cgi.$(OBJEXT)
+ test_cgi_LDADD = $(LDADD)