aboutsummaryrefslogtreecommitdiff
path: root/www/libecap
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-13 13:52:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-13 13:52:09 +0000
commit1b5decaadb4fa2e8838456f4078734af8f5f6cf6 (patch)
tree5b45b96dd96d028b368e0b6d16148c8a4a3af64f /www/libecap
parent913dc6871b35cc5f7a9d63fc0808bd8d576bab0b (diff)
downloadports-1b5decaadb4fa2e8838456f4078734af8f5f6cf6.tar.gz
ports-1b5decaadb4fa2e8838456f4078734af8f5f6cf6.zip
Notes
Diffstat (limited to 'www/libecap')
-rw-r--r--www/libecap/Makefile23
-rw-r--r--www/libecap/distinfo4
-rw-r--r--www/libecap/files/patch-src-libecap-common-area.cc (renamed from www/libecap/files/patch-src__libecap__common__area.cc)6
-rw-r--r--www/libecap/files/patch-src-libecap-common-memory.h (renamed from www/libecap/files/patch-src__libecap__common__memory.h)4
-rw-r--r--www/libecap/files/patch-src__libecap__common__area.h25
-rw-r--r--www/libecap/pkg-descr6
-rw-r--r--www/libecap/pkg-plist4
7 files changed, 17 insertions, 55 deletions
diff --git a/www/libecap/Makefile b/www/libecap/Makefile
index 6c05b8abda33..542e9d833410 100644
--- a/www/libecap/Makefile
+++ b/www/libecap/Makefile
@@ -2,30 +2,21 @@
# $FreeBSD$
PORTNAME= libecap
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.1
CATEGORIES= www security
-MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/
+MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/ \
+ LOCAL/sunpoet
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library for module based network content analysis
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS_DEFINE= DOCS
-
-USES= libtool
-
+CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-
-PORTDOCS= CREDITS LICENSE NOTICE README
-
-CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+USE_LDCONFIG= yes
+USES= libtool
.include <bsd.port.mk>
diff --git a/www/libecap/distinfo b/www/libecap/distinfo
index 3f34770c6b7e..fbff6f254324 100644
--- a/www/libecap/distinfo
+++ b/www/libecap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libecap-1.0.0.tar.gz) = 64c7bb52e04d218903dbc6c7cc4c62cfc22a6db468d1e0f8dac58e0f8620c4be
-SIZE (libecap-1.0.0.tar.gz) = 343468
+SHA256 (libecap-1.0.1.tar.gz) = 7c166d997a079110dcc55e9b81eb70b4d73c08b2bcb986fa81bbf78bb62ec8f4
+SIZE (libecap-1.0.1.tar.gz) = 339799
diff --git a/www/libecap/files/patch-src__libecap__common__area.cc b/www/libecap/files/patch-src-libecap-common-area.cc
index 70787542f046..8920978554b1 100644
--- a/www/libecap/files/patch-src__libecap__common__area.cc
+++ b/www/libecap/files/patch-src-libecap-common-area.cc
@@ -1,6 +1,6 @@
---- src/libecap/common/area.cc.orig 2010-12-17 21:08:50.000000000 +0300
-+++ src/libecap/common/area.cc 2014-09-12 15:11:20.000000000 +0400
-@@ -14,8 +14,8 @@
+--- src/libecap/common/area.cc.orig 2015-05-13 16:00:35 UTC
++++ src/libecap/common/area.cc
+@@ -14,8 +14,8 @@ const libecap::size_type libecap::nsize
libecap::Area libecap::Area::FromTempString(const std::string &tmp) {
diff --git a/www/libecap/files/patch-src__libecap__common__memory.h b/www/libecap/files/patch-src-libecap-common-memory.h
index ef85435a65d9..db4f9894ee89 100644
--- a/www/libecap/files/patch-src__libecap__common__memory.h
+++ b/www/libecap/files/patch-src-libecap-common-memory.h
@@ -1,5 +1,5 @@
---- src/libecap/common/memory.h.orig 2010-05-26 01:27:41.000000000 +0400
-+++ src/libecap/common/memory.h 2014-09-12 15:06:36.000000000 +0400
+--- src/libecap/common/memory.h.orig 2014-10-02 04:05:24 UTC
++++ src/libecap/common/memory.h
@@ -4,14 +4,23 @@
#define LIBECAP__COMMON_MEMORY_H
diff --git a/www/libecap/files/patch-src__libecap__common__area.h b/www/libecap/files/patch-src__libecap__common__area.h
deleted file mode 100644
index f9d0ba224d70..000000000000
--- a/www/libecap/files/patch-src__libecap__common__area.h
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/libecap/common/area.h.orig 2011-02-17 21:04:23.000000000 +0300
-+++ src/libecap/common/area.h 2014-09-12 15:16:00.000000000 +0400
-@@ -45,7 +45,8 @@
- Details details; // creator-defined
-
- private:
-- bool does_not_support_comparisons() const; // not implemented
-+ template<typename T> bool operator==(const T&) {}
-+ template<typename T> bool operator!=(const T&) {}
- };
-
- // this stub can be enhanced by area creators to optimize area operations
-@@ -57,10 +58,8 @@
- std::ostream &operator <<(std::ostream &os, const Area &area);
-
- /* make Area comparisons illegal by default */
--template <typename T> bool operator ==(const Area &a, const T &) { return a.does_not_support_comparisons(); }
--template <typename T> bool operator !=(const Area &a, const T &) { return a.does_not_support_comparisons(); }
--template <typename T> bool operator ==(const T &, const Area &a) { return a.does_not_support_comparisons(); }
--template <typename T> bool operator !=(const T &, const Area &a) { return a.does_not_support_comparisons(); }
-+template <typename T> bool operator ==(const T &t, const Area &a) { return a == t; }
-+template <typename T> bool operator !=(const T &t, const Area &a) { return a != t; }
-
- } // namespace libecap
-
diff --git a/www/libecap/pkg-descr b/www/libecap/pkg-descr
index 46bca2d4355f..781d75dac7a9 100644
--- a/www/libecap/pkg-descr
+++ b/www/libecap/pkg-descr
@@ -1,5 +1,5 @@
-eCAP is a software interface that allows a network application,
-such as an HTTP proxy or an ICAP server, to outsource content
-analysis and adaptation to a loadable module.
+eCAP is a software interface that allows a network application, such as an HTTP
+proxy or an ICAP server, to outsource content analysis and adaptation to a
+loadable module.
WWW: http://www.e-cap.org/
diff --git a/www/libecap/pkg-plist b/www/libecap/pkg-plist
index d2c466fef864..a6091dabe176 100644
--- a/www/libecap/pkg-plist
+++ b/www/libecap/pkg-plist
@@ -25,7 +25,3 @@ lib/libecap.so
lib/libecap.so.3
lib/libecap.so.3.0.0
libdata/pkgconfig/libecap.pc
-@dirrm include/libecap/adapter
-@dirrm include/libecap/common
-@dirrm include/libecap/host
-@dirrm include/libecap