aboutsummaryrefslogtreecommitdiff
path: root/www/libecap
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-06 14:54:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-06 14:54:23 +0000
commit355169e234fb787c68d5a9bea6a35aea9d59e159 (patch)
treeb9e2d227b7406df67a3cfe0027c5bc41595b3b53 /www/libecap
parent5fb7e4edd5d3f1a09d1405f66a4f45ce1f05dd7e (diff)
downloadports-355169e234fb787c68d5a9bea6a35aea9d59e159.tar.gz
ports-355169e234fb787c68d5a9bea6a35aea9d59e159.zip
Notes
Diffstat (limited to 'www/libecap')
-rw-r--r--www/libecap/Makefile28
-rw-r--r--www/libecap/distinfo3
-rw-r--r--www/libecap/pkg-descr5
-rw-r--r--www/libecap/pkg-plist30
4 files changed, 66 insertions, 0 deletions
diff --git a/www/libecap/Makefile b/www/libecap/Makefile
new file mode 100644
index 000000000000..971b8e3dbfdf
--- /dev/null
+++ b/www/libecap/Makefile
@@ -0,0 +1,28 @@
+# Ports collection Makefile for: libecap
+# Date created: 2009/06/02
+# Whom: Thomas-Martin Seck <tmseck@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libecap
+PORTVERSION= 0.0.2
+CATEGORIES= www security
+MASTER_SITES= http://www.measurement-factory.com/tmp/ecap/
+
+MAINTAINER= tmseck@web.de
+COMMENT= Library for module based network content analysis
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GCC= 4.2+
+
+PORTDOCS= CREDITS LICENSE NOTICE README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/libecap/distinfo b/www/libecap/distinfo
new file mode 100644
index 000000000000..a97530095cbb
--- /dev/null
+++ b/www/libecap/distinfo
@@ -0,0 +1,3 @@
+MD5 (libecap-0.0.2.tar.gz) = 9bd302fef03eba1e6627a4ad2942aa41
+SHA256 (libecap-0.0.2.tar.gz) = ec3a7acc848eeb3e93d9bae6bebae5d7f6eb32023b5e814b45daeea45b0731d6
+SIZE (libecap-0.0.2.tar.gz) = 298074
diff --git a/www/libecap/pkg-descr b/www/libecap/pkg-descr
new file mode 100644
index 000000000000..46bca2d4355f
--- /dev/null
+++ b/www/libecap/pkg-descr
@@ -0,0 +1,5 @@
+eCAP is a software interface that allows a network application,
+such as an HTTP proxy or an ICAP server, to outsource content
+analysis and adaptation to a loadable module.
+
+WWW: http://www.e-cap.org/
diff --git a/www/libecap/pkg-plist b/www/libecap/pkg-plist
new file mode 100644
index 000000000000..1ec6f0fb35a3
--- /dev/null
+++ b/www/libecap/pkg-plist
@@ -0,0 +1,30 @@
+@comment $FreeBSD$
+include/libecap/adapter/service.h
+include/libecap/adapter/xaction.h
+include/libecap/common/libecap.h
+include/libecap/common/registry.h
+include/libecap/common/forward.h
+include/libecap/common/errors.h
+include/libecap/common/log.h
+include/libecap/common/memory.h
+include/libecap/common/call.h
+include/libecap/common/area.h
+include/libecap/common/name.h
+include/libecap/common/names.h
+include/libecap/common/header.h
+include/libecap/common/body.h
+include/libecap/common/body_size.h
+include/libecap/common/message.h
+include/libecap/common/version.h
+include/libecap/common/delay.h
+include/libecap/common/autoconf.h
+include/libecap/host/host.h
+include/libecap/host/xaction.h
+@dirrm include/libecap/adapter
+@dirrm include/libecap/common
+@dirrm include/libecap/host
+@dirrm include/libecap
+lib/libecap.a
+lib/libecap.la
+lib/libecap.so
+lib/libecap.so.0