aboutsummaryrefslogtreecommitdiff
path: root/www/libhttpd-persistent
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-10-23 20:21:55 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-10-23 20:21:55 +0000
commit9e4870a5d6532b1cb9b38ac066d328a59a038265 (patch)
tree1db19a50ae8e956454150139ec691de3cbb474d3 /www/libhttpd-persistent
parent6e450c32b48679de1e1c4b4218962c42b62ed017 (diff)
downloadports-9e4870a5d6532b1cb9b38ac066d328a59a038265.tar.gz
ports-9e4870a5d6532b1cb9b38ac066d328a59a038265.zip
Notes
Diffstat (limited to 'www/libhttpd-persistent')
-rw-r--r--www/libhttpd-persistent/Makefile41
-rw-r--r--www/libhttpd-persistent/distinfo1
-rw-r--r--www/libhttpd-persistent/pkg-descr9
-rw-r--r--www/libhttpd-persistent/pkg-plist7
4 files changed, 58 insertions, 0 deletions
diff --git a/www/libhttpd-persistent/Makefile b/www/libhttpd-persistent/Makefile
new file mode 100644
index 000000000000..24e9a1b30aeb
--- /dev/null
+++ b/www/libhttpd-persistent/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: libhttpd-persistent
+# Date created: 19 October 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libhttpd
+PORTVERSION= ${VERSION}${LEVEL}
+CATEGORIES= www devel
+MASTER_SITES= http://www.deleet.de/projekte/daap/daapd/
+PKGNAMESUFFIX= -persistent
+DISTNAME= ${PORTNAME}-${VERSION}p-${LEVEL}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Library for embedded web servers
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${VERSION}-persistent-${LEVEL}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+CC= ${CXX}
+
+VERSION= 1.3
+LEVEL= e
+
+DOCS= README HISTORY License doc/FAQ.txt doc/libhttpd.pdf
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/Site.mm.in \
+ ${WRKSRC}/src/Makefile.tmpl
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/libhttpd-persistent/distinfo b/www/libhttpd-persistent/distinfo
new file mode 100644
index 000000000000..e2bd389519e9
--- /dev/null
+++ b/www/libhttpd-persistent/distinfo
@@ -0,0 +1 @@
+MD5 (libhttpd-1.3p-e.tgz) = 638f5e743393188c2761372e951a692b
diff --git a/www/libhttpd-persistent/pkg-descr b/www/libhttpd-persistent/pkg-descr
new file mode 100644
index 000000000000..e68113ab8160
--- /dev/null
+++ b/www/libhttpd-persistent/pkg-descr
@@ -0,0 +1,9 @@
+libHTTPD can be used to add basic web server capabilities to an
+application or embedded device. The library handles both static and
+dynamically generated content, has very low overheads, and provides many
+features to simplify the creation of web based application interfaces.
+
+This is a version modified for persistent connections by the author of
+daapd.
+
+WWW: http://www.deleet.de/projekte/daap/daapd/
diff --git a/www/libhttpd-persistent/pkg-plist b/www/libhttpd-persistent/pkg-plist
new file mode 100644
index 000000000000..2049e7d21771
--- /dev/null
+++ b/www/libhttpd-persistent/pkg-plist
@@ -0,0 +1,7 @@
+include/httpd.h
+lib/libhttpd.a
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/HISTORY
+%%PORTDOCS%%%%DOCSDIR%%/License
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.txt
+%%PORTDOCS%%%%DOCSDIR%%/libhttpd.pdf