aboutsummaryrefslogtreecommitdiff
path: root/www/libmicrohttpd/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-01-17 20:05:33 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-01-17 20:05:33 +0000
commit02bceac4bea9759eb94f7eacbdf1ff78de0c6e79 (patch)
treee4a64fd375223325ab7a56c71b0c1abab12e8bd8 /www/libmicrohttpd/Makefile
parentd026836dbe5de969862d219709db691669ade2d0 (diff)
Notes
Diffstat (limited to 'www/libmicrohttpd/Makefile')
-rw-r--r--www/libmicrohttpd/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/www/libmicrohttpd/Makefile b/www/libmicrohttpd/Makefile
index 8ebe878ba05d..8a229dc26818 100644
--- a/www/libmicrohttpd/Makefile
+++ b/www/libmicrohttpd/Makefile
@@ -7,14 +7,24 @@
PORTNAME= libmicrohttpd
PORTVERSION= 0.9.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= libmicrohttpd
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gaod@hychen.org
COMMENT= C library for embedding HTTP server functionality
LICENSE= LGPL21
+
+OPTIONS= GNUTLS "Build with gnutls to support ssl" off
+.include <bsd.port.options.mk>
+
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS= gnutls.40:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+=--with-gnutls=${LOCALBASE} --enable-https
+.endif
+
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
MAKE_ARGS+= pkgconfigdir=${PREFIX}/libdata/pkgconfig