aboutsummaryrefslogtreecommitdiff
path: root/www/libwww/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-06-26 16:49:35 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-06-26 16:49:35 +0000
commite880a487e070914d525bbc878283828726686443 (patch)
treeac0c072212a46d95db20f11576c979ecde85c262 /www/libwww/Makefile
parent0778360d05fc7a37ef5a5a5bc5971011f9825e36 (diff)
Notes
Diffstat (limited to 'www/libwww/Makefile')
-rw-r--r--www/libwww/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/www/libwww/Makefile b/www/libwww/Makefile
index 5e1dca7380ad..a9d95421e1d0 100644
--- a/www/libwww/Makefile
+++ b/www/libwww/Makefile
@@ -1,16 +1,28 @@
# New ports collection makefile for: libwww
-# Version required: 4.0D
+# Version required: 5.1b
# Date created: 18 Feb 1996
# Whom: torstenb
#
-# $Id: Makefile,v 1.1.1.1 1996/03/06 18:50:26 torstenb Exp $
+# $Id: Makefile,v 1.2 1996/11/18 11:41:19 asami Exp $
#
-DISTNAME= libwww_4.0D_src
-PKGNAME= libwww-4.0D
+DISTNAME= w3c-libwww-5.1b
+PKGNAME= libwww-5.1b
CATEGORIES= www devel
MASTER_SITES= ftp://ftp.w3.org/pub/libwww/
-WRKSRC= ${WRKDIR}/WWW
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+DOCDIR= ${PREFIX}/share/doc/libwww
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/Library/src/*.h ${PREFIX}/include
+ @${LDCONFIG} -m ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCDIR}/User
+ ${CP} -R ${WRKSRC}/Library/User/* ${DOCDIR}/User
+ @${MKDIR} ${DOCDIR}/src
+ ${CP} ${WRKSRC}/Library/src/*.html ${DOCDIR}/src
+.endif
.include <bsd.port.mk>