aboutsummaryrefslogtreecommitdiff
path: root/www/libwww
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-10 21:01:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-10 21:01:48 +0000
commitc0e6077fa2a9fe4f21dc80431c96c0e58240b1e5 (patch)
tree5056d99b635474d404b99999ba5f604a673b9122 /www/libwww
parent4d5da453576e61661da2f586ec8ee718cb08c371 (diff)
downloadports-c0e6077fa2a9fe4f21dc80431c96c0e58240b1e5.tar.gz
ports-c0e6077fa2a9fe4f21dc80431c96c0e58240b1e5.zip
Notes
Diffstat (limited to 'www/libwww')
-rw-r--r--www/libwww/Makefile3
-rw-r--r--www/libwww/files/patch-configure15
2 files changed, 17 insertions, 1 deletions
diff --git a/www/libwww/Makefile b/www/libwww/Makefile
index 4de1a61c8e19..eea0f329a07d 100644
--- a/www/libwww/Makefile
+++ b/www/libwww/Makefile
@@ -19,9 +19,10 @@ COMMENT= The W3C Reference Library
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ARGS= --enable-shared --enable-static --with-zlib --with-ssl
+CONFIGURE_ARGS= --enable-shared --enable-static --with-zlib --with-ssl=${OPENSSLBASE}
USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
+USE_OPENSSL= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
diff --git a/www/libwww/files/patch-configure b/www/libwww/files/patch-configure
new file mode 100644
index 000000000000..5d2695f867b6
--- /dev/null
+++ b/www/libwww/files/patch-configure
@@ -0,0 +1,15 @@
+--- configure.orig Wed Jun 12 11:31:31 2002
++++ configure Sat Mar 10 21:51:00 2007
+@@ -7612,8 +7612,11 @@
+ if test "x$withval" = "xyes"; then
+ withval=$ssllib
+ SSLINC=$sslinc
++ LIBS="$LIBS $withval"
++ else
++ SSLINC="-I$withval/include/openssl"
++ LIBS="$LIBS -L$withval/lib -lssl -lcrypto"
+ fi
+- LIBS="$LIBS $withval"
+ cat > conftest.$ac_ext <<EOF
+ #line 7619 "configure"
+ #include "confdefs.h"