aboutsummaryrefslogtreecommitdiff
path: root/www/libxul/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-07-16 06:05:59 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-07-16 06:05:59 +0000
commitef0a0c91f153782cd38b84d14147dfa8cef8337f (patch)
treecaa550e9c6de6d456de3b7c58dd8a734b5352b71 /www/libxul/Makefile
parent0f6380feb102214049ed4d6947dbd85a02b35d19 (diff)
Notes
Diffstat (limited to 'www/libxul/Makefile')
-rw-r--r--www/libxul/Makefile30
1 files changed, 19 insertions, 11 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index abff4c6b7677..fc9b90ce6154 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -2,37 +2,36 @@
# $FreeBSD$
PORTNAME= libxul
-DISTVERSION= 31.7.0
-PORTREVISION= 1
+DISTVERSION= 38.1.0
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
- MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build2/source
+ MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build1/source
DISTNAME= firefox-${DISTVERSION}esr.source
MAINTAINER?= gecko@FreeBSD.org
COMMENT?= Mozilla runtime package that can be used to bootstrap XUL+XPCOM apps
-BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
- nss>=3.16.2.3:${PORTSDIR}/security/nss \
+BUILD_DEPENDS= nspr>=4.10.8:${PORTSDIR}/devel/nspr \
+ nss>=3.19.2:${PORTSDIR}/security/nss \
libevent2>=2.0.21_2:${PORTSDIR}/devel/libevent2 \
cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo \
soundtouch>=1.8.0:${PORTSDIR}/audio/soundtouch \
harfbuzz>=0.9.25:${PORTSDIR}/print/harfbuzz \
graphite2>=1.2.4:${PORTSDIR}/graphics/graphite2 \
- libvorbis>=1.3.5:${PORTSDIR}/audio/libvorbis \
- opus>=1.1:${PORTSDIR}/audio/opus \
+ libvorbis>=1.3.4:${PORTSDIR}/audio/libvorbis \
libvpx>=1.3.0:${PORTSDIR}/multimedia/libvpx \
- sqlite3>=3.8.4.2:${PORTSDIR}/databases/sqlite3 \
+ sqlite3>=3.8.9:${PORTSDIR}/databases/sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
+# opus>=1.1:${PORTSDIR}/audio/opus \
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-WRKSRC= ${WRKDIR}/mozilla-esr31
-CONFLICTS= libxul-1.9.*
+WRKSRC= ${WRKDIR}/mozilla-esr38
+CONFLICTS_INSTALL= libxul-1.9.*
USE_QT5= # empty
QT_NONSTANDARD= yes
@@ -47,11 +46,16 @@ MOZ_OPTIONS?= --enable-application=xulrunner
USE_GECKO= gecko
CPE_PRODUCT= firefox_esr
MOZILLA_EXEC_NAME=xulrunner
-USE_MOZILLA= # empty
+USE_MOZILLA= -opus
MOZILLA_PLIST_DIRS= bin include lib share/idl libdata
MOZ_PKGCONFIG_FILES= libxul-embedding libxul mozilla-js \
mozilla-plugin
+OPTIONS_DEFAULT= GTK2
+
+OPTIONS_SINGLE+= TOOLKIT
+OPTIONS_SINGLE_TOOLKIT= GTK2 GTK3
+
.include "${.CURDIR}/../../www/firefox/Makefile.options"
.include <bsd.port.pre.mk>
@@ -67,6 +71,10 @@ RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
.endif
+.if ${PORT_OPTIONS:MGTK3}
+BUILD_DEPENDS+= gtk3>=3.14.6:${PORTSDIR}/x11-toolkits/gtk30
+.endif
+
.if ${PORT_OPTIONS:MTEST}
BROKEN= stage-package fails with ValueError: no path specified
.endif