aboutsummaryrefslogtreecommitdiff
path: root/www/libxul
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-03-03 19:38:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-03-03 19:38:13 +0000
commitb0d611aa447013bc4fe9c353f277831880c44fd1 (patch)
tree7d3284e05228817e5a098f0866e33d8843538a73 /www/libxul
parenta3bf534f8daa058155a59935da829fae1c8fc128 (diff)
gecko: attempt to drop RPATH for libxul.so dependencies
Notes
Notes: svn path=/head/; revision=435362
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile2
-rw-r--r--www/libxul/files/patch-bug133679121
2 files changed, 22 insertions, 1 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 2ed457fc0999..931d0110fa53 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build2/source
diff --git a/www/libxul/files/patch-bug1336791 b/www/libxul/files/patch-bug1336791
new file mode 100644
index 000000000000..e9ed891a4c56
--- /dev/null
+++ b/www/libxul/files/patch-bug1336791
@@ -0,0 +1,21 @@
+# Allow readelf to print types without parentheses
+
+--- toolkit/library/dependentlibs.py
++++ toolkit/library/dependentlibs.py
+@@ -57,11 +57,15 @@ def dependentlibs_readelf(lib):
+ for line in proc.stdout:
+ # Each line has the following format:
+ # tag (TYPE) value
++ # or with BSD readelf:
++ # tag TYPE value
+ # Looking for NEEDED type entries
+ tmp = line.split(' ', 3)
+- if len(tmp) > 3 and tmp[2] == '(NEEDED)':
++ if len(tmp) > 3 and 'NEEDED' in tmp[2]:
+ # NEEDED lines look like:
+ # 0x00000001 (NEEDED) Shared library: [libname]
++ # or with BSD readelf:
++ # 0x00000001 NEEDED Shared library: [libname]
+ match = re.search('\[(.*)\]', tmp[3])
+ if match:
+ deps.append(match.group(1))