aboutsummaryrefslogtreecommitdiff
path: root/www/libxul
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-12-14 15:39:16 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-12-14 15:39:16 +0000
commit67051dbc47dcbc0cfe19a7583d5460f0d5446ae4 (patch)
treee044d8874568429701a07d15cb3adb69c1d7e3ba /www/libxul
parent724ebbe5ddcfafbbf87c85465804c80cc5242353 (diff)
downloadports-67051dbc47dcbc0cfe19a7583d5460f0d5446ae4.tar.gz
ports-67051dbc47dcbc0cfe19a7583d5460f0d5446ae4.zip
Notes
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile2
-rw-r--r--www/libxul/files/patch-bug129003729
2 files changed, 30 insertions, 1 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index ddf1adabd78f..049a8e008adb 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxul
DISTVERSION= 45.6.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= www devel
MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
MOZILLA/firefox/candidates/${DISTVERSION}esr-candidates/build1/source
diff --git a/www/libxul/files/patch-bug1290037 b/www/libxul/files/patch-bug1290037
new file mode 100644
index 000000000000..033137a94f50
--- /dev/null
+++ b/www/libxul/files/patch-bug1290037
@@ -0,0 +1,29 @@
+commit 7943c27406fb
+Author: Franziskus Kiefer <franziskuskiefer@gmail.com>
+Date: Thu Jul 28 16:48:00 2016 +0200
+
+ Bug 1290037 - Update keybits in H2, r=mt
+
+ MozReview-Commit-ID: 35oWoDMqe1Y
+
+ --HG--
+ extra : rebase_source : 020fbd93c190131eb04eed2d583787d6e5954a5a
+---
+ netwerk/protocol/http/Http2Session.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git netwerk/protocol/http/Http2Session.cpp netwerk/protocol/http/Http2Session.cpp
+index dbcc1115cbd3..f3cd57304f73 100644
+--- netwerk/protocol/http/Http2Session.cpp
++++ netwerk/protocol/http/Http2Session.cpp
+@@ -3549,8 +3549,8 @@ Http2Session::ConfirmTLSProfile()
+ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to DH %d < 2048\n",
+ this, keybits));
+ RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
+- } else if (kea == ssl_kea_ecdh && keybits < 256) { // 256 bits is "security level" of 128
+- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 256\n",
++ } else if (kea == ssl_kea_ecdh && keybits < 224) { // see rfc7540 9.2.1.
++ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 224\n",
+ this, keybits));
+ RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
+ }