aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd-mod_h264_streaming
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2014-01-19 11:00:28 +0000
committerMartin Matuska <mm@FreeBSD.org>2014-01-19 11:00:28 +0000
commit7ee11da839c6650f15e4e369bedd3f75aba62c4b (patch)
tree0c38efabe4dced5cc84e16960ef5eff44742f521 /www/lighttpd-mod_h264_streaming
parente2ca71c3487fe13fad5ca4d6605899cba9769360 (diff)
downloadports-7ee11da839c6650f15e4e369bedd3f75aba62c4b.tar.gz
ports-7ee11da839c6650f15e4e369bedd3f75aba62c4b.zip
Notes
Diffstat (limited to 'www/lighttpd-mod_h264_streaming')
-rw-r--r--www/lighttpd-mod_h264_streaming/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/lighttpd-mod_h264_streaming/Makefile b/www/lighttpd-mod_h264_streaming/Makefile
index d5ab8427124b..8e7cad2ea4f3 100644
--- a/www/lighttpd-mod_h264_streaming/Makefile
+++ b/www/lighttpd-mod_h264_streaming/Makefile
@@ -35,21 +35,22 @@ ALL_TARGET= ${PORTNAME}.la
_BUILDING_LIGHTTPD_MODULE= yes
-NO_STAGE= yes
do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/lighttpd
@${INSTALL_KLD} ${WRKSRC}/src/.libs/${PORTNAME}.so \
- ${LOCALBASE}/lib/lighttpd
+ ${STAGEDIR}${PREFIX}/lib/lighttpd
@${INSTALL_KLD} ${WRKSRC}/src/.libs/${PORTNAME}.la \
- ${LOCALBASE}/lib/lighttpd
+ ${STAGEDIR}${PREFIX}/lib/lighttpd
@${INSTALL_DATA} ${WRKSRC}/src/.libs/${PORTNAME}.a \
- ${LOCALBASE}/lib/lighttpd
+ ${STAGEDIR}${PREFIX}/lib/lighttpd
post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/lighttpd/conf.d
@${INSTALL_DATA} ${FILESDIR}/h264_streaming.conf \
- ${PREFIX}/etc/lighttpd/conf.d/h264_streaming.conf.sample
-.if !exists(${PREFIX}/etc/lighttpd/conf.d/h264_streaming.conf)
+ ${STAGEDIR}${PREFIX}/etc/lighttpd/conf.d/h264_streaming.conf.sample
+.if !exists(${STAGEDIR}${PREFIX}/etc/lighttpd/conf.d/h264_streaming.conf)
@${INSTALL_DATA} ${FILESDIR}/h264_streaming.conf \
- ${PREFIX}/etc/lighttpd/conf.d/h264_streaming.conf
+ ${STAGEDIR}${PREFIX}/etc/lighttpd/conf.d/h264_streaming.conf
.endif
.include "${MASTERDIR}/Makefile"