aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-06-03 17:57:42 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-06-03 17:57:42 +0000
commit512694953a7e0e9b4e2e037a3758fc131eb62d04 (patch)
treeffd626eec8f6534d53966273e0313771f02aed37 /www/lighttpd/Makefile
parenta2849b70c4f5540fd145f12fbdd7ef7f11ef32ba (diff)
Notes
Diffstat (limited to 'www/lighttpd/Makefile')
-rw-r--r--www/lighttpd/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
new file mode 100644
index 000000000000..e58b3e3e49e0
--- /dev/null
+++ b/www/lighttpd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lighttpd
+# Date created: 20 May 2004
+# Whom: k@123.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= lighttpd
+PORTVERSION= 1.2.1
+CATEGORIES= www
+MASTER_SITES= http://jan.kneschke.de/projects/lighttpd/download/
+
+MAINTAINER= k@123.org
+COMMENT= A secure, fast, compliant, and very flexible Web Server
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+USE_REINPLACE= yes
+USE_RC_SUBR= yes
+USE_LIBTOOL= yes
+USE_GNOME= lthack
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LIBS=-L${PREFIX}/lib
+STARTUP_FILE= ${PREFIX}/etc/rc.d/lighttpd.sh
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
+MAN1= lighttpd.1
+
+post-install:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/lighttpd.sh.tmpl > ${STARTUP_FILE}
+ @${CHMOD} 755 ${STARTUP_FILE}
+ @${INSTALL_DATA} ${FILESDIR}/lighttpd.conf.sample ${PREFIX}/etc/
+
+.include <bsd.port.mk>