aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-10 18:01:50 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-10 18:01:50 +0000
commit6f7330c746aec675fdbefc874206ce006f9a33b6 (patch)
tree6cd3d19e5d63d422d232a4ffcb5d208339b89931 /www/lighttpd/Makefile
parent865547524265bbe14895efc65d72697f88cfa0d2 (diff)
downloadports-6f7330c746aec675fdbefc874206ce006f9a33b6.tar.gz
ports-6f7330c746aec675fdbefc874206ce006f9a33b6.zip
Notes
Diffstat (limited to 'www/lighttpd/Makefile')
-rw-r--r--www/lighttpd/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 1bfb6c2033d8..90c2743ed72f 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.4.5
+PORTVERSION= 1.4.6
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://dl.fkb.wormulon.net/lighttpd/ \
@@ -23,15 +23,15 @@ USE_RC_SUBR= lighttpd.sh
USE_LIBTOOL_VER= 15
USE_GNOME= lthack
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LIBS=-L${PREFIX}/lib
CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
MAN1= lighttpd.1 spawn-fcgi.1
-OPTIONS= OPENSSL "Enable SSL support" on \
+OPTIONS= OPENSSL "Enable SSL support" on \
OPENLDAP "Enable LDAP support" off \
MYSQL "Enable MYSQL support" off \
- IPV6 "Disable IPV6 support" off
+ IPV6 "Disable IPV6 support" off \
+ CML "Enable Cache Meta Language support" off
.include <bsd.port.pre.mk>
@@ -54,8 +54,17 @@ CONFIGURE_ARGS+= --with-mysql
CONFIGURE_ARGS+= --disable-ipv6
.endif
+.if defined(WITH_CML)
+LIB_DEPENDS+= lua.5:${PORTSDIR}/lang/lua
+CONFIGURE_ARGS+= --with-lua
+CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L/${LOCALBASE}/lib
+.endif
+
post-install:
- @${INSTALL_DATA} ${FILESDIR}/lighttpd.conf.sample ${PREFIX}/etc/
+ @${INSTALL_DATA} ${FILESDIR}/lighttpd.conf.sample ${PREFIX}/etc
+.if !exists(${PREFIX}/etc/lighttpd.conf)
+ @${INSTALL_DATA} ${FILESDIR}/lighttpd.conf.sample ${PREFIX}/etc/lighttpd.conf
+.endif
@${LIBTOOL} --finish ${PREFIX}/lib
.include <bsd.port.post.mk>