aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-07 06:50:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-07 06:50:59 +0000
commitda6a715fffa1f89d3ccd9bcd3d653539a8bb98ba (patch)
tree3310089a67f75fa0523d50b88635dabde49d90a5 /www/lighttpd/Makefile
parentb2acb8ac33db5e408ce62ce5b621d268d185a1f0 (diff)
downloadports-da6a715fffa1f89d3ccd9bcd3d653539a8bb98ba.tar.gz
ports-da6a715fffa1f89d3ccd9bcd3d653539a8bb98ba.zip
Notes
Diffstat (limited to 'www/lighttpd/Makefile')
-rw-r--r--www/lighttpd/Makefile32
1 files changed, 9 insertions, 23 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 1aabb97c4638..07fb876a3f48 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= lighttpd
PORTVERSION= 1.4.35
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= www
MASTER_SITES?= http://download.lighttpd.net/lighttpd/releases-1.4.x/
@@ -17,21 +17,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
-USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GNOME= lthack
-USES= gmake pkgconfig
-
-#.if !defined(_BUILDING_LIGHTTPD_MODULE)
-#USE_AUTOTOOLS= libtool
-#.else
-USE_AUTOTOOLS= autoconf autoheader aclocal automake libtool
-ACLOCAL_ARGS= -I m4
-AUTOMAKE_ARGS= --add-missing
-#.endif
-CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd --enable-static
-
-CFLAGS+= -I${LOCALBASE}/include
+USES= gmake libtool pkgconfig tar:bzip2
+
+USE_AUTOTOOLS= autoconf autoheader aclocal automake
+AUTOMAKE_ARGS= -a -c -f
+CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/lighttpd
+INSTALL_TARGET= install-strip
+
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.if !defined(_BUILDING_LIGHTTPD_MODULE)
@@ -203,18 +197,10 @@ post-install:
.for FILE in ${LIGHTTPD_CONF_FILES}
@${INSTALL_DATA} ${WRKSRC}/doc/config/${FILE} \
${STAGEDIR}${PREFIX}/etc/lighttpd/${FILE}.sample
-.if !exists(${STAGEDIR}${PREFIX}/etc/lighttpd/${FILE})
- @${INSTALL_DATA} ${WRKSRC}/doc/config/${FILE} \
- ${STAGEDIR}${PREFIX}/etc/lighttpd/${FILE}
-.endif
.endfor
.for FILE in ${LIGHTTPD_CONF_D_FILES}
@${INSTALL_DATA} ${WRKSRC}/doc/config/conf.d/${FILE} \
${STAGEDIR}${PREFIX}/etc/lighttpd/conf.d/${FILE}.sample
-.if !exists(${STAGEDIR}${PREFIX}/etc/lighttpd/conf.d/${FILE})
- @${INSTALL_DATA} ${WRKSRC}/doc/config/conf.d/${FILE} \
- ${STAGEDIR}${PREFIX}/etc/lighttpd/conf.d/${FILE}
-.endif
.endfor
@${INSTALL_DATA} ${WRKSRC}/doc/config/vhosts.d/vhosts.template \
${STAGEDIR}${PREFIX}/etc/lighttpd/vhosts.d/vhosts.template