aboutsummaryrefslogtreecommitdiff
path: root/www/lighttpd
diff options
context:
space:
mode:
authorDaniel Gerzo <danger@FreeBSD.org>2009-02-21 18:38:01 +0000
committerDaniel Gerzo <danger@FreeBSD.org>2009-02-21 18:38:01 +0000
commit5601cdae582a5ec523def3695777499426968103 (patch)
tree64191e13eb1135952ab39c86cade8e480069acd3 /www/lighttpd
parent2c3a185e7afbc09faca14df350434cfff7880794 (diff)
downloadports-5601cdae582a5ec523def3695777499426968103.tar.gz
ports-5601cdae582a5ec523def3695777499426968103.zip
Notes
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile2
-rw-r--r--www/lighttpd/distinfo6
-rw-r--r--www/lighttpd/files/patch-src_mod_simple_vhost.c13
3 files changed, 17 insertions, 4 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 7456e9b9f800..0598c871906b 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.4.20
+PORTVERSION= 1.4.21
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index 9cda0bf9414d..0ac00213f378 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (lighttpd-1.4.20.tar.bz2) = ed6ee0bb714f393219a32768d86984d8
-SHA256 (lighttpd-1.4.20.tar.bz2) = 3cda2ce779f24948062f765f2630b5865e483f5fab7149681a2a25422fd61176
-SIZE (lighttpd-1.4.20.tar.bz2) = 618018
+MD5 (lighttpd-1.4.21.tar.bz2) = 49eeba63c931fa82120711adc7182731
+SHA256 (lighttpd-1.4.21.tar.bz2) = 1c5f4e3643773fc5885c1fb0eb588852099ceb1f2517cf4e5e5211cc5504ebd1
+SIZE (lighttpd-1.4.21.tar.bz2) = 657787
diff --git a/www/lighttpd/files/patch-src_mod_simple_vhost.c b/www/lighttpd/files/patch-src_mod_simple_vhost.c
new file mode 100644
index 000000000000..338521a44458
--- /dev/null
+++ b/www/lighttpd/files/patch-src_mod_simple_vhost.c
@@ -0,0 +1,13 @@
+Index: src/mod_simple_vhost.c
+===================================================================
+--- src/mod_simple_vhost.c (revision 2398)
++++ src/mod_simple_vhost.c (revision 2399)
+@@ -249,6 +249,8 @@
+ return HANDLER_GO_ON;
+ } else {
+ buffer_copy_string_buffer(con->server_name, p->conf.default_host);
++ buffer_copy_string_buffer(con->physical.doc_root, p->doc_root);
++
+ /* do not cache default host */
+ return HANDLER_GO_ON;
+ }